" , P text:FFFFFFS000039FB4 LORS ll, [X6,X8] 100011001000010111100001110101 729
#-0x10+var_20]! . ‘text:FFFFFF8000039FB8 ADD X10, X10, X11,LSL#2 C 6 3 2
i text:FFFFFF8000039F)  Feuwmmoecu 0 0 ., 100011000101110100011110111010

0 text:FFFFFF8000039F8C STP X20, X19, [SP,#@x20+var_10] 2 5{ 4c fc

1101011001111
1011100101101
0101011000001
1101000101101
110001100100¢
1100011000101

100100101100
110000111010
001111011101

from 20/08/2021 to 26/08/2022 ﬂ>hex—ra)'$

Welcome to Igor’s Tip Season 2! With this edition, we are looking to build on the success of the previous one and give a
broader scope to the users of what IDA is capable of. As usual, Igor begins with some basic and advanced usage of IDA
features, and then he touches on working with types. In the next section, Igor reveals a few not-so-widely-known
functionalities that can improve your work. Much attention has been put on the Decompiler and how to get the most out
of it. In the last two sections, Igor talks briefly about automating repetitive tasks and how to customize IDA's User
Interface to suit your workflow better.

Finally, we hope you enjoy this Season 2 and follow Igor’s Tip every Friday!
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#55: Using debug symbols #97: Cross reference depth
#59: Automatic function arguments comments
#61: Status bars Decompiler: related to the Hex-Rays decompiler
#64: Full-screen mode #56: String literals in pseudocode
#65: Stack frame view #66: Decompiler annotations
#72: More string literals #67: Decompiler helpers
#74: Parameter identification and tracking (PIT) #68: Skippable instructions
#78: Auto-hidden messages #69: Split expression
#80: Bookmarks #71: Decompile as call
#81: Database notepad #76: Quick rename
#84: Array indexes #77: Mapped variables
#85: Source-level debugging #79: Handling variable reuse
#86: Function chunks #82: Decompiler options: pseudocode formatting
#88: Character operand type and stack strings #83: Decompiler options: default radix
#89: En masse operations #87: Function chunks and the decompiler
#90: Suspicious operand limits #100: Collapsing pseudocode parts
#91: Item flags #101: Decompiling variadic function calls
#92: Address details #102: Resetting-decompiler-information
#95: Offsets
#104: Inmediate search Automation: automating repetitive tasks
#63: IDA installer command-line options
Types: working with types #73: Output window and logging
#54: Shifted pointers
#57: Shifted pointers 2 Customization: customizing IDA Ul to better suit your workflow
#60: Type libraries #98: Analysis options
#62: Creating custom type libraries #103: Sharing plugins between IDA installs
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#94: Variable-sized structures
#99: Enums

Hidden: hidden gems, not widely known but useful functionality
#53: Manual switch idioms
#58: Keyboard modifiers
#70: Multiple highlights in IDA 7.7
#93: COM reverse engineering and COM Helper
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IDA supports most of the switch patterns produced by major compilers out-of-box and usually you don’t need to worry
about them. However, occasionally you may encounter a code which has been produced by an unusual or a very recent
compiler version, or some peculiarity of the code prevented IDA from recognizing the pattern, so it may become neces-
sary to help IDA and tell it about the switch so a proper function graph can be presented and decompiler can produce
nice pseudocode.

Switch pattern components
The common switch pattern is assumed to have the following components:

1. indirect jump
This is an instruction which actually performs the jump to the destination block handling the switch case; usually
involves some register holding the address value;

2. jump table
A table of values, containing either direct addresses of the destination blocks, or some other values allowing to
calculate those addresses (e.g. offsets from some base address). It has to be of a specific fixed size (number of ele-
ments) and the values may be scaled with a shift value. Some switches may use two tables, first containing indexes
into the second one with addresses.

3. input register
register containing the initial value which is being used to determine the destination block. Most commonly, it is used
to index the jump table.

Switch formula
The standard switches are assumed to use the following calculation for the destination address:

target = base +/- (table_element << shift)
base and shift can be set to zero if not used.

Example
Here’s a snippet from an ARM64 firmware.
The indirect jump is highlighted with the red rectangle. Here’s the same code in text format:

__text:FFFFFF8000039F88 STP X22, X21, [SP,#-0x10+var_20]!

sTP X22, X21, [SP,#-0x10+var_20]!

__text:FFFFFF8000039F8C STP X20, X19, [SP,#@x20+var_10] o o e e
__text:FFFFFF8000039F90 STP X29, X3@, [SP,#0x20+var_s@] ov o

BL sub_FFFFFF80000415E:
__text:FFFFFF8000039F94 ADD X29, SP, #0x20 B.H loc_FFFFFF808003A01C

MoV w20, #@

__text:FFFFFF8000039F98 MOV X19, X0 on %9, bye_FrrrrFsQscRds
__text:FFFFFF8000039F9C BL sub_FFFFFF80000415E4 o e Lo 00 e PETREREETIEE
__text:FFFFFF8000039FA® B.HI loc_FFFFFF800003A01C B yor) (R sus
__text:FFFFFF8000039FA4 MOV W20, #0 - Rer
__text:FFFFFF8000039FA8 ADR X9, byte FFFFFF8000048593

__text:FFFFFF800Q039FAC NOP

__text:FFFFFF8000039FBO ADR X10, loc_FFFFFF8000039FCe

__text:FFFFFF8000039FB4 LDRB W11, [X9,X8]

__text:FFFFFF8000039FB8 ADD X10, X1@, X11,LSL#2

_ text:FFFFFF8000039FBC BR X10

End of function sub_FFFFFF8008

We can see that the register used in the indirect branch (X10) is a result of some calculation so it is probably a switch
pattern. However, because the code was compiled with size optimization (the range check is moved into a separate func-
tion used from several places), IDA was not able to match the pattern in the automatic fashion. Let’s see if we can find
out components of the standard switch described above.

The formula matches the instruction ADD X106, X10, X11,LSL#2(in C syntax: X10 = X10+(X11<<2)). We can see that the
table element (X11) is shifted by 2 before being added to the base (X10). The value of X11 comes from the previous load
of W11 using LDRB (load byte) from the table at X9 and index X8. Thus:

1. Indirect jump: yes, the BR X10 instruction at FFFFFF8000039FBC.

2. jump table: yes, at byte_FFFFFF8000048593. Additionally, we have a base at loc_FFFFFF8000039FC0 and shift value of
2. It contains eight elements (this can be checked visually or deduced from the range check which uses 7 as the
maximum allowed value).

3. input register: yes, X8 is used to index the table (we can also use W8 which is the 32-bit part of X8 and is used by the
range check function.
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Now that we have everything, we can specify the pattern by putting the cursor on the indirect branch and invoking Edit >
Other > Specify switch idiom...

The values can be specified in C syntax (0x...) or as labels thanks to the expression evaluation' feature. Once the dialog
is confirmed, we can observe the switch nicely labeled and function graph updated to include newly reachable nodes.

We can also use “List cross-references from...” (Ctr1-J) to see the list of targets from the indirect jump.

Additional options
Our example was pretty straightforward but in some cases you can make use of the additional options in the dialog.

1. separate value table is present: when a two-level table is used, i.e.:

table_element = jump_table[value_table[input_register]]; instead of the default table_element = jump_table[in-
put_register];

2. signed jump table elements: when table elements are loaded using a sign-extension instruction, for example LDRSB or
LDRSW on ARM or movsx on x86.

3. Subtract table elements: if the values are subtracted from the base instead of being added (minus sign is used in the
formula).

4. Table element is insn: the “jump table” contains instructions instead of data values. This is used in some architec-
tures which can perform relative jumps using a delta value from the instruction pointer. For example, the legacy ARM
jumps using direct PC manipulation:
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CcMp R3, #7 ; SWITCH ; switch 8 cases
ADDLS PC, PC, R3,LSL#2 ; switch jump

; ...........................................................................

loc_6684 ; CODE XREF: _ pthread_manager+1BCtj
B def_6680 ; jumptable 00006680 default case, c

; ...........................................................................

loc_6688 ; CODE XREF: _ pthread_manager+1BCtj
B loc_66A8 ; jumptable 00006680 case @

; ...........................................................................

loc_668C ; CODE XREF: _ pthread_manager+1BC?j
B loc_6854 ; jumptable 00006680 case 1

; ...........................................................................

loc_6690 ; CODE XREF: _ pthread_manager+1BC?j
B loc_68CC ; jumptable 00006680 case 2

; ...........................................................................

loc_6694 ; CODE XREF: __ pthread_manager+1BCtj
B loc_695C ; jumptable 00006680 case 3

; ...........................................................................

loc_6698 ; CODE XREF: _ pthread_manager+1BCtj
B loc_6990 ; jumptable 00006680 case 4

; ...........................................................................

loc_669C ; CODE XREF: _ pthread_manager+1BCtj
B loc_69FC ; jumptable 00006680 case 5

; ...........................................................................

loc_66A0 ; CODE XREF: _ pthread_manager+1BC?j
B def_6680 ; jumptable 00006680 default case, c

; ...........................................................................

loc_66A4 ; CODE XREF: __ pthread_manager+1BCtj
B loc_699C ; jumptable 00006680 case 7

Usually in such situation the table “elements” are fixed-size branches to the actual destinations.

Optional values
Some values can be omitted by default but you may also fill them for a more complete mapping to the original code:

1. Input register of switch: can be omitted if you only need cross-references for the proper function flow graph but it has
to be specified if you want decompiler to properly parse and represent the switch.

2. First(lowest) input value: the value of the input register corresponding to the entry O of the jump table. In the example
above, we can see that the range check calculates W8 = W1 - 1, so we could specify lowest value of 1 (this would also
update the comments at the destination addresses to be 1to 8 instead of O to 7).

3. default jump address: the address executed when the input range check fails (in our example — destination of the
B.HI instruction). Can make the listing and/or decompilation a little more neat but is not strictly required otherwise.

For even more detailed info about supported switch patterns, see the and the uiswitch plugin
source code in the SDK. If you encounter a switch which cannot be handled by the standard formula, you can also look
into writing a

"https://hex-rays.com/blog/igors-tip-of-the-week-21-calculator-and-expression-evaluation-feature-in-ida/
2 https://hex-rays.com/products/ida/support/sdkdoc/structswitch__info__t.html
3 https://hex-rays.com/blog/jump-tables/
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we briefly mentioned shifted pointers but without details. What are they?

Shifted pointers is another custom extension to the C syntax. They are used by IDA and decompiler to represent a
pointer to an object with some offset or adjustment (positive or negative). Let’s see how they work and several situations
where they can be useful.

Shifted pointer description and syntax
A shifted pointer is a regular pointer with additional information about the name of the parent structure and the offset
from its beginning. For example, consider this structure:

struct mystruct

{
char buf[16];

int dummy;
int value; // <- myptr points here
double fval;

b
And this pointer declaration:

int *__shifted(mystruct,20) myptr;
It means that myptr is a pointer to int and if we decrement it by 20 bytes, we end up with mystruct*.

In fact, the offset value is not limited to the containing structure and can even be negative. Also, the “parent” type does
not have to be a structure but can be any type except void. This can be useful in some situations.

Whenever a shifted pointer is used with an adjustment, it will be displayed using the ADJ helper, a pseudo-operator
which returns the pointer to the parent type (in our case mystruct). For example, if the pointer is dereferenced after add-
ing 4 bytes, it can be represented like this:

ADJ(myptr)->fval

Optimized loop on array of structures

When compiling code which is processing an array of structures, a compiler may optimize the loop so that the “current
item” pointer points into a middle of the structure instead of the beginning. This is especially common when only a small
subset of fields are being accessed. Consider this example:

struct mydata

{

int a, b, c;
void *pad[2];
int d, e, f;
char path[260];

}s
int sum_c_d(struct mydata *arr, int count)
{

int sum=0;

for (int i=0; i< count; i++)

{

sum+=arr[i].d+arr[i].c*43;

}

return sum;
}

When compiled with Microsoft Visual C++ x886, it can produce the following code:
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?sum_c_d@@YAHPAUmydata@@H@Z proc near

arg_0 = dword ptr 4
arg_4 = dword ptr 8

mov edx, [esp+arg_ 4]
push esi
xor esi, esi

test edx, edx
jle short loc_25

mov eax, [esp+4+arg_0]
add eax, 14h
loc_12: ; CODE XREF: sum_c_d(mydata *,int)+23!j
imul ecx, [eax-@Ch], 2Bh ; ‘+’
add ecx, [eax]
lea eax, [eax+124h]
add esi, ecx
sub edx, 1
jnz short loc_12
loc_25: ; CODE XREF: sum_c_d(mydata *,int)+91j
mov eax, esi
pop esi
retn

And initial decompilation looks quite strange even after adding and specifying the correct types:

int _ cdecl sum_c_d(struct mydata *arr, int count)
{

int v2; // edx

int v3; // esi

int *p_d; // eax

int v5; // ecx

v2 = count;
v3 = 0;
if ( count <=0 )
return v3;
p_d = &arr->d;
do
{
v5 = *p d + 43 * *(p_d - 3);
p_d += 73;
v3 += V5;
--v2;
}
while ( v2 );
return v3;

}

Apparently, the compiler decided to use the pointer to the d field and accesses c relative to it. How can we make this
look nicer?

We can find out the offset at which d is situated in the structure via manual calculation, by inspecting disassembly, or by
hovering the mouse over it in pseudocode.

if ( count <= 8 )
return v3;

p d = &ahh—>dﬂ

do

{ off=0x14; int

v5 = ¥p d + 43 * *¥(p d - 3);
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Thus, we can change the type of p_d to int * __shifted(mydata, @x14) to get improved pseudocode:

int __cdecl sum_c_d(struct mydata *arr, int count)
{

int v2; // edx

int v3; // esi

int *__shifted(mydata,ox14) p_d; // eax

int v5; // ecx

v2 = count;

v3 = 0;

if ( count <=0 )
return v3;

p_d = &arr->d;

do

{
v5 = ADJ(p_d)->d + 43 * ADI(p_d)->c;
p_d += 73;
v3 += V5;
--v2;

while ( v2 );
return v3;

}

Prepended metadata

This technique is used in situations where a raw block of memory needs to have some management info attached to it,

i.e. heap allocators, managed strings and so on.

As a specific example, let’s consider the classic MFC 4.x CString class. It uses a structure placed before the actual
character array:

struct CStringData

{
long nRefs; // reference count
int  nDatalLength; // length of data (including terminator)
int  nAllocLength; // length of allocation
// TCHAR data[nAllocLength]
TCHAR* data() // TCHAR* to managed data
{
return (TCHAR*)(this+1);
}
}s

The CString class itself has just one data member:

class CString
{
public:
// Constructors
[...skipped]
private:
LPTSTR  m_pchData; // pointer to ref counted string data

// implementation helpers
CStringData* GetData() const;
[...skipped]
}s
inline
CStringData*
CString: :GetData(
) const
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ASSERT(m_pchData != NULL);
return ((CStringData*)m_pchData)-1;
}

Here’s how it looks in memory:

nRefs

CStringData nDatalength

nAllocLength

)HJ})e),J]-J,JlJ’JOJ’G

R

CString |m_pchData

Here’s how the CString’s destructor looks like in initial decompilation:

void __ thiscall CString::~CString(CString *this)

{
if ( *(_DWORD *)this - (_DWORD)off_4635E@ != 12 && InterlockedDecrement((volatile LONG *)(*(_DWORD *)this
- 12)) <=0 )
operator delete((void *)(*(_DWORD *)this - 12));
}

Even after creating a CString structure with a single member char *m_pszData it’s still somewhat confusing:

void _ thiscall CString::~CString(CString *this)

{
if ( this->m_pszData - (char *)off_4635E0 != 12 && InterlockedDecrement((volatile LONG *)this->m_pszData
-3)<=0)
operator delete(this->m_pszData - 12);
}

Finally, if we create the CStringData struct as described above and change the type of the CString member to: char
* _shifted(CStringData,0xC) m_pszData:

void __thiscall CString::~CString(CString *this)
{
if ( ADJ(this->m_pszData)->data - (char *)off_4635E0 != 12 && InterlockedDecrement(&ADJ(this->m_psz-
Data)->nRefs) <= 0 )
operator delete(ADJ(this->m_pszData));
}

Now the code is more understandable: if the decremented reference count becomes zero, the CStringDatainstance is
deleted.

More info: TDA Help: Shifted pointers?

"https://hex-rays.com/blog/igors-tip-of-the-week-52-special-attributes/t
2 https://hex-rays.com/products/ida/support/idadoc/1695.shtml
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IDA supports many file formats, among them the main ones used on the three major operating systems:

¢ PE (Portable Executable) on Windows;
¢ ELF (Executable and Linkable Format) on Linux;
¢ Mach-O (Mach object) on macOS.

Symbols and debugging information

Symbols associate locations inside the file (e.g. addresses of functions or variables) with textual names (usually the
names used in the original source code). The part of the file storing this association is commonly called symbol table.
Symbols can be stored in the file itself or separately.

Traditionally, the PE files do not contain any symbols besides those that are required for imports or exports for in-
ter-module linking. ELF and Mach-O commonly do keep names for global functions, however most of this information
can be removed, or stripped, without affecting execution of the file. Because such information is very valuable for possi-
ble debugging later, it can be stored in a separate debug information file.

For PE files, a common debug format is PDB (Program Database), although other formats were used in the past, for
example TDS (Turbo Debugger Symbols) was used by Borland compilers, and DBG in legacy versions of Visual Stu-
dio. Both ELF and Mach-O use . All of the above can contain not only plain symbols but also types (structures,
enums, typedefs), function prototypes, information on local variables as well as mapping of binary code to source files
(filenames and line numbers).

Although originally intended to improve debugging experience, all this information obviously makes the reverse engineer-
ing process much easier, so IDA supports these formats out of box, using standard plugins shipped with IDA:

¢ pdb for PDB;

e tds for TDS;

e dbg for DBG;

e dwarf for DWARF.

Automatic debug info loading

Standard file loaders detect when the file has been built with debug information and invoke the corresponding debug
info loader. If debug info is found in the input file, next to it, or in another well-known location, the user is prompted
whether to load it.

Manual debug info loading
If the separate debug info file is not present in standard location or discovered later, after you've already loaded the file,
it can be loaded manually. Currently only PDB and DWARF can be loaded using this option.

e For PDB, use File > Load file > PDB File...
¢ For DWARF, Edit > Plugins > Load DWARF File
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For the PDB loader, you can specify a DLL or EXE file instead of the PDB; in that case IDA will try to find and load a
matching PDB for it, including downloading it from symbol servers if necessary. By using the “Types only” option, you
can import types from an arbitrary PDB and not necessarily PDB for the current file. For example, PDB for the Windows
kernel (ntoskrnl.exe) contains various structures used in kernel-mode code (drivers etc.) so this feature can be useful
when reverse-engineering files without available debug info.

Example: Linux kernel debug info
Linux kernels are usually stripped during build, however many distros provide separate debug info repositories?, or you
can recompile the kernel with debug info® How to load it into IDA?

For self-built kernel it’s pretty simple — the vmlinuxfile is a normal ELF which can be simply loaded into IDA. However,
the pre-built kernels are usually distributed as vmlinuz which is a PE file (so that it can be booted directly by the UEFI
firmware), with the actual kernel code stored as compressed payload inside it. The unpacked kernel can be extracted
manually* or using the vmlinux-to-elf project, loaded into IDA, and the external debuginfo file can then be loaded via Edit
> Plugins > Load DWARF File, producing a nice database with all kernel types and proper function prototypes.

"https://en.wikipedia.org/wiki/DWARF

2http://ddebs.ubuntu.com/pool/main/I/linux/
3https://wiki.ubuntu.com/Kernel/Systemtap#How_do_|_build_a_debuginfo_kernel_if_one_isn.27t_available.3F
“https://stackoverflow.com/questions/12002315/extract-vmlinux-from-vmlinuz-or-bzimage

5 https://github.com/marin-m/vmlinux-to-elf
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Strings in binaries are very useful for the reverse engineer: they often contain messages shown to the user, or some-
times even internal debugging information (function or variable names) and so having them displayed in the decompiled
code is very helpful.

However, sometimes you may see named variables in pseudocode even though the disassembly shows the string nicely.
Why does this happen and how to fix it?

Memory access permissions

When deciding whether to display a string literal inline, the main criteria are attributes of the memory area it resides in.
If the memory is writable, it means that the string is not really constant but may change, so displaying a variable name is
more correct. For example, here’s the default pseudocode of a function from a decompressed Linux kernel:

We can see a string literal is displayed as a variable name (aApicIcrReadRet) even though it is a nice-looking string in the
disassembly. The mystery can be cleared up if we jump to its definition (e.g. by double-clicking) and inspect the segment
properties (Edit > Segment > Edit Segment..., or A1t - S). We can see that the segment is marked as writable:

Why does .rodata (“read-only data”) have write permissions? We can’t say for sure, but the section does include this
flag in the ELF headers:

(readelf output)

Section Headers:

[Nr] Name Type Address Offset
Size EntSize Flags Link 1Info Align

[ o] NULL 0000000000000000 0000940
0000000000000000 000000V 0 0 0

[ 1] .text PROGBITS ffffffffs1000000 ©0001000
0000000000628281 000000000V AX 0 0 4096

[ 2] .notes NOTE ffffffff81628284 00629284
0000000000000204 0000000V AX 0 0 4

[ 3] __ex_table PROGBITS ffffffff81628490 00629488
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0000000000002cdc  0000000000000000 A 0 0 4
[ 4] .rodata PROGBITS fffffff81800000 ©062d000
0000000000275332 0000000000000000 WA 0 0 4096

<...skipped...>

Key to Flags:
W (write), A (alloc), X (execute), M (merge), S (strings), I (info),
L (link order), O (extra OS processing required), G (group), T (TLS),
C (compressed), x (unknown), o (OS specific), E (exclude),
1 (large), p (processor specific)

One possibility is that it is made actually read-only later in the boot process.

So one solution for our problem is to make sure that the segment has only Read (and possibly Execute) permissions but
not Write. If you do that, the string literals from that segment will be displayed inline:

Override access permissions

While changing segment attributes works, it may not be suitable for all cases. For example, some compilers can put
string constants in the same section as other writable data, so if you change the segment permissions to read-only,

the decompiler could produce wrong output for functions using the writable variables. You may also have an opposite
situation: a string constant is not actually constant but simply has a default value, so it needs to be marked as variable. In
such cases, you can override the attributes of each string variable using const or volatile type attributes. For example,
instead of changing the whole segment’s permission, you could edit the type of the aApicIcrReadRet variable by pressing
Y (change type) and changing its type to const char aApicIcrReadRet[].

With this option, only the edited strings literals will be shown inline and others remain as variables.

seq_puts(p, | AFIC ICR read r‘etr“les\n"P;
if ( x86_platform_ipi_callback )

{
vlid = -1;
seq_printf(p, "%*s: ", prec, );
while ( 1 )
{
v15 = find_next_bit(_cpu_online_mask.bits, ©x200ullL, vi4 + 1);
vl4d = v15;
if ( v15 >= (int)nr_cpu_ids )
break;
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Show all string literals

Yet another possibility is to rely on IDA’s analysis of disassembly and
show all strings marked as string literals on the disassembly level. This
can be done in the decompiler options ( Edit > Plugins > Hex-Rays
Decompiler, Options, Analysis Options 1) by turning off “Print only
constant string literals” option.

To change this option for all future databases, see the HO_CONST_
STRINGS option in hexrays.cfg.

For more info see the decompiler manual:

o Tips and tricks: Constant memory?
o Configuration?

1 https://hex-rays.com/products/decompiler/manual/tricks.shtml#02
2 https://hex-rays.com/products/decompiler/manual/config.shtml
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This week we’ll cover another situation where shifted pointers' can be useful.

Intrusive linked lists

This approach is used in many linked list implementations. Let’s consider the one used in the Linux kernel. 1ist.h defines

the linked list structure:

struct list_head {
struct list_head *next, *prev;

}s

As an example of its use, consider the struct module from module.h:

struct module {
enum module_state state;

/* Member of list of modules */
struct list_head list;

/* Unique handle for this module */
char name[MODULE_NAME_LEN];

[..skipped..]
} cacheline_aligned _ randomize_layout;

Where struct 1ist_head list; is used to link the instances of struct module together. Because the next and prev point-
ers do not point to the start of struct module, some pointer math is required to access its fields. For this, various macros

in list.h are used:

/**
* list_entry - get the struct for this entry
* @ptr: the &struct list_head pointer.
* @type: the type of the struct this is embedded in.
* @member: the name of the list_head within the struct.
*/
#define list entry(ptr, type, member) \
container of(ptr, type, member)
/**
* list_first_entry - get the first element from a list
* @ptr: the list head to take the element from.
* @type: the type of the struct this is embedded in.
* @member: the name of the list_head within the struct.
*
* Note, that list is expected to be not empty.
*/
#define list first entry(ptr, type, member) \
list_entry((ptr)->next, type, member)
/**
* list_last_entry - get the last element from a list
* @ptr: the list head to take the element from.
* @type: the type of the struct this is embedded in.
* @member: the name of the list_head within the struct.
*
* Note, that list is expected to be not empty.
*/
#define list last entry(ptr, type, member) \
list_entry((ptr)->prev, type, member)

Let’s look at some functions from module.c. For example, m_show():
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static int m_show(struct seq_file *m, void *p)

{
struct module *mod = list_entry(p, struct module, list);
char buf[MODULE_FLAGS_BUF_SIZE];
void *value;

/* We always ignore unformed modules. */
if (mod->state == MODULE_STATE_UNFORMED)
return ©;

seq_printf(m, “%s %u”,
mod->name, mod->init_layout.size + mod->core_layout.size);
print_unload_info(m, mod);

/* Informative for users. */

seq_printf(m, “ %s”,
mod->state == MODULE_STATE_GOING ? “Unloading” :
mod->state == MODULE_STATE_COMING ? “Loading” :
“Live”);

/* Used by oprofile and other similar tools. */

value = m->private ? NULL : mod->core_layout.base;

seq_printf(m, “ °x%px”, value);

/* Taints info */
if (mod->taints)
seq_printf(m, “ %s”, module_flags(mod, buf));

seq_puts(m, “\n”);
return ©;

}

Although the function accepts a void * p, from the code we can see that it actually points to the list entry for the module
at offset 8.

The initial decompilation looks like follows:
int _ fastcall m_show(seq_file *m, void *p}
{
J// [COLLAPSED LOCAL DECLARATIONS. PRESS KEYPAD CTRL-"+" TO EXPAND]

_fentry__ (m);

vE =  readgsqword(@x28u);
if ( *({_DWORD *)p - 2) == 3 )
return @;

seq_printf(m, "%s %u", (const char *)p + 16, (unsigned int){*({_DWORD *)p + 116}
seq_printf(m, " %i ", (unsigned int)(*((_DWORD *)p + 192) - 1});
v2 = (_QWORD *)*(( QWORD *)p + 91);
if ( (char *)p + 728 != (char *)v2 )
1
do
{
seq_printf(m, "%s,", (const char *}{v2[4] + 24LL));
v2 = (_QWORD *})*v2;
while ( v2 != (_QWORD *)((char *)p + 728) );
if ( PR((_QWORD *)p + 42) || *((_QWORD *)p + 95) )
goto LABEL_7;
goto LABEL_6;

H
if ( *((_QWORD *)p + 42) 8& !*((_QWORD *)p + 95) )
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Not very readable, is it? But since we know that p actually points to 1ist inside struct module, we can use a shifted
pointer instead:

int _ fastcall m_show(seq_file *m, struct list_head *_ shifted(module,8) p)

{
// [COLLAPSED LOCAL DECLARATIONS. PRESS KEYPAD CTRL-"+" TO EXPAND]

_fentry__ (m);
vE = _ readgsqword(8x28u);
if ( ADI()->state == MODULE_STATE_UNFORMED )
return @;
seg_printf(m, "%s %u", ADI(p)->name, ADI(p)->init layout.size + ADI(p)->c
seg_printf(m, " %i ", (unsigned int)(ADI(p)->refcnt.counter - 1));
next = ADJ(p)->source_list.next;
if ( &ADI(p)->source list != next )

{
do

{
seg_printf(m, "%s,", (const char *)&next[2].next[1].prev);

next = next->next;

while ( next != &ADI(p)->source_list );

if ( 1ADI(p)->init || ADI(p)-dexit )
goto LABEL_7;

goto LABEL_6;

h
if ( ADI(p)->init &8 !'ADI(p)-»exit )

This is already much better. The ugly expression with the next variable is caused by the fact that source_list actually
stores instances of struct module_use so by changing the variable’s type we can improve the output again:

use]l = (module use *)ADI(p)->source list.next;
if ( &ADI(p)->source_list != (list _head *)use )
{ hodule_use *use; f/ rbx
do
i
seq_printf(m, "%s,", use->source->name);
use = (module _use *)use->source_list.next;
¥
while ( use != (module use *}&ADI(p)->source_list );
if ( 1aDI(p)-»init || ADI(p)->exit )
goto LABEL_7;
goto LABEL_6;

Creating shifted pointers for structures
Although shifted pointers are not limited to structure members, it is the most common use case, and thus we implement-

ed a Ul feature to make their creation easier.




17Sep2021
& https://hex-rays.com/blog/igors-tip-of-the-week-57-shifted-pointers-2/

In the decompiler, untyped variables and void pointers have a context menu item “Convert to struct *...”. When invoked,
the dialog shows a list of structures (and unions) available in the local type library so you can easily create a pointer to it
without typing manually. But in addition to simple struct pointers, you can create a shifted pointer by entering a non-zero
delta value in the “Pointer shift value” field.

Because the original pointer had type void *, the shifted pointer retained it, so you may need to change the final type to
get proper decompilation (in our example, struct list_head *__shifted(module,8) p).

If you want to practice this, here’s the 7.6 IDB with the function described: vmlinux_trimmed.elf.i642, To save space, it’'s
been trimmed to only include the function in question and its direct dependencies. To get the full kernel with symbols,
see the post on DWARF info loading®.

list_entry https://elixir.oootlin.com/linux/latest/C/ident/list_entry
list_first_entry https://elixir.bootlin.com/linux/latest/C/ident/list_first_entry
list_last_entry https://elixir.bootlin.com/linux/latest/C/ident/list_last_entry
member https://elixir.oootlin.com/linux/latest/C/ident/member

container_of https://elixir.bootlin.com/linux/latest/C/ident/container_of

1 https://hex-rays.com/blog/igors-tip-of-the-week-54-shifted-pointers/
2 https://hex-rays.com/wp-content/uploads/2021/09/vmlinux_trimmed.elf_.i64.zip
3 https://hex-rays.com/blog/igors-tip-of-the-week-57-shifted-pointers-2/
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Today we'll cover how keyboard modifiers (Ctrl, Alt, Shift) can be used with some IDA actions to modify their behavior
or provide additional functionality.

Modifiers in shortcuts

Obviously, some shortcuts already include modifiers as part of their key sequence, but some commonalities may be not
immediately obvious. For example, the Search menu commands tend to use Alt-letter to start search and corresponding
Ctrl-letter to continue the search:

A somewhat similar situation exists with data formatting shortcuts: same as D defines byte/word/dword items and A1t-D
is used for extra item types and configuration, A creates a default string literal type while A1t-A handles additional ones
and configuration.

Modifiers and the mouse
In some situations modifiers also change how mouse operations are interpreted:

¢ In the text IDA View, holding Ctrl while double-clicking a label or address opens the target in a new tab.

¢ Holding ctrl or Shift while using the mouse wheel scrolls text tpage (like Pgbn/PgUp). This also resizes hint popups!
faster.

e Inthe graph view?, ctrl + wheel zooms the graph, while Alt + wheel scrolls horizontally (you can also use two-finger
panning on trackpads).

e Ctrl + wheel also zooms in the navigation band?®,

Miscellaneous
¢ if one of the recent file entries in the File menu is selected while shift key is held down, the file is opened in a new
IDA instance.
e Windows only: if Shift key is held down while clicking the close window (X) corner button, IDA closes without confir-
mation with default exit options (save the database). If Ctrl is also held down, IDA exits without saving.

1 https://hex-rays.com/blog/igors-tip-of-the-week-47-hints-in-ida/
2 https://hex-rays.com/blog/igors-tip-of-the-week-23-graph-view/
3 https://hex-rays.com/blog/igors-tip-of-the-week-49-navigation-band/
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You may have observed that IDA knows about standard APIs or library functions and adds automatic function comments
for the arguments passed to them.

For example, here’s a fragment of disassembly with commented arguments to Win32 APIs CreateFileW and ReadFile:

This works well when functions are imported in a standard way and are known at load time. However, there may be
cases when the actual function is only known after analysis (e.g. imported dynamically using GetProcAddress or using a
name hash). In that case, there may be only a call to some dummy name and no commented arguments:

You can of course add a comment that dword_4031A5 is CreateFileA, and comment arguments manually, but this can be
quite tedious. Is there a way to do it automatically?

In fact, it is sufficient to simply rename the pointer variable to the corresponding APl name for IDA to pick up the proto-
type and comment the arguments:

A few notes about this feature:

1. The function prototype must be present in one of the loaded type librar-
ies;

2. The comments are added only for code inside a function, so you may
need to create one around the call (e.g. in case of decrypted or decom-
pressed code);

3. if the function is called in many places, it may take a few seconds for
IDA to analyze and comment all call sites.
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Type libraries are collections of high-level type information for selected platforms and compilers which can be used by
IDA and the decompiler.

A type library may contain:
1. function prototypes, e.g.:

void *__cdecl memcpy(void *, const void *Src, size_t Size);
BOOL __ stdcall EnumWindows(WNDENUMPROC lpEnumFunc, LPARAM 1lParam);

2. typedefs, e.g.:

typedef unsigned long DWORD;
BOOL (__stdcall *WNDENUMPROC)(HWND, LPARAM);

3. standard structure and enum definitions, e.g.:

struct tagPOINT
{
LONG Xx;
LONG y;
b
enum tagSCRIPTGCTYPE
{
SCRIPTGCTYPE_NORMAL = 0x0,
SCRIPTGCTYPE_EXHAUSTIVE = ox1,

¥
4. Synthetic enums created from groups of preprocessor definitions (macros):

enum MACRO_WM
{
WM_NULL = exe,
WM_CREATE = ox1,
WM _DESTROY = @x2,
WM_MOVE = ©x3,
WM_SIZEWAIT = 0x4,
WM _SIZE = x5,
WM_ACTIVATE = 0x6,
WM_SETFOCUS = @x7,
WM_KILLFOCUS = ©x8,
WM_SETVISIBLE = @x9,
[...]
};

Manipulating type libraries

The list of currently loaded type libraries is available in the Type Libraries view (View > Open subiews > Type Libraries,
or Shift-F11).

Additional libraries can be loaded using “Load type library...” context menu item or the Ins hotkey.
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Once loaded, definitions from the type library can be used in IDA and the decompiler: you can use them in function pro-
totypes and global variable types ( Y hotkey), as well as when adding new definitions in Local Types'.

Importing types into IDB

While the decompiler can use types from loaded type libraries without extra work, to use them in the disassembly some
additional action may be necessary. For example, to use a standard structure or enum, it has to be added to the list in
the corresponding view first:

1. Open the Structures (Shift- F9) or Enums (Shift- F10) window;
2. Select “Add struct type..” or “Add enum” from the context menu, or use the hotkey (Ins);
3. If you know the struct/enum name, enter it in the name field and click OK;

4. If you don’t know or remember the exact name, click “Add standard structure” (“Add standard enum”) and select the
struct or enum from the list of all corresponding types in the loaded type libraries. As with all choosers?, you can use
incremental search or filtering (Ctr1-F).
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After importing, the structure or enum can be used in the disassembly view.

cmp
jnz
xor

call
test
jnz
mowv
Jmp

Function prototypes

short loc_14801D44B

word ptr [rcx+POINT.x], rldw
short loc_14001D428
eax, eax 88888888 ; --------------------oooooo oo
loc_14881D5A5 20000000
————————————————————————— 66000000 POINT struc ; (sizeof=@x8,
08000008
; CODE |@ooooBee
?TranslateString@@YAXPEOOOE0E0O = dd ?
ebx, ebx 660006880
short loc_148@1D439 00000004 v dd ?
edi, cs:?dyTop@@3HA ; iPEEEEOA4

When a type library is loaded, functions with name matching the prototypes present in the library will have their proto-
types applied in the database. Alternatively, you can rename functions after loading the library, like we described last

week3.

1 https://hex-rays.com/blog/igors-tip-of-the-week-36-working-with-list-views-in-ida/
2 https://hex-rays.com/blog/igors-tip-of-the-week-36-working-with-list-views-in-ida/
3 https://hex-rays.com/blog/igors-tip-of-the-week-59-automatic-function-arguments-comments/
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Many of IDA’'s windows have status bars and they contain useful information and functionality which may not be always
obvious.

Main window status bar
The status bar at the bottom of IDA’s main window contains:

1. Autoanalysis progress indicator. See |DA Help: Analysis options! for possible values you may see there.
2. Search direction indicator for “Next search” commands? (Ctrl+Letter).
3. Free disk space.

~  Analysis indicator

Reanalyze program
Python |

—

Processor analysis options...

-
All:™ idle Down = D:i.s]?: 22GB

It also has a context menu offering quick access to analysis and processor-specific options (if supported by current
processor module).

Disassembly view status bar
Each disassembly (IDA View) windows has a separate status bar too. In the text mode it contains:

1. offset in the input file (for addresses which can be mapped directly to the input file);

2. address on the current cursor position

3. symbolic location (if available). for locations inside functions, a function name and offset from its start is printed;
4. synchronization status.

000070€E 0000000000407CEE: _ alloca probe+3E (Synchronized with Hex View-1)

< 2 - -

Same status bar style is also used for Hex View and Pseudocode windows.

In the Graph mode?, additional graph-related information is displayed (zoom level, mouse position etc.).

Chooser (list view) status bar
List views™ status bars by default display the current index and total number of items in the list

However, when using incremental search (type the first letters of the item to jump to the matching item), the typed letters
replace it.

1 https://hex-rays.com/products/ida/support/idadoc/620.shtml

2 https://hex-rays.com/blog/igors-tip-of-the-week-58-keyboard-modifiers/
3 https://hex-rays.com/blog/igors-tip-of-the-week-23-graph-view/

4 https://hex-rays.com/blog/igors-tip-of-the-week-28-functions-list/
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Previously we’ve talked about shipped with IDA, but what can be done when dealing with uncommon
or custom APIs or SDKs not covered by them?

In such situation it is possible to use the tilib utility available for IDA Pro users from our

Creating type libraries
tilib is a powerful command-line utility and the full list of options may look somewhat scary.

Type Information Library Utility v1.227 Copyright (c) 2000-2021 Hex-Rays
usage: tilib [-sw] til-file

-C create til-file -t... set til-file title

-h... parse .h file -pP C++ mode (not ready yet)
-D... define a symbol -I... list of include dirs

-M... create macro defs file -X external display types

-i internal display types -z debug .h file parsing (use it!)
-B... dump bad macro defs -q internal check: unpack types
-C... compiler info(-C? help) -G... mangling format (n=org.name)
-m... parse macro defs file -S strip macro table

-dt... delete type definition -rtX:Y rename type X as Y

-ds... delete symbol definition -rsX:Y rename symbol X as Y

-b... wuse base til -0... directory with til files

-1[1csxf] show til-file contents; 1-with decorated names, c-as c code
s-dump struct layout, x-exercise udt serialization, f-dump funcarg locations

-v verbose -e ignore errors

-R allow redeclarations -n ignore til macro table

-u+ uncompress til-file -u- compress til-tile

-u set ‘universal til’ bit -em suppress macro creation errors
-# enable ordinal types -#- disable ordinal types

-p... load types from PDB (Win32) -TL lower existing type

-TAL  assume low level types -TH keep high types

-g[nb]X:Y move macro X (regex) to group Y; n-name, b-body

@... response file with switches

example: tilib -c -Ccl -hstdio.h stdio.til
However, as mentioned at the botttom, the basic usage can be quite simple:
tilib -c¢ -Ccl -hstdio.h stdio.til
This creates a type library stdio.til by parsing the header file stdio.h as a Visual C++ compiler.

Advanced options
The sample commandline might work in simple cases (e.g. a single, self-contained header) but with real life SDKs you will
likely run into problems quickly. To handle them, additional options may be necessary:

1. Include directories for headers from #include directives: -I<directory> (can be specified multiple times);
2. preprocessor defines: -Dname[=value];

Instead of using -D on command line, you can also create a new header with #define statements and include other head-
ers from it.

Response files
To avoid specifying the same options again and again, you can use response files. These files contain one command line
option per line and can be passed to tilib using the @ option:
tilib @vc32.cfg -c -hinput.h output.til
There are sample response files shipped with the tilib package for Visual C++ (32- and 64-bit), GCC and Borland C++.

Examining type libraries
You can dump the contents of a til file using the -1 switch:

tilib -1 mylib.til
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Using created type libraries in IDA

To make the custom type library available in IDA, copy it in the til/<processor> subdirectory of IDA. For example, librar-
ies for x86/x64 files should go under til/pc. After this, the new library should appear in the list shown when you invoke
the “Load type library” command.

Advanced example
One of our users made a very nice write-up on generating a type library for Apache modules. Please find it here: https://
github.com/trou/apache-module-ida-til.

See also readme.txt in the tilib package for advanced usage such as creating enums from groups of preprocessor macro
definitions.

1 https://hex-rays.com/blog/igors-tip-of-the-week-60-type-libraries/
2 https://hex-rays.com/download-center/
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Most users probably run IDA installers in standard, interactive mode. However, they also can be run in unattended mode

(e.g. for automatic, non-interactive installation).

Available options

To get the list of available options, run the installer with the --help argument. For example, here’s the list on Linux:

igor@/home/igor$ ./idapronl[...].run --help
IDA Pro and Hex-Rays Decompilers (x86, x64,

Usage:
--help
--version

--unattendedmodeui <unattendedmodeui>

ARM, ARM64, PPC, PPC64, MIPS) 7.6 7.6

Display the list of valid options

Display product information

Unattended Mode UI

Default: none
Allowed: none minimal minimalWithDialogs

--optionfile <optionfile> Installation option file

--debuglevel <debuglevel>

--mode <mode>

--debugtrace <debugtrace>

--installer-language <installer-language>

Default:

Debug information level of verbosity
Default: 2
Allowed: 012 3 4

Installation mode
Default: gtk
Allowed: gtk xwindow text unattended

Debug filename
Default:

Language selection
Default: en
Allowed: sq ar es_AR az eu pt_BR bg ca hr cs da nl en et fi fr

de el he hu id it ja kk ko 1lv 1t no fa pl pt ro ru sr zh_CN sk sl es sv th zh_TW tr tk uk va vi cy

--prefix <prefix>

--python_version <python_version>

--installpassword <installpassword>

Installation Directory
Default: /home/igor/idapro-7.6

IDAPython Version
Default: 3
Allowed: 2 3

Installation password
Default:

For example, to run the installer in text (console) instead of GUI mode, specify --mode text.

On Windows, the set of options is slightly

IDA Pro and Hex-Rays Decompilers (x86, x64,

Usage:
--help
--version

--unattendedmodeui <unattendedmodeui>

--optionfile <optionfile>

different (and is shown in a GUI dialog instead of console):

ARM, ARM64, PPC, PPC64, MIPS) 7.6 7.6

Display the list of valid options
Display product information
Unattended Mode UI

Default: none

Allowed: none minimal minimalWithDialogs

Installation option file
Default:
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--debuglevel <debuglevel> Debug information level of verbosity
Default: 2
Allowed: © 1 2 3 4

--mode <mode> Installation mode
Default: win32
Allowed: win32 unattended

--debugtrace <debugtrace> Debug filename
Default:

--installer-language <installer-language> Language selection
Default: en
Allowed: sq ar es_AR az eu pt_BR bg ca hr cs da nl en et fi fr
de el he hu id it ja kk ko 1lv 1t no fa pl pt ro ru sr zh_CN sk sl es sv th zh_TW tr tk uk va vi cy

--prefix <prefix> Installation Directory
Default: C:\Program Files/idapro-7.6

--python_version <python_version> IDAPython Version
Default: 3
Allowed: 2 3

--installpassword <installpassword> Installation password
Default:

--install_python <install_python> Install Python 3
Default:

In partcular, --install_python option allows to enable installation of the bundled Python 3 (useful for machines without
Python preinstalled). On Linux and Mac, the system-wide Python is presumed to be available.

Using the option file
Especially for unattended mode, you may need to specify multiple options (install path, Python version, installation pass-
word etc.). Instead of passing them all on the command line, you can use the option file:

1. Create a simple text file with a list of option=value lines. The option names are those from the usage screen without
the leading --.
2. Pass the filename to the installer using the --optionfile <filename> switch.

For example, here’s a file for unattended install for Python 3:
installpassword=mypassword
prefix=/home/igor/ida-7.6

mode=unattended
python_version=3

Running Mac installer from command line
Because the Mac installer is not a single binary but an app bundle, you need to pass arguments to the executable inside
the bundle, for example:

ida[...].app/Contents/Mac0S/installbuilder.sh --mode text

Uninstaller options
The uninstaller can also be run with commandline opions:

~/idapro-7.6/uninstall --mode unattended
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While not commonly used, full-screen mode can be useful on complex IDA layouts when working with a single monitor or
on a laptop, for example when you need to read a long listing line but are tired of scrolling around.

The feature is somewhat hidden, but the action is present in the View menu.

By pressing F11, the current view is temporarily expanded to full screen, and all other views and Ul elements (toolbars,
menus) are hidden to remove all distractions.

To go back to the standard layout, just press F11 again.
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The stack frame is part of the stack which is managed by the current function and contains the data used by it.

Background
The stack frame usually contains data such as:

local and temporary variables;

incoming arguments (for calling conventions which use stack for passing arguments);
saved volatile registers;

other bookkeeping information (e.g. the return address on x86).

Because the stack may change unpredictably during execution, the stack frame and its parts do not have a fixed ad-
dress. Thus, IDA uses a pseudo structure to represent its layout. This structure is very similar to other structures in the
Structures view, with a few differences:

1. The frame structure has no name and is not included in the global Structures list; it can only be reached from the
corresponding function;

2. Instead of offsets from the structure start, offsets from the frame pointer are shown (both positive and negative);

3. It may contain special members to represent the saved return address and/or saved register area.

Stack frame view
To open the stack frame view:

e Edit > Functions > Stack variables... or press Ctr1-K while positioned in a function in disassembly (IDA View);
e Double-click or press Enter on a stack variable in the disassembly or pseudocode.

In this view, you can perform most of the same operations as in the Structures view:

1. Define new or change existing stack variables (D);
2. Rename variables (N);
3. Create (*) or structure instances (Alt- Q).

Example
Consider this vulnerable program:

#include <stdio.h>
int main () {
char username[8];
int allow = 0;
printf external link(“Enter your username, please: “);
gets(username); // user inputs “malicious”
if (grantAccess(username)) {
allow = 1;

if (allow != @) { // has been overwritten by the overflow of the username.
privilegedAction();
}

return 0;

}

Source:
When compiled by an old GCC version, it might produce the following assembly:

.text:0000000000400580 main proc near ; DATA XREF: _start+1DTo
.text :0000000000400580

.text:0000000000400580 var_10= byte ptr -10h

.text:0000000000400580 var_4= dword ptr -4

.text:0000000000400580

.text:0000000000400580 ; _ unwind {

.text:0000000000400580 push rbp

.text:0000000000400581 mov rbp, rsp

.text:0000000000400584 sub rsp, 1eh

.text:0000000000400588 mov [rbp+var_4], ©

.text:000000000040058F mov edi, offset format ; “Enter your username, please:
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.text:
.text:
.text:
.text:
.text:
.text:
.text:
.text:
.text:
.text:
.text:
.text:
.text:
.text:
.text:
.text:
.text:
.text:
.text:
.text:
.text:
.text:
.text:
.text:

0000000000400594
0000000000400599
000000000040059E
00000000004005A2
00000000004005A5
00000000004005AA
00000000004005AE
00000000004005B1
00000000004005B6
00000000004005B8
00000000004005BA
00000000004005C1
00000000004005C1
00000000004005C1
00000000004005C5
00000000004005C7
00000000004005CC
00000000004005D1
00000000004005D1
00000000004005D1
00000000004005D6
00000000004005D7

00000000004005D7

mov
call
lea
mov
call
lea
mov
call
test
jz
mov

loc_4005C1:
cmp
jz
mov
call

loc_4005D1:
mov
leave
retn

main endp

eax, 0

_printf

rax, [rbp+var_10]
rdi, rax

_gets

rax, [rbp+var_10]
rdi, rax
grantAccess

eax, eax

short loc_4005C1
[rbp+var_4], 1

; CODE XREF: main+38tj

[rbp+var_4], o
short loc_4005D1
eax, 0
privilegedAction

; CODE XREF: main+451j

eax, 0

00000000004005D7 ; } // starts at 400580

On opening the stack frame we can see the following picture:

Stack of main

-0000000000000010 ; D/A/*
-0000000002000010 ; N
-0000000000000010 ; U
-0000000002000010 ;
-00060000800000168 ;
-0000000002000010 ;
-00060000800000168 ;
-0000000800008010

: rename
: undefine

+2000000000000010
+2000000000000010 ;

SP+0000000000000000
<

: change type (data/asciifarray)a

Use data definition commands to create ]
Two special fields "
Frame size: 1@; Saved regs: 8; Purge: @

P oand " 5"

-0006peER0RBEER10 var_10 db ?
-000000000000EREF db ? ; undefined
- 0020e0E00E000R0E db ? ; undefined
-000000000000002D db ? ; undefined
- 002000E00800080C db ? ; undefined
-000000000000002B db ? ; undefined
-000000000000080A db ? ; undefined
-0000000000000009 db ? ; undefined
-0000000000000008 db ? ; undefined
-008000OROAROORBT db ? ; undefined
-0000000000000006 db ? ; undefined
-00B000OROAROONBS db ? ; undefined
-0000000000000R04 var_4 dd ?
+0000000000000000 s db 8 dup(?)
+60060E0AROARARES db 8 dup(?)

end of stack variables

represe

v
>

By comparing the source code and disassembly, we can infer that var_10 is username and var_4 is allow. Because the
code only takes the address of start of the buffer, IDA could not detect its full size and created a single byte variable.
To improve it, press * on var_10 and convert it into an array of 8 bytes. We can also rename the variables to their proper

names.

Stack of main B
-0000000000000018 ; D/A/* : change type (data/ascii/array)A
-00000000000R00010 ; N rename

-0000000000000018 ; U : undefine

-0008000000000010 ; Use data definition commands to create ]
-0080000800000010 ; Two special fields " r" and " s" represe

-0066000000000010 ;
-0000000000000010 ;

Frame size: 1@; Saved regs: 8; Purge: 8

SD+0000000000000000
<

- 0e060EE0eEEERa1e
10 usd db 8 dup(?)
- 08060EE0EEEE000E db ? ; undefined
- 0006000000000087 db ? ; undefined
- 0B06EERDEEEROEBE db ? ; undefined
- 0006000000000085 db ? ; undefined
-00060EE00EER0084 allow dd ?
+D0BAOROBERROEERE db 8 dup(?)
+0000000G00006008 db 8 dup(?)
+DBBEAROEEOROEE1E

+8008060000800010 ;

end of stack variables
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Because IDA shows the stack frame layout in the natural memory order (addresses increase towards the bottom), we
can immediately see the problem demonstrated by the vulnerable code: the gets function has no bounds checking, so
entering a long string can overflow the username buffer and overwrite the allow variable. Since the code is only checking
for a non-zero value, this will bypass the check and result in the execution of the privilegedAction function.

Frame offsets and stack variables

As mentioned above, in the stack frame view structure offsets are shown relative to the frame pointer. In some cases, like
in the example above, it is an actual processor register (RBP). For example, the variable allow is placed at offset -4 from
the frame pointer and this value is used by IDA in the disassembly listing for the symbolic name instead of raw numerical
offset:

.text:0000000000400580 allow= dword ptr -4

[...]
.text :0000000000400588 mov [rbp+allow], ©

[...]

By pressing # or K on the instruction, you can ask IDA to show you the instruction’s original form:
.text:0000000000400588 mov dword ptr [rbp-4], ©

Press K again to get back to the stack variable representation.

In other situations the frame pointer can be just an arbitrary location used for convenience (usually a fixed offset from
the stack pointer value at function entry). This is common in binaries compiled with frame pointer omission, a common
optimization technique. In such situation, IDA may use an extra delta to compensate for the stack pointer changes in
different parts of function. For example, consider this function:

.text:10001030 sub_10001030 proc near ; DATA XREF: sub_100010B0:1loc_100010E7l0
.text:10001030

.text:10001030 LCData= byte ptr -0Ch

.text:10001030 var_4= dword ptr -4

.text:10001030

.text:10001030 sub esp, OCh

.text:10001033 mov eax, dword_100B2960

.text:10001038 push esi

.text:10001039 mov [esp+1@h+var_4], eax

.text:1000103D xor esi, esi

.text:1000103F call ds:GetThreadlLocale

.text:10001045 push 7 ; cchData
.text:10001047 lea ecx, [esp+l4h+LCData]

.text:1000104B push ecx ; lpLCData
.text:1000104C push 1004h ; LCType
.text:10001051 push eax ; Locale
.text:10001052 call ds:GetLocaleInfoA

.text:10001058 test eax, eax

.text:1000105A jz short loc_1000107D

.text:1000105C mov al, [esp+l@h+LCData]
.text:10001060 test al, al

.text:10001062 lea ecx, [esp+1@h+LCData]
.text:10001066 jz short loc_1000107D

Here, the explicit frame pointer (ebp) is not used, and IDA arranges the stack frame so that the return address is placed
offset O:

-00000010 ; Frame size: 10; Saved regs: @; Purge: @

-00000010 ;

-00000010

-00000010 db ? ; undefined
-0000000F db ? ; undefined
-0000000E db ? ; undefined
-0000000D db ? ; undefined

-0000000C LCData db ?
-0000000B db ? ; undefined
-0000000A db ? ; undefined
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-00000009 db ? ; undefined
-00000008 db ? ; undefined
-00000007 db ? ; undefined
-00000006 db ? ; undefined
-00000005 db ? ; undefined
-00000004 var_4 dd ?

+00000000 r db 4 dup(?)
+00000004

+00000004 ; end of stack variables

To compensate for the changes of the stack pointer (sub esp, @Ch and the push instructions), values 10h or 14h have to
be added in the stack variable operands. Thanks to this, we can easily see that instructions at 10001047 and 1000105C
refer to the same variable, even though in raw form they use different offsets ( [esp+8] and [esp+4] ).

Extra information: IDA Help: Stack Variables Window?

1 https://hex-rays.com/blog/igor-tip-of-the-week-10-working-with-arrays/
2 https://security.web.cern.ch/rec ommendations/en/codetools/c.shtml
3 https://www.hex-rays.com/products/ida/support/idadoc/488.shtml
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When working with pseudocode in the decompiler, you may have noticed that variable declarations and hints have com-
ments with somewhat cryptic contents. What do they mean?

While meaning of some may be obvious, others less so, and a few appear only in rare situations.

Variable location
The fist part of the comment is the variable location. For stack variables, this includes its location relative to the stack
and frame pointers. For register variables — the register(s) used for storing its value.

In some cases, you may also see the syntax. For example:
structl2 v78; // ©0:r2.8,8:70.4

This denotes a 12-byte structure stored partially in registers (8 first bytes, beginning at r2), and on stack (4 last bytes,
starting from stack offset 8).

Variable attributes
After the location, there may be additional attributes printed as uppercase keywords. Here are the most common possi-
bilities:

e BYREF: address of this variable is taken somewhere in the current function (e.g. for passing to a function call);

e OVERLAPPED: shown when the decompiler did not manage to separate all the variables so some of them ended up
being stored in intersecting locations. Usually functions with such variables are also marked with the comment:
// local variable allocation has failed, the output may be wrong!

e MAPDST: another variable has been to this one;

e FORCED: this is an explicitly .

e ISARG: shown for function arguments (in mouse hint popups);

User comment
Local variables may also have additional, user-defined comments which can be added using the / shortcut or the con-
text menu:

If present, it will be printed at the end of the variable comment, after the annotations.

Type annotations
In addition to local variables, decompiler can also show annotations in the hints for:

e Structure and union fields. Offset and type is shown.

gRT = a2->RuntimeServices;
sub_203AC(&unk_g7548. &u7Y:
v2 = u7; loff=0x58; EFI_RUNTIME_SERVICES *
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¢ Global variables. Only the type is shown.

¢ Functions and function calls. The list of arguments as well as their locations is printed:

if ( sub_675B() >= @ )

_ sub_52430); [off=ox148;
if ( (gBS->LocateProj 2: 0008
. 1: 00es
if ( *(_DWORD *)v3. 2. 0oR8
{ RET @08
305818 _ModuleEntryPoins:5{ TOTAL STKARGS SIZE:

EFI_LOCATE_PROTOCOL

rex
rdx
rg

rax

EFI_GUID *Protocol;
void *Registration;
void **Interface;
EFT_STATUS;

32

1 https://hex-rays.com/blog/igors-tip-of-the-week-51-custom-calling-conventions/
2 https://hex-rays.com/products/decompiler/manual/cmd_map_Ivar.shtml
3 https://hex-rays.com/products/decompiler/manual/cmd_force_lvar.shtml
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We've already described used in the decompiled code, but you may also encounter some unusual key-
words resembling function calls. They are used by the decompiler to represent operations which it was unable to map to
nice C code, or just to make the output more compact. They are listed in the defs.h header file that is provided with the
decompiler (can be found in plugins/hexrays_sdk/include in your IDA directory) but here is a high level overview of the
commonly seen ones.

Partial access macros
Sometimes the code may access smaller parts of a big variable. To not pollute the code with multitudes of casts, the
decompiler uses helper macros for this purpose.

LOWORD(x) , LOWORD(x) , LODWORD(x) return the lowest byte/word/dword of the variable x as an unsigned value;
HIWORD(x),HIWORD(x),HIDWORD(x) return the corresponding high part;

BYTE1(x), BYTE2(x) etc. return individual bytes in the memory order. The variable is considered to start at byte O in
memory;

4. same macros but with the S prefix (SLOBYTE, SBYTEL etc.) return signed values.

wWN -

Note: this approach may lead to somewhat confusing situations on big endian processors like PPC. Because big-endian
data is stored starting from the high byte, the low-order byte of it is stored at the highest memory address and so is ac-
cessed using the HIBYTE macro. For example, consider a 32-bit variable containing value 0x1A2B3CA4D. It will be stored
in memory in different order on little-endian(LE) and big-endian(BE) platforms:

LE BE

4D |1AF«<—1LOBYTE

3C|2B<—BYTE1

2B|3C<—BYTE2

1A|4D «——HIBYTE

Combining values
Sometimes the compiler needs to represent the opposite operation: two values are combined to make a larger one. For
this, “pair” macros are used:

1. __PAIR16__ (high, low) creates a 16-bit value from two 8-bit ones. Unlike partial accesses macros, it does not
depend on the memory order but uses simple bit shifts, so the result is the same for little- and big-endian code. For
example, _ PAIR16__ (0x1A, 0x2B) returns in ©x1A2B in either situation;

2. __PAIR32_,_PAIR64__,_ PAIR128 perform the corresponding operation for bigger-sized values;

3. __SPAIR16__ etc. return signed values.

Bit and flag manipulations
Some assembly instructions do not have simple C representation so custom helper functions are used.

1. __ROLn__(value, count) and __RORn__(value, count) (n=1,2,4,8) represent n-byte left and right bit rotates;
2. __OFADD__ and _ OFSUB__ return the overflow flag of addition(subtraction) operation on two values;

3. __CFADD__ and __CFSUB__ perform the same for carry flag;

4. _ SETP__(x, y) is used to represent the parity flag generated by expression x-y.

Overflow-checking multiplications

Recent compilers started adding overflow checks in common situations. For example, when calling operator new[],
behind the scenes the compiler has to multiply the size of the elements by their count. If this operation overflows, wrong
value may be produced, leading to under-allocation or allocation failure. Programmers may also add manual overflow
checks. The following helper functions are used to represent such code patterns:

1. is_mul_ok(count, elsize) represents overflow check on the result of count*elsize. It is presumed to return true if
the overflow does not happen.

2. saturated_mul(count, elsize) returns either the result of multiplication if it can be calculated safely, or the maxi-
mum unsigned integer value of the corresponding size (e.g. @xFFFFFFFF). The latter should ensure that the allocation
fails in case of overflow. This pattern is commonly used in calls to operator new[] in recent versions of Visual C++.
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Value coercion
Sometimes the code treats the same underlying value as different types. For example, the famous inverse square root
function from Quake treats a 32-bit floats as an integers and vice versa:

float InvSqrt (float x){
float xhalf = 0.5f*x;
int i = *(int*)&x;

i = @x5f3759df - (i>>1);

X = *(float*)&i;
X = x*(1.5f - xhalf*x*x);
return x;

}

Although in the source code this conversion is represented using casts and dereferences, in the optimized code they
may be replaced by simple moves between registers, especially when using SSE or AVX instructions which use the
same registers to store both floating-point and integer values. Thus the decompiler has to use special macros to repre-
sent such code:

1. COERCE_FLOAT(v), COERCE_DOUBLE(v), COERCE_LONG_DOUBLE (V) are used to treat the bit pattern of v as the correspond-
ing floating-point type.

2. COERCE_UNSIGNED_INT(v) and COERCE_UNSIGNED INT64(v) are used for the opposite conversions.

3. You may also see SLODWORD when a floating-point value is treated as a signed integer.

For example, here’s how pseudocode for the above function looks like when decompiled:

double _ cdecl InvSqrt(float al)

{
float v2; // [esp+@h] [ebp-8h]

v2 = al * 9.5;
return (float)((1.5
- v2 * COERCE_FLOAT(Ox5F3759DF - (SLODWORD(al) >> 1)) * COERCE_FLOAT(®x5F3759DF - (SLOD-
WORD(a1) >> 1)))
* COERCE_FLOAT(@X5F3759DF - (SLODWORD(al) >> 1)));

}

1 https://hex-rays.com/blog/igors-tip-of-the-week-45-decompiler-types/
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In compiled code, you can sometimes find instructions which do not directly represent the code written by the program-
mer but were added by the compiler for its own purposes or due to the requirements of the environment the program is
executing in.

Skippable instruction kinds
Compiled functions usually have prolog instructions at the start which perform various bookkeeping operations, for
example:

preserve volatile registers used in the function’s body;
. set up new stack frame for the current function;
. allocate stack space for local stack variables;
. initialize the stack cookie to detect buffer overflows;
. set up exception handlers for the current function.

aOh~hwWNDA

In a similar manner, a function’s epilog performs the opposite actions before returning to the caller.

In switch patterns there may also be instructions which only perform additional manipulations to determine the destina-
tion of an indirect jump and do not represent the actual logic of the code.

To not spend time analyzing such boilerplate or uninteresting code and only show the “real” body of the function, the
decompiler relies on processor modules to mark such instructions.

Showing skippable instructions
By default skipped instructions are not distinguished visually in any way. To enable their visualization, create a text file
idauser.cfg with the following contents:

#ifdef _ GUI__
PROLOG_COLOR
EPILOG_COLOR
SWITCH_COLOR
t#tendif

OXEQEQEQ // grey
OXEOQFFE@ // light green
OXEGEQFF // pink

Place the file in the user directory (%appdata%\Hex-Rays\IDA Pro on Windows, $HOME/.idapro on Unix) and restart IDA or
reload the database to the observe the effect in the disassembly listing.

Original disassembly: After creating the configuration file:
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As you can seg, the first three and last two instructions are highlighted in the specified colors. These instructions will be
skipped during decompilation.

Modifying skippable instructions

There may be situations where you need to adjust IDA’s idea of skipped instructions. For example, IDA may fail to mark
some register saves as part of prolog (this may manifest as accesses to uninitialized variables in the pseudocode). In that
case, you can fix it manually:

1. In the disassembly view, select the instruction(s) which should be marked;
2. invoke Edit > Other > Toggle skippable instructions...;
3. select the category (prolog/epilog/switch) and click OK.

In case of an opposite problem (IDA erroneously marked some instructions which do necessary work), perform the same
actions, except there won't be a dialog at step 3 - the instructions will be unmarked directly.

More info: Toggle skippable instructions (Decompiler Manual)?

1 https://hex-rays.com/products/decompiler/manual/interactive.shtml#06
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While using the decompiler, sometimes you may have seen the item named Split expression in the context menu. What
does it do and where it can be useful? Let’s look at two examples where it can be applied.

Structure field initialization
Modern compilers perform many optimizations to speed up code execution. One of them is merging two or more adja-
cent memory stores or loads into a single wide one. This often happens when writing to nearby structure fields.

For example, when you decompile a macOS program which uses and use our to
analyze the supporting code in a function, you may observe pseudocode similar to the following:

block.isa = _NSConcreteStackBlock;
*(_QWORD *)&block.flags = 3254779904LL;
block.invoke = sub_10000A159;
block.descriptor = &stru_10001EQES;
block.lvarl = self;

The block variable uses a structure created by the plugin which looks like this:

struct Block_layout_10000A088
{
void *isa;
int32_t flags;
int32_t reserved;
void (__cdecl *invoke)(Block_layout_10000A088 *block);
Block_descriptor_1 *descriptor;
_QWORD 1lvari;

s

As you can see, the compiler decided to initialize the two 32-bit flags and reserved fields in one go using a single 64-bit
store. Although technically correct, the pseudocode looks somewhat ugly and not easy to understand at a glance. To
tell the decompiler that this write should be treated as two separate ones, right-click the assignment and choose “Split
expression™

Once the pseudocode is refreshed, two separate assignments are displayed:

block.isa = _NSConcreteStackBlock;
block.flags = 0xC2000000;
block.reserved = 0;

block.invoke = sub_10000A159;
block.descriptor = &stru_10001EQES;
block.lvarl = self;

The newly 32-bit constant could, for example, be converted to hex or a set of flags using a custom enum.

This example is rather benign because the reserved field is set to 0 so the constant was already effectively 32-bit; other
situations can be more involved when different distinct values are merged into one big constant.

If necessary, expressions can be split further (e.g. when one value is used to initialize 3 or more fields). You can also
revert the split by choosing “Unsplit expression” in the context menu.
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64-bit variables in 32-bit programs

When handling 64-bit values on processors with 32-bit registers, the compiler has to work with data in 32-bit pieces.
This can lead to very verbose code if translated as-is, so our decompiler detects common patterns such as 64-bit math,
comparisons or data manipulations and automatically creates 64-bit variables consisting of two 32-bit registers or
memory locations. While our heuristics work well in most cases, there may be false positives, when two actually separate
32-bit variables get merged into a 64-bit one. In such situation, you can use “Split expression” on the 64-bit operations
involving the variable to split the pair and recover proper, separate variables.

See also: Hex-Rays interactive operation: Split/unsplit expression3

1 https://developer.apple.com/library/archive/documentation/Cocoa/Conceptual/ProgrammingWithObjectiveC/WorkingwithBlocks/WorkingwithBlocks.html
2 https://hex-rays.com/products/ida/support/idadoc/1687.shtml
3 https://hex-rays.com/products/decompiler/manual/cmd_split.shtml
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The last week’s post got preempted by the IDA 7.7 release so I'll take this opportunity to highlight (ha ha) one of the new
features.

In previous IDA versions we already had highlight® with an option to lock it so it remains fixed while browsing the data-
base. In IDA 7.7 it’s been improved so that you can have several highlights active at the same time!

Setting highlights
Basic usage remains the same: highlight any string you want (by clicking on a word, dragging mouse, or with Shift-ar-
rows), then click the Lock/unlock current highlight button (initially displaying A on a yellow background).

On the first glance, the effect seems to be the same: the current highlight is locked and stays on as you browse. Howev-
er, if you click on another word, you'll see that the dynamic highlight now uses another color, and the lock button chang-
es color too.

5wl s .
push esi

push offset vsnprintf

push 3EAABDE4A

push 7
mowv ecx, BD22E2014h

cdi sub_1e@e3eDe
mov edx, offset dword_18601288

mov ecx, eax
call sub_ 18083148

add esp, OCh
mowv ecx, BF7EE&72h

push offset SetlLastError
push 27668B7Ch

Now, if you click the button again, the second highlight gets locked and the dynamic highlight switches to the next color.
You can keep doing this up to the limit (currently 8 color slots).

Removing highlights

Removing a locked highlight is pretty straightforward: click on a currently highlighted item in the listing and click on the
toolbar button to unlock it. Alternatively, you can use the dropdown menu next to the button to see the currently as-
signed highlights and clear a specific one by picking the corresponding entry.
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Changing highlight colors
The highlight colors, like most others, can be changed in the Options > Colors... dialog. Select one of the “Highlight
background” entries in the “Background colors” dropdown, then click “Change color” to set the new color.

Shortcuts
As can be seen in the screenshot of the dropdown menu, each highlight color has a corresponding shortcut
ctrl+Alt+digit (digit=1,2,..8), which can be used to set or clear the corresponding highlight directly.

Other views
The multiple highlight feature is available not only in the disassembly but also in other text-based views of IDA: Struc-
tures, Enums, Pseudocode, and even the Hex View, although some of them may be more or less useful than others.

Hopefully, you'll find this little feature useful in your work!

1 https://hex-rays.com/products/ida/news/7_7/
2 https://hex-rays.com/blog/igor-tip-of-the-week-05-highlight/
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Although the Hex-Rays decompiler was originally written to deal with compiler-generated code, it can still do a decent
job with manually written assembly. However, such code may use non-standard instructions or use them in non-standard
ways, in which case the decompiler may fail to produce equivalent C code and has to fall back to _asm statements.

Analyzing system code
As an example, let’s have a look at this function from a PowerPC firmware.

ROM:
ROM:
ROM:
ROM:
ROM:
ROM:
ROM:
ROM:
ROM:
ROM:
ROM:
ROM:
ROM:
ROM:
ROM:
ROM:
ROM:
ROM:
ROM:
ROM:
ROM:
ROM:
ROM:
ROM:
ROM:
ROM:
ROM:
ROM:

00000C8C sub_C8C:

00000C8C
00000C8C
00000C8C
00000C8C
00000C8C
00000C8C
00000C8C
00000C90
00000C9%4
00000C98
00000C9C
00000CAQ
00000CA4
00000CA8
0000ACAC
00000CB0O
00000CB4
00000CB8
00000CBC
00000CCo
00000CC4
00000CC8
00000CCC
00000CD0o
00000CD4
00000CD8

.set back_chain, -0x18
.set var_C, -0xC
.set sender_1r, 4

stwu
mflr
stmw
stw
addi
mflr
addi

bl

lis

1lhz
mtsprgo
not
slwi

or
mtsprgl
mtsprg2
mftb
addi
mtsprg3
bl

rl, back_chain(rl)
ro

r29, oxi18+var_C(rl)
ro, o0x18+sender_lr(rl)
r3l, r3, 0

r3

r3e, r3, o
sub_1264

r29, ox4e # ‘@’
r29, -ex2C(r29)

r29

rll, r31

ri1, ril, 16

r3l, rll, r31

r31

r3e

r3

r3e, r3, 0

r30

sub_1114

00000CD8 # End of function sub_C8C

# CODE XREF: ROM:00000B1CTp
# sub_CFo+44lp ...

The code seems to be using Special Purpose Register General (sprgo/1/2/3) for its own purposes, probably to store
some information for exception processing. Because system instructions are generally not encountered in user-mode
code, they are not supported by the decompiler out-of-box and the default output looks like this:

void _ fastcall _ noreturn sub_C8C(int al)

{

int v1; // 1r

_R30 = vi;

sub_1264();

_R29 = (unsigned __int16)word_3FFFD4;

__asm { mtsprgo
_R31 = (~al << 16) | a1;

__asm

{

}

_R30 = _R3;
__asm { mtsprg3
sub_1114();

}

mtsprgl
mtsprg2
mftb

r3l
r3e
r3

r29 }

r3e }

Although the instructions themselves are shown as _asm statements, the decompiler could detect the registers used by
them and created pseudo variables (_R29, _R30, _R31) to represent the operations performed. However, it is possible to
get rid of _asm blocks with a bit of manual work.
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Decompile as call

It is possible to tell the decompiler that specific instructions should be treated as if they were function calls. You can
even use a custom calling convention' to specify the exact input/output registers of the pseudo function. Let’s try it for
the unhandled instructions.

1. In the disassembly view, place the cursor on the instruction (e.g. mtsprgo r29);

2. Invoke Edit > Other > Decompile as call...
3. Enter the prototype, taking into account input/output registers. In our example we'll use:
void __usercall mtsgpro@(unsigned int value<r29>);
4. Repeat for the remaining instructions, for example:
void __usercall mtsgpri(unsigned int<r31>);
void __usercall mtsgpr2(unsigned int<r3e»);
void __usercall mtsgpr3(unsigned int<r3e>)
int __usercall mftb<r3>();
5. Refresh the decompilation if it’'s not done automatically.

We get something like this:

void _ fastcall _ noreturn sub_C8C(int al)

{

unsigned int v1; // 1lr

sub_1264();

mtsgpro((unsigned __ int16)word_3FFFD4);
mtsgprl((~al << 16) | al);

mtsgpr2(vl);

mtsgpr3(mftb());

sub_1114();

}

No more _asm blocks! The only remaining wrinkle is the mysterious variable v1 which is marked in orange (“value may be
undefined”).

if we look at the assembly, we'll see that the r3e passed to mtsprg2 originates from r3 set by the mflr r3instruction.
The instruction reads value of the 1r (link register), which contains the return address to the caller and thus by definition
has no determined value. However, we can use a pseudo function such as GCC’s _ builtin_return_address?® by speci-
fying this prototype for the mflr r3 instruction:

void * _ builtin_return_address ();

NB: We do not need to use __usercall here because r3 is already the default location for a return value in the PPC ABI.

Finally, the decompilation is looking nice and tidy:




07Jan2022

& https://hex-rays.com/blog/igors-tip-of-the-week-71-decompile-as-call/

Complex situations

If you want to automate the process of applying prototypes to instructions, you can use a decompiler plugin or script. For
example, see the vds&° decompiler SDK sample (also shipped with IDA), which handles some of the SVC calls in ARM
code. In even more complicated cases, such as when some arguments can’t be represented by custom calling conven-
tion, or the semantics are better represented by something other than a function call (e.g. the instruction affects multiple
registers), you can use a “microcode filter” to generate custom microcode which would then be optimized and converted
to C code by the decompiler engine. A great example is the excellent microAVX plugin® by Markus Gaasedelen.

See also: Decompile as call® in the decompiler manual.

1 https://hex-rays.com/blog/igors-tip-of-the-week-51-custom-calling-conventions/
2 https://gcc.gnu.org/onlinedocs/gcc/Return-Address.html

3 https://github.com/idapython/src/blob/master/examples/hexrays/vds8.py

4 https://github.com/gaasedelen/microavx/

5 https://hex-rays.com/products/decompiler/manual/interactive.shtml#08
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We’ve covered basics of working with string constants (aka string literals) before! but IDA support additional features
which may be useful in some situations.

Exotic string types

Pascal and derived languages (such as Delphi) sometimes employ string literals which start with the length followed by
the characters. Similarly to the wide (Unicode) strings, they can be created using the corresponding buttons in the Op-
tions > String literals... dialog or the Edit > Strings submenu.

seg@ee:DE24 aPressF3ToView db 16, 'Press F3 to view'
Some OS or embedded firmware can employ a byte other than 0 as string terminator. When analyzing such binary, you
can set this up in the Options > General..., Strings tab (also accessible via Options > String literals..., “Manage defaults”
link.

As a common variation of this type, DOS type strings (terminated with the $ character) have their own entry in the Edit >
Strings menu.

Changing string length
For already-created string literals, you can use the * shortcut to edit them as if they were an array and adjust “Array size”
to change the length of the string.

See also:
Unicode strings and custom encodings?
How to format multiple strings placed together3.

1 https://hex-rays.com/blog/igor-tip-of-the-week-13-string-literals-and-custom-encodings/
2 https://hex-rays.com/blog/igor-tip-of-the-week-13-string-literals-and-custom-encodings/
3 https://hex-rays.com/blog/igor-tip-of-the-week-10-working-with-arrays/
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Output window is part of IDA’s default desktop layout and shows various messages from IDA and possibly third-party
components (plugins, processor modules, scripts...). It also contains the Command-line interface (CLI) input box.

Output
B T :

2022-01-21 14:09:11.316 0. Creating a new segment (0000000000000000-0000000000000028) ... ... [0
2022-01-21 14:09:11.320 1. Creating a new segment (0000000000000028-0000000000000028) +.. ... [o:4
2022-01-21 14:09:11.320 2. Creating a new segment (0000000000000029-0000000000000028) ... ... [:4
2022-01-21 14:09:11.320 3. Creating a new segment (0000000000000030-000000000000003C) ... ... [0
2022-01-21 14:09:11.321 4. Creating a new segment (000000000000003C-0000000000000070) +.v ..» [o:4
2022-01-21 14:09:11.401 5. Creating a new segment (0000000000000070-0000000000000074) ... ... [:4

2022-01-21 14:09:11.401 Processing relocations...
Python ||

Opening the Output window
Although it is present by default, it is possible to close this window, or use a without it. If this happens,
one way to restore it is to use Windows > Reset desktop to bring the layout to the initial state. But you can also use:

¢ Windows > Output window (shortcut Alt+ 0), to (re)open it and focus on the text box (for example, to select text for
copying);

¢ Windows > Focus command line (Shortcut Ctrl+ .) to switch to the CLI input field, which also re-opens the Output
window if it was closed.

Context menu
There are several actions available in the text box of the Output window, which can be consulted by opening the context
menu:

Copy Ctrl+C
Select All Chrl+ 4
Eind Alt+T
Find next Ctrl+T
Clear Ctrl+X
Copy to CLI Ctrl+P
Save to file... Ctrl+5
*  Show timestamps
Font...

For example, similarly to other IDA windows, you can search for text using ALt+T/Ctr1+T shortcuts, or clear the current
text to easier see output of a script you're planning to run.

Timestamps

Starting from , you can turn on timestamps for every message printed to the Output window. They are stored in-
dependently from the text so can be turned on or off at any point and affect all (past and future) messages in the current
IDA session.

Navigation

Double-clicking on an address or identifier in Output window will jump to the corresponding location (if it exists) in the
last active disassembly, pseudocode, or Hex view. This can be useful when writing quick scripts: just print addresses or
names of interest using msg() function and double-click to inspect them in the disassembly listing.
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Logging to file
Logging of the messages in Output window to a file can be especially useful when using IDA in batch mode?, but also in
other situations (e.g. debugging scripts or plugins). The following options exist to enable it:

1. set environment variable* IDALOG to a filename. If the path is not absolute, the file will be created in the current direc-
tory. All IDA run afterwards will append output to the same file, so it can contain information from multiple runs.

2. pass the -L<file> command line® switch to IDA. Note that it has to precede the input filename.

3. On-demand, one-time saving can be done via “Save to file” context menu command (shortcut Ctrl+ S).

Note: if you have enabled timestamps in IDA, they will be added in the log file too (and in all future IDA sessions). There is
currently no possibility to turn timestamps on or off via environment variable or command line switch.

1 https://hex-rays.com/blog/igors-tip-of-the-week-22-ida-desktop-layouts/

2 https://hex-rays.com/blog/igors-tip-of-the-week-48-searching-in-ida/

3 https://hex-rays.com/blog/igor-tip-of-the-week-08-batch-mode-under-the-hood/
4 https://www.hex-rays.com/products/ida/support/idadoc/1375.shtml

5 https://www.hex-rays.com/products/ida/support/idadoc/417.shtml
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Many features of IDA and other disassemblers are taken for granted nowadays but it’s not always been the case. As one
example, let’s consider automatic variable naming.

A little bit of history
In the , IDA did not differ much from a dumb disassembler with comments and renaming and showed pretty
much raw instructions with numerical offsets. To keep track of them users often had to add manual comments.

A few versions later, support for stack variables appeared. They initially had dummy names (var_4, var_C etc.) but could
be renamed by the user which eased the reverse engineering process. However, this could still be tedious in big pro-
grams.

Next, was added, which helped identify standard library functions. Now the user did not need to analyze boil-
erplate code from the compiler runtime libraries but only the code written by the programmer. Having identified library
functions also helped in picking names for variables: most library functions had known prototypes so the variables used
for their arguments could be renamed accordingly.

However, this process was still manual, could it not be automated?

And indeed, this is what happened in , with the addition of the type system and . Now
the identified library or imported functions could be matched to their prototypes in the type library and their arguments
commented and/or renamed. For the arguments using a complex type (e.g. a structure), the stack variable could also be
changed to use that type.

In practice
As a current example, let’s have a look at a Win32 program which calls CreatelWindowExA.

First, with everything disabled:

mov eax, [ebp-20h]

push dword ptr [ebp+8]
sub eax, [ebp-28h]

push dword ptr [ebx+1Ch]
push eax

mov eax, [ebp-24h]

sub eax, [ebp-2Ch]

push eax

push dword ptr [ebp-28h]
push dword ptr [ebp-2Ch]
push dword ptr [ebp-8]

push edi
push offset aEdit 5 “edit”
push edi

call ds:CreateWindowExA
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Next, with stack variables:

mov eax, [ebp+var_20]
push [ebp+arg_0]

sub eax, [ebp+var_28]
push dword ptr [ebx+1Ch]
push eax

mov eax, [ebp+var_24]
sub eax, [ebp+var_2C]
push eax

push [ebp+var_28]
push [ebp+var_2C]
push [ebp+var_8]

push edi
push offset aEdit 5 “edit”
push edi

call ds:CreateWindowExA

Stack variables are created but use dummy names. We could consult the function’s documentation® and rename and

retype them manually. But instead we can enable argument propagation and reanalyze the function®:

mov eax, [ebp+Rect.bottom]

push [ebp+hMenu] ; hMenu

sub eax, [ebp+Rect.top]

push dword ptr [ebx+1Ch] ; hWndParent
push eax ; nHeight

mov eax, [ebp+Rect.right]

sub eax, [ebp+Rect.left]

push eax 5 nWidth

push [ebp+Rect.top] ; Y
push [ebp+Rect.left] ; X
push [ebp+dwStyle] ; dwStyle

push edi 5 lpWindowName
push offset aEdit ; “edit”
push edi ; dwExStyle

call ds:CreateWindowExA

Now, all arguments are renamed and all instructions initializing them are commented. The Rect variable was renamed

and typed thanks to another place in the same function:
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lea eax, [ebp+Rect]
push eax ; lpRect
push ebx 5 hihnd

call ds:GetClientRect

Here, IDA recognized that the lea instruction effectively takes an address of a struct so the stack variable should be the
struct itself and not just a pointer. Thanks to this, the field references are clearly identified in the other snippet.

Recursive propagation

In fact, PIT is not limited to single functions: if any of the function’s own arguments are renamed or retyped thanks to the
type information, this information is propagated up the call tree. For example, arg_o from the second snippet is a function
argument which was renamed to hMenu, so this information is used by the caller:

1 https://hex-rays.com/about-us/our-journey/

2 https://hex-rays.com/products/ida/tech/flirt/

3 https://hex-rays.com/products/ida/news/4_x/

4 https://hex-rays.com/blog/igors-tip-of-the-week-60-type-libraries/

5 https://docs.microsoft.com/en-us/windows/win32/api/winuser/nf-winuser-createwindowexa
¢ https://hex-rays.com/blog/igor-tip-of-the-week-17-cross-references-2/
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In C, union' is a type similar to a struct but in which all members (possibly of different types) occupy the same memory,
overlapping each other. They are used, for example, when there is a need to interpret the same data in different ways, or
to save memory when storing data of different types (this is common in scripting engines, among others). IDA and the
decompiler fully support unions and include definitions of commonly used ones in the standard type libraries?, so they
may be already present in the analyzed binaries.

Creating unions
Assembly-level unions can be created in the Structures window by enabling “create union” checkbox when adding a new

“structure”.

You can also use the Local Types® editor to create a union using C syntax.

Using unions in disassembly

In disassembly, unions can be used similarly to structures. For example, when a member is referenced as an offset from
a register, you can use the context menu’s “Structure offset” submenu or the T hotkey. The difference is that you may
see multiple “paths” for the same offset, representing alternative union members, so you can pick one most suitable for
the specific use case.

Example: OLE automation

OLE Automation is a COM-based set of APIs commonly used to implement scripting in Microsoft and other applications.
One of the basic types used in it is the VARIANT* aka VARIANTARG structure, which can contain different types of values by
embedding a union of different typed fields inside it.

typedef struct tagVARTIANT {

union {

struct {

VARTYPE vt;
WORD wReservedl;
WORD wReserved2;
WORD wReserveds;
union {

LONGLONG 11val;
LONG lval;
BYTE bval;
SHORT ival;
FLOAT fltval;
DOUBLE dblval;

VARIANT_BOOL boolVal;
VARIANT_BOOL _ OBSOLETE_ VARIANT_BOOL;

SCODE scode;
Y cyval;
DATE date;
BSTR bstrval;
TUnknown *punkval;

IDispatch *pdispval;
SAFEARRAY *parray;
BYTE *pbval;
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For example, if we have an instruction mov eax, [edx+8] and we know that edx points to an instance of VARIANTARG, using
T on the second operand shows us multiple versions of the union field, so we can pick the one most relevant to the spe-
cific code path take.

Changing the union field used

After you (or IDA) selected a union field, you can change it by going through the struct selection again (e.g. the T hotkey).
But if the parent structure should remain the same, you can change only the union member by using the command Edit >
Structs > Select union member... (hotkey Ctrl-Y). This can be especially useful when a structure with embedded union is
placed on the stack, because you can’t use the normal structure offset commands there (the offset inside the instruction
is based on the stack or frame pointer which does not point to the beginning of the structure).

Unions in decompiler

Because the decompiler can do dataflow analysis, in many cases it can pick up the most suitable union field by matching
the expected type of the variable used by the code. For example, in the snippet below the decompiler picked the correct
field for the argument passed to SysAllocString, because it knows that the function expects an argument of type const
OLECHAR *, which is compatible with the BSTR bstrVal field of the union.

if ( varg.vt == 8 )

{
#*attrString = SysAllocString(varg.bstrVall);

else if ( varg.vt == 11 )

{
vs = L"TRUE";

if ([

v5 = L"FALSE";
*¥attrString = SysAllocString(vs);
H
However, for the other reference the ival filed was selected. While it is compatible for the use case (comparing against
zero), by looking at the code it’s obvious that the code is interpreting a boolean variant value (this can be made more
clear by replacing the number 11 by the symbolic constant VT_B00OL). This means that boolVal is a more logical choice, and
we can pick it by using “Select union field...” from the context menu, or the same Alt- Y hotkey as for disassembly.
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More info:
IDA Help: Select union member3
Hex-Rays interactive operation: Select union field®

1 https://en.cppreference.com/w/c/language/union

2 https:// hex-rays.com/blog/igors-tip-of-the-week-60-type-libraries/

3 https://hex-rays.com/blog/igor-tip-of-the-week-11-quickly-creating-structures/

4 https://docs.microsoft.com/en-us/windows/win32/api/oaidl/ns-oaidl-variant

5 https://www.hex-rays.com/products/ida/support/idadoc/498.shtml

¢ https://hex-rays.com/products/decompiler/manual/cmd_select_union_field.shtml
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One of the features added in was automatic renaming of variables in the decompiler.

latencyState = OALWakeuplatency GetCurrentState();
TCRR = g pTimerRegs->TCRR;
if ( (int)(dword 61874 - TCRR) >= dword 61864 )

if ( (int)(dword 61874 - TCRR) >= g wakeuplatencyConstraintTickCount )
vi2 = g wakeuplatencyConstraintTickCount;

= dword_61874 - TCRR;
icks = OALWakeuplatency_GetDelayInTicks(latencyState);
icks )

latencyState = DALWakeuplatency_FindStateByMaxDelayInTicks(v12);
DelayInTicks = OALWakeuplatency_GetDelayInTicks(latencyState);

if ( v12 »= DelayInTicks )

OEMiriteDebuglED(@x1Eu, 1u);

if ( OAlWakeuplatency IsChipOff(latencyState) )
OALContextSave();

OALWakeuplatency PushState(latencyState);

dword_61874 -= DelayInTicks;

OALTimerSetCompare(dword 61874);

g _pPremPrm->pOMAP_WKUP_PRM->PM_WKST HKUP = 256;

g_pPremPrm->pOMAP_WKUP_PRM->PM_WKEN_WKUP |= @x180u;

fnOALCPUIdle(g_pCPUINfo);

g_pPremPr->pOMAP_WKUP_PRM->PM_WKEN_WKUP &= ~Bx108u;

OALWakeupLatency_PopState();

PM_WKST_WKUP = g_pPrcmPrm->pOMAP_WKUP_PRM->PM_WKST_WKUP;

E_pPromPrm->pOiAP_CORE_PRM->PM_PREPNSTST_CORE;
previipustate = g_pPromPrm->pOMAP_MPU_PRM->PM_PREPHSTST_MPU;
prevPerstate = g_pPromPrm->pOMAP_PER_PRM-»PM_PREPHSTST_PER;
OALContextRestore(previipustate, data, prevPerState);

V1l = g_pTimerRegs->TCRR;

PremProcessPostipublakeup();

Unlike PIT, it is not limited to stack variables but also handles variables stored in registers and not just calls but also
assignments and some other expressions. It also tries to interpret function names which include a verb (get, make, fetch,
query etc.) and rename the assigned result accordingly.

Triggering renaming manually

To cover situations where automatic renaming fails or insufficient, the decompiler also supports a manual action called
“Quick Rename” with the default hotkey Shift- N. It can be used to propagate names across assignments and other
expressions. Usually, it only renames dummy variables which were not explicitly named by the user (v1, v2, etc.). Here is
an incomplete list of rules used by the action:

by name of the opposite variable in assignments: vi = myvar: rename v1 -> myvar1
by name of the opposite variable in comparisons: offset < vi: rename v1 -> offset1
as pointer to a well-named variable: vl = &value: rename v1 -> p_Value

by structure field in expressions: v1 = x.Next: rename v1 -> Next

as pointer to a structure field: v1 = &x.left: rename v1-> p_left

by name of formal argument in a call: close(v1): rename v1 -> fd

by name of a called function: vi=create_table(): rename v1 -> table

by return type of called function: vi = strchr(s, 1’):rename v1-> str

by a string constant: v1 = fopen(*“/etc/fstab”, “r”):rename v1-> etc_fstab

by variable type: error_t v1: rename v1 -> error

standard name for the result variable: return vi: rename v1 -> ok if current function returns bool

Example: Windows driver

We'll inspect the driver used by to perform actions requiring kernel mode access. On opening kpro-
cesshacker.sys, IDA automatically applies well-known function prototype to the briverEntry entrypoint and loads kernel
mode type libraries, so the default decompilation is already decent:

NTSTATUS __ stdcall DriverEntry(_DRIVER_OBJECT *DriverObject, PUNICODE_STRING RegistryPath)
{

NTSTATUS result; // eax

NTSTATUS v5; // rlld

PDEVICE_OBJECT v6; // rax

struct _UNICODE_STRING DestinationString; // [rsp+40h] [rbp-18h] BYREF

PDEVICE_OBJECT DeviceObject; // [rsp+6@h] [rbp+8h] BYREF

gword_132C0 = (__int64)DriverObject;
VersionInformation.dwOSVersionInfoSize = 284;
result = RtlGetVersion(&VersionInformation);
if ( result >=0 )
{
result = sub_15100(RegistryPath);
if ( result >= 0 )
{
RtlInitUnicodeString(&DestinationString, L”\\Device\\KProcessHacker3”);
result = IoCreateDevice(DriverObject, @, &DestinationString, ©x22u, ©x100u, ©, &DeviceObject);
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v5 = result;
if ( result >=0 )
{
v6 = DeviceObject;
DriverObject->MajorFunction[@]
gword_132D0 = (__int64)v6;
DriverObject->MajorFunction[2] = (PDRIVER_DISPATCH)&sub_1114C;
DriverObject->MajorFunction[14] = (PDRIVER_DISPATCH)&sub_11198;
DriverObject->DriverUnload = (PDRIVER_UNLOAD)sub_150EC;
v6->Flags &= ~0x80u;
return v5;
}
}

(PDRIVER_DISPATCH)&sub_11008;

}

return result;

}

However, to make sense of it we need to make some changes. The indexes into the MajorFunction array are so-called
IRP Major Function Codes® which have symbolic names starting with IRP_MJ_. So we can apply the Enum action (M hot-
key) to convert numbers to the corresponding symbolic constants available in the type library.

Afterwards we can rename the corresponding routines and make the pseudocode look very similar to the standard
DriverEntry4:

if ( result >=8 )
i
v6 = DeviceObject;
DriverObject-*MajorFunction[IRP_M]_CREATE] = (PDRIVER DISPATCH)&KhDispatchCreate;
qword_132D0 = (__int&4)vé;
DriverObject-*MajorFunction[IRP_MJ_CLOSE] = (PDRIVER_DISPATCH)&KhDispatchClose;
DriverObject-*MajorFunction[IRP_M]_DEVICE_CONTROL] = (PDRIVER DISPATCH)&KhDispatchDeviceControl;
DriverObject->DriverUnload = (PDRIVER_UNLOAD)KhUnleoad;
vb->Flags &= ~Bx80u;
return v5;

H

To get rid of the casts, set the proper prototypes to the dispatch routines® using the “Set item type®” action (Y hotkey).
We can use the same prototype string for all three routines:
NTSTATUS Dispatch(PDEVICE_OBJECT Device, PIRP Irp)

This works because function name is not considered to be a part of function prototype and is ignored by IDA. For the
unload function, the prototype is different:
void Unload(PDRIVER_OBJECT Driver)

After setting the prototypes, no more casts:
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Now we can go into KhDispatchDeviceControl to investigate how it works. Thanks to the preset prototype, the initial
pseudocode looks plausible at the first glance:

NTSTATUS __ stdcall KhDispatchDeviceControl(PDEVICE_OBJECT Device, PIRP Irp)

{
// [COLLAPSED LOCAL DECLARATIONS. PRESS KEYPAD CTRL-”+” TO EXPAND]

vl3 = Irp;
CurrentStackLocation = Irp->Tail.Overlay.CurrentStackLocation;
FsContext = CurrentStackLocation->FileObject->FsContext;
Parameters = CurrentStackLocation->Parameters.CreatePipe.Parameters;
Options = CurrentStackLocation->Parameters.Create.Options;
LowPart = CurrentStackLocation->Parameters.Read.ByteOffset.LowPart;
AccessMode = Irp->RequestorMode;
if ( !FsContext )
{
v9 = -1073741595;
goto LABEL_105;
}
if ( LowPart != -1718018045
&& LowPart != -1718018041
&& (dword_132CC == 2 || dword_132CC == 3)
&& (*FsContext & 2) == 0 )

But on closer inspection, some oddities become apparent. The Parameters member of the 10 STACK _LOCATION” struc-
ture is a union which contains the request-specific parameters. With insufficient information, the decompiler picked the
first matching members, but they do not make sense for the request we're dealing with. For IRP_MJ_DEVICE_CONTROL, the
DeviceIoControl struct should be used.

Thus, we can use the “Select union field®” action (ALt-Y hotkey) to choose DeviceIoControl on the three references to
CurrentStackLocation->Parameters to see which parameters are actually being used.

The references have been changed, but the variable names and types remain. In such situation, we can update the
names by using Quick rename (Shift-N) on the assignments.

TypeSIInputEuffer' = (PNAMED_PIPE_CREATE_PARAMETERS)CurreﬁtSta:kLocaticmf>Parameters.DevicEIoContr‘Dl.Type31nputBuf‘FEr;
TnputBufferlength = CurrentStacklocation->Parameters.DeviceloControl.InputBufferlength;
ToControlCode = CurrentStacklocation->Parameters.DeviceloControl.ToControlCode;
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To get rid of the cast, we can either change the Type3InputBuffer variable type to void* manually, or simply refresh the

decompilation (F5). This causes the decompiler to rerun the type derivation algorithm and update types of automatically
typed variables.

Now the pseudocode more closely reflects what is going on. In particular, we can see that the first comparisons are
checking the IoControlCode against some expected values, which makes more sense than the original LowPart.

CurrentStacklocation = Irp->Tail.Overlay.CurrentStackLocation;
FsContext = CurrentStackLocation->FileObject->FsContext;
Type3InputBuffer = CurrentStacklocation->Parameters.DeviceIoControl. Type3InputBu
InputBufferlength = CurrentStackLocation->Parameters_DeviceloControl.InputBuffer
ToControlCode = CurrentStacklocation->Parameters.DeviceloControl.IoControlCode;
Accesshode = Irp->Requestorflode;
if ( IFsContext )
{
v9 = -1073741595;
goto LABEL_105;
¥
if ( ToControlchde != -1718018045
&& ToControlCode != -1718018041
8& (dword_132CC == 2 || dword_132CC == 3)
&& (*FsContext & 2) == @ )
{

Other uses
Quick rename can be useful when automatic renaming fails due to a name conflict. For example, if we go back to
DriverEntry, we can see that DeviceObject is copied to a temporary variable vé:

v6 = DeviceObject;

DriverObject->MajorFunction[IRP_MJ_CREATE] = KhDispatchCreate;

gword_132D0 = (__int64)v6;

DriverObject->MajorFunction[IRP_MJ_CLOSE] = KhDispatchClose;
DriverObject->MajorFunction[IRP_MJ_DEVICE_CONTROL] = KhDispatchDeviceControl;
DriverObject->DriverUnload = KhUnload;

v6->Flags &= ~0x80u;

We can rename v6 manually, or simply press Shift— N on the assignment and the decompiler will reuse the name with a
numerical suffix to resolve the conflict:

DeviceObjectl = DeviceObject;

DriverObject->MajorFunction[IRP_MJ_CREATE] = KhDispatchCreate;

gword_132D@ = (__int64)DeviceObjectl;
DriverObject->MajorFunction[IRP_MJ_CLOSE] = KhDispatchClose;
DriverObject->MajorFunction[IRP_MJ_DEVICE_CONTROL] = KhDispatchDeviceControl;
DriverObject->DriverUnload = KhUnload;

DeviceObjectl->Flags &= ~0x80u;

1 https://hex-rays.com/products/ida/news/7_6/

2 https://processhacker.sourceforge.io/

3 https://docs.microsoft.com/en-us/windows-hardware/drivers/kernel/irp-major-function-codes

4 https://docs.microsoft.com/en-us/windows-hardware/drivers/kernel/driverentry-s-required-responsibilities
5 https://docs.microsoft.com/en-us/windows-hardware/drivers/ddi/wdm/nc-wdm-driver_dispatch

6 https://hex-rays.com/products/decompiler/manual/cmd_settype.shtml

7 https://docs.microsoft.com/en-us/windows-hardware/drivers/ddi/wdm/ns-wdm-_io_stack_location

8 https://hex-rays.com/products/decompiler/manual/cmd_select_union_field.shtml
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can be useful when you have code which copies data around so the variable names stay the same or
similar. However, sometimes there is a way to get rid of duplicate variables altogether.

Reasons for duplicate variables

Even if in the source code a specific variable may appear only once, on the machine code level it is not always possible.
For example, most arithmetic operations use machine registers, so the values have to be moved from memory to regis-
ters to perform them. Conversely, sometimes a value has to be moved to memory from a register, for example:

taking a reference/address of a variable requires that it resides in memory;

when there are too few available registers, some variables have to be to the stack;

when a calling convention uses stack for passing arguments;

recursive calls or closures are usually implemented by storing the current variables on the stack;
some other situations.

All this means that the same variable may be present in different locations during the lifetime of the function. Although
the decompiler tries its best to merge these different locations into a single variable, it is not always possible, so extra
variables may appear in the pseudocode.

Example
For a simple example, we can go back to DriverEntry in kprocesshacker.sys from the . The initial output looks
like this:

NTSTATUS __stdcall DriverEntry(_DRIVER_OBJECT *DriverObject, PUNICODE_STRING RegistryPath)
{

NTSTATUS result; // eax

NTSTATUS v5; // rild

PDEVICE_OBJECT v6; // rax

struct _UNICODE_STRING DestinationString; // [rsp+40h] [rbp-18h] BYREF

PDEVICE_OBJECT DeviceObject; // [rsp+6@h] [rbp+8h] BYREF

gword_132C@ = (__int64)DriverObject;
VersionInformation.dwOSVersionInfoSize = 284;
result = RtlGetVersion(&VersionInformation);
if ( result >=0 )
{
result = sub_15100(RegistryPath);
if ( result >= 0 )
{
RtlInitUnicodeString(&estinationString, L”\\Device\\KProcessHacker3”);
result = IoCreateDevice(DriverObject, @, &DestinationString, ©x22u, ©x100u, ©, &DeviceObject);
v5 = result;
if ( result >=0 )
{
v6 = DeviceObject;
DriverObject->MajorFunction[@] = (PDRIVER_DISPATCH)&sub_11008;
gword_132D0 = (__int64)v6;
DriverObject->MajorFunction[2] = (PDRIVER_DISPATCH)&sub_1114C;
DriverObject->MajorFunction[14] = (PDRIVER_DISPATCH)&sub_11198;
DriverObject->DriverUnload = (PDRIVER_UNLOAD)sub_150EC;
v6->Flags &= ~0x80u;
return v5;
}
}
}

return result;

}

We can see that there are two variables which look redundant: v5 and vé. v5 is a copy of result which resides in r11d and
v6 is a copy of DeviceObject which resides in rax. It seems they were introduced for related reasons:
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1. The compiler had to move DeviceObject from the stack to a register to initialize the global variable qword_132D0 and
also modify the Flags member. It picked the register rax for that;

2. Because rax already contained the result variable (in the lower part of it: eax), it had to be saved elsewhere in the
meantime (and moved back to eax at the end of manipulations with DeviceObject);

3. The decompiler could not automatically merge DeviceObject with vé because they use different storage types
(stack vs register) and because in theory the writes to Driverobject->MajorFunction could have changed the stack
variable, so the values would not be the same anymore.

Mapping variables

After looking at the code closely, it seems that v5 and vé can be replaced correspondingly by result and DeviceObject in
all cases. To ask the decompiler do it, we can use “ ” action from the context menu.

When you use it for the first time, the following warning appears:

Alternatively, you can use the hotkey = (equals sign); it's best to use it on the initial assignment such as vé = Device0-

bject because then the best match (the other side of assignment) will be preselected in the list of replacement candi-
dates. In our case we get only one candidate, but in big functions you may have several variables of the same type, so
triggering the action on an assignment helps ensure that you pick the correct one.

After mapping both variables, the output no longer mentions them:

NTSTATUS __stdcall DriverEntry(_DRIVER_OBJECT *DriverObject, PUNICODE_STRING RegistryPath)
{

NTSTATUS result; // eax MAPDST

struct _UNICODE_STRING DestinationString; // [rsp+46h] [rbp-18h] BYREF

PDEVICE_OBJECT DeviceObject; // [rsp+6@h] [rbp+8h] MAPDST BYREF

gqword_132C0 = (__int64)DriverObject;
VersionInformation.dwOSVersionInfoSize = 284;
result = RtlGetVersion(&VersionInformation);
if ( result >=0 )
{
result = sub_15100(RegistryPath);
if ( result >= 0 )
{
RtlInitUnicodeString(&DestinationString, L”\\Device\\KProcessHacker3”);
result = IoCreateDevice(DriverObject, @, &DestinationString, ©x22u, ©x100u, ©, &DeviceObject);
if ( result >=0 )
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DriverObject->MajorFunction[@] = (PDRIVER_DISPATCH)&sub_11008;
gword_132D0@ = (__int64)DeviceObject;
DriverObject->MajorFunction[2] = (PDRIVER_DISPATCH)&sub_1114C;
DriverObject->MajorFunction[14] = (PDRIVER_DISPATCH)&sub_11198;
DriverObject->DriverUnload = (PDRIVER_UNLOAD)sub_150EC;
DeviceObject->Flags &= ~@x80u;
}
}
}

return result;

}

You can see that result and DeviceObject variables now have a new annotation®: MAPDST. This means that some other
variable(s) have been mapped to them.

Unmapping variables

If you've changed your mind and want to see how the original pseudocode looked like, or observe something suspicious
in the output involving mapped variables, you can remove the mapping by right-clicking a mapped variable (marked with
MAPDST) and choosing “Unmap variable(s)”.

More info: Hex-Rays interactive operation: Map to another variable®

1 https://hex-rays.com/blog/igors-tip-of-the-week-76-quick-rename/

2 https://en.wikipedia.org/wiki/Register_allocation#Components_of_register_allocation
3 https://hex-rays.com/blog/igors-tip-of-the-week-76-quick-rename/

4 https://hex-rays.com/products/decompiler/manual/cmd_map_lvar.shtml

5 https://hex-rays.com/blog/igors-tip-of-the-week-66-decompiler-annotations/

6 https://hex-rays.com/products/decompiler/manual/cmd_map_lvar.shtml
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During the work with binaries, IDA sometimes shows warnings to inform the user about unusual or potentially dangerous
behavior or asks questions:

Hiding messages

For some of such messages there is a checkbox “Don’t Display this message again”. If you enable it before answering or
confirming the message (hint: you can press ‘D’ to toggle it without the mouse’), IDA will remember your answer and use
it the next time automatically. This can be observed in the log of the Output window?:

Changing the automatic answer

Sometimes you may change your mind and want to pick a different answer. For example, you've answered “No” to the
PDB symbols questions but later you do need to load PDB symbols for a file at load time (Note: it is still possible to do it?
after the fact using the File menu). Currently, there is no per message option but you can reset automatic answers for all
of them using the menu Windows > Reset hidden messages...

After this, IDA will revert to the default settings and once again show all prompts and warnings, giving you a chance to
answer differently.

IDA Help: Reset Hidden Messages?

1 https://hex-rays.com/blog/igor-tip-of-the-week-01-lesser-known-keyboard-shortcuts-in-ida/
2 https://hex-rays.com/blog/igors-tip-of-the-week-43-annotating-the-decompiler-output/

3 https://hex-rays.com/blog/igors-tip-of-the-week-55-using-debug-symbols/

4 https://www.hex-rays.com/products/ida/support/idadoc/1464.shtml
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Previously we’ve discussed how to reduce the number of variables used in pseudocode by copies of a variable
to one. However, sometimes you may run into an opposite problem: a single variable can be used for different purposes.

Reused stack slots
One common situation is when the compiler reuses a stack location of either a local variable or even an incoming stack
argument for a different purpose. For example, in a snippet like this:

vtbl = DiaSymbol->vtbl;
vtbl->get_symTag(DiaSymbol, (int *)&DiaSymbol);
Symbol->Tag = (int)DiaSymbol;

The second argument of the call is clearly an output argument and has a different meaning and type from DiaSymbol
before the call. In such case, you can use the “Force new variable” command (shortcut Shift- F). Due to implementation
details, sometimes the option is not displayed if you right-click on the variable itself; in that case try right-clicking on the
start of the pseudocode line.

The decompiler creates a new variable at the same stack location, initially with the same type:
IDiaSymbol *v14; // [esp+3@h] [ebp+8h] FORCED BYREF

vtbl = DiaSymbol->vtbl;
vtbl->get_symTag(DiaSymbol, (int *)&v14);
Symbol->Tag = (int)vi4;

Naturally, you can change its type and name to a better one:
int tag; // [esp+36h] [ebp+8h] FORCED BYREF

vtbl = DiaSymbol->vtbl;
vtbl->get_symTag(DiaSymbol, &tag);
Symbol->Tag = tag;

Using a union to represent a polymorphic variable
Unfortunately, “Force new variable” is not available for register variables (as of IDA 7.7). In such case, using a union may
work. For example, consider this snippet from ntd11.d11‘s LdrRelocateImage function:

int v6; // esi
int v7; // eax
int v8; // edi
int v9; // eax

V6 = 0;

v20 = 0;

v7 = RtlImageNtHeader(al);
v8 = Vv7;

if ((Iv7)

return -1073741701;
v9 = *(unsigned __intl6 *)(v7 + 24);
if ( v9 == IMAGE_NT_OPTIONAL_HDR32_MAGIC )
{

v18 = *(_DWORD *)(v8 + 52);

vl = 0;
}
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else
{
if ( v9 != IMAGE_NT_OPTIONAL_HDR64 MAGIC )
return -1073741701;
v18 = *(_DWORD *)(v8 + 48);
v16 = *(_DWORD *)(v8 + 52);

}

The function Rt1ImageNtHeader returns a pointer to the IMAGE_NT_HEADERS structure of the PE image at the given address.
After changing its prototype and types of the variables, the code becomes a little more readable:

int v6; // esi

PIMAGE_NT_HEADERS v7; // eax
PIMAGE_NT_HEADERS v8; // edi

int Magic; // eax

int v10; // edx

int v11; // eax

unsigned int v12; // ecx

int v13; // ecx

int v15; // [esp+Ch] [ebp-16h]

unsigned int v16; // [esp+1@h] [ebp-Ch]
int v17; // [esp+1@h] [ebp-Ch]

unsigned int v18; // [esp+14h] [ebp-8h]
char *v19; // [esp+14h] [ebp-8h]

int v20; // [esp+18h] [ebp-4h] BYREF

V6 = 0;

V20 = 0;

v7 = RtlImageNtHeader(al);
v8 = v7;

if (Iv7)

return -1073741701;
Magic = v7->OptionalHeader.Magic;
if ( Magic == IMAGE_NT_OPTIONAL_HDR32_MAGIC )

{ v18 = v8->0OptionalHeader.ImageBase;
vl6 = 0;

}

else

{

if ( Magic != IMAGE_NT_OPTIONAL_HDR64 MAGIC )
return -1073741701;

v18 = v8->OptionalHeader.BaseOfData;

v16 = v8->OptionalHeader.ImageBase;

}

However, there is a small problem. Judging by the checks of the magic value, the code can handle both 32-bit and 64-bit
images, however the current PIMAGE_NT_HEADERS type is 32-bit (PIMAGE_NT_HEADERS32) so the code in the else clause is
likely incorrect. If we change v8 to PIMAGE_NT_HEADERS64, then the if clause becomes incorrect:

if ( Magic == IMAGE_NT_OPTIONAL_HDR32_MAGIC )

{ ImageBase = HIDWORD(v8->OptionalHeader.ImageBase);
vlé = 0;

}

else

{

if ( Magic != IMAGE_NT_OPTIONAL_HDR64_ MAGIC )
return -1073741701;

ImageBase = v8->OptionalHeader.ImageBase;

v16 = HIDWORD(v8->OptionalHeader.ImageBase);

}
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We can’t force a new variable because v8 is allocated in a register and not on stack. Can we still use both types at once?
The answer is yes: we can use a union which combines both types. Here’s how it can be done in this example:

1. Open Local Types (Shift-F1);
2. Add a new type (Ins);
3. Enter this definition:

union nt_headers
{

PIMAGE_NT_HEADERS32 hdr32;
PIMAGE_NT_HEADERS64 hdr64;

s

4. change type of v8 to nt_headers and use “Select Union Field?” to pick the correct field in each branch of the if:

Magic = v7->OptionalHeader.Magic;

if ( Magic == IMAGE_NT_OPTIONAL_HDR32_MAGIC )

{
ImageBase = v8.hdr32->0OptionalHeader.ImageBase;
ImageBaseHigh = 0;

}

else

{
if ( Magic != IMAGE_NT_OPTIONAL_HDR64 MAGIC )

return -1073741701;

ImageBase = v8.hdré64->0ptionalHeader.ImageBase;
ImageBaseHigh = HIDWORD(v8.hdré4->OptionalHeader.ImageBase);

}

In this specific example the difference is minor and you could probably get by with some comments, but there may be
situations where it makes a real difference. Note that this approach can be used for stack variables too.

See also: Hex-Rays interactive operation: Force new variable3

1 https://hex-rays.com/blog/igors-tip-of-the-week-77-mapped-variables/
2 https://hex-rays.com/blog/igors-tip-of-the-week-75-working-with-unions/
3 https://www.hex-rays.com/products/decompiler/manual/cmd_force_lvar.shtml
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In addition to comments’, IDA offers a few more features for annotating and quickly navigating in the database. Today
we'll cover bookmarks.

Adding bookmarks

Bookmarks can be added at most locations in the address-based views (disassembly listing, Hex View, Pseudocode), as
well as Structures and Enums. This can be done via the Jump > Mark position... menu, or the hotkey Al1t- M. You can enter
a short text to describe the bookmark which will then be displayed in the bookmark list.

In the disassembly listing, bookmarks can be quickly added while in the text view by clicking to the left of the breakpoint
circles in the execution flow arrows panel. In that case, the bookmark description will contain only the address and the
label, if any. Active bookmarks are marked with the an icon which can be clicked again to remove them. Hover the mouse
over the icon to see the bookmark’s description.

Managing and navigating bookmarks

To see the list of bookmarks and quickly jump to any of them, use Jump > Jump to &marked position... menu, or the Ctrl-
M hotkey. This dialog can also be used to delete or edit bookmarks via the context menu or hotkeys (Del and Ctrl-E,
respectively).

However, if you add many bookmarks, it can get difficult to find the one you need, so in IDA 7.6% we’'ve added a dedicated
bookmarks view as well as the possibility to group bookmarks into folders. The new view is available via View > Open
subviews > Bookmarks, or Ctrl- Shift— M shortcut. The window is non-modal and can be docked.

1 https://hex-rays.com/blog/igors-tip-of-the-week-50-execution-flow-arrows/
2 https://hex-rays.com/products/ida/news/7_6/
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There are multiple ways of annotating IDA databases: renaming, commenting’, or adding bookmarks? However, some-
times there is a need for general notes for the database as a whole, not tied to specific locations.

Notepad window
The database notepad is a text input box which can store arbitrary text within the database, so you can add your notes

and thoughts there instead of using separate software.
It can be opened using the menu View > Open subview > Notepad.

There is no built-in shortcut for quick access, but you can add one?®, or open the Quick view” (Ctrl- 1), type “no” to select
the entry and Enter to activate it.

1 https://hex-rays.com/blog/igor-tip-of-the-week-14-comments-in-ida/

2 https://hex-rays.com/blog/igors-tip-of-the-week-80-bookmarks/

3 https://hex-rays.com/blog/igor-tip-of-the-week-02-ida-ui-actions-and-where-to-find-them/
4 https://hex-rays.com/blog/igors-tip-of-the-week-30-quick-views/
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The default output of the Hex-Rays decompiler tries to strike a balance between conciseness and readability. However,
everyone has different preferences so it offers a few options to control the layout and formatting of the pseudocode.

Accessing the options
Because of its origins as a third-party plugin for IDA, the decompiler options are accessible not through IDA’s Options

menu, but via Edit > Plugins > Hex-Rays Decompiler, Options button

Pseudocode formatting options
Formatting options are available on the main page of the options dialog.

¢ Comment indent: starting position for regular (end-of-line) comments. Obviously, for longer lines the comment will
be shifted further to the right. Elock comments' are aligned to the statement they’re attached to so this setting does

not apply to them.

¢ Block indent: indentation for nested statements, e.g. inside if statements or for/do/while loop bodies.
¢ Right margin: the decompiler tries to keep the pseudocode line length under the specified length. For example, it
will try to split a function call with many arguments by putting them on separate lines:
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void *handle; // r4

TickType_t TickCountFromISR; // r@

BaseType_t v5; // r4

TickType_t TickCount; // r©

0SStatus result; // r@

int xHigherPriorityTaskWoken; // [sp+Ch] [bp-Ch] BYREF

v2 = platform_is_in_interrupt_context();
handle = timer->handle; // comment ©
if (v2 ==1)

// block comment
TickCountFromISR = xTaskGetTickCountFromISR();// comment 1
v5 = xTimerGenerikCommand(

handle,
6,
TickCountFromISR,
&xHigherPriorityTaskWoken,
0); // comment 2
if ( xHigherPriorityTaskWoken ) // comment 3
vTaskSwitchContext(); // comment 4

}

else
{
TickCount = xTaskGetTickCount();
v5 = xTimerGenericCommand(
handle,
1,
TickCount,
9,
OxFFFFFFFF);
}
result = v5 - 1;
if (w5 1=1)
return -1;
return result;

Note that in some cases you may still see lines longer than the specified margin because it’s not always possible to
break a long line so that it remains valid C.

e Max strlit len: maximum length of a string constant displayed directly (inline) in the pseudocode. A constant longer
than this value will be replaced by a name referring to it.

¢ Max commas: how many comma operators? the decompiler can use in one expression to make the code more
compact. By reducing this value, you should see simpler expressions at the cost of more lines of code: more/deeper
nested if statements, extra variables for intermediate results, or even additional goto statements.
For example, here’s a fragment of pseudocode with a comma statement inside the if condition:

After changing max commas to 1, the comma disappears at the cost of additional if and goto statements:
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Changing the defaults

When changing the settings from inside IDA using the Ul described above, they apply only to the current database. To
change the defaults for all new databases, either edit cfg/hexrays.cfgin IDA’s install directory, or create one in the user
directory® with the options you want to override.

Related options
Extra empty lines can be added to the pseudocode to improve readability. This feature was described in the tip #43
(Annotating the decompiler output?).

More info: Configuration (Hex-Rays Decompiler User Manual)52

1 https://hex-rays.com/blog/igors-tip-of-the-week-43-annotating-the-decompiler-output/
2 https://en.cppreference.com/w/c/language/operator_other#Comma_operator

3 https://hex-rays.com/blog/igors-tip-of-the-week-33-idas-user-directory-idausr/

4 https://hex-rays.com/blog/igors-tip-of-the-week-43-annotating-the-decompiler-output/
5 https://www.hex-rays.com/products/decompiler/manual/config.shtml
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We've covered the major pseudocode formatting options previously but there is one more option which can influence the
output. It is the radix used for printing numbers in the pseudocode.

In a positional numeral system, the radix or base is the number of unique digits, including the digit zero, used to represent numbers.
For example, for the decimal/denary system (the most common system in use today) the radix (base number) is ten, because it uses
the ten digits from O through 9.

(from )

Automatic radix
The default radix setting is 0, which means “automatic”.

With this setting, the decompiler uses hexadecimal radix for values detected as unsigned, and decimal otherwise. For
example, in the below screenshot, arguments to CContextMenuManager: : AddMenu() are shown in hex because the function
prototype specifies the last argument type as “unsigned int”, while those for LoadStringA() are in decimal because the
decompiler used a guessed prototype with the type which behaves like a signed type.

“Nice” numbers
In some cases, the decompiler may use hex even for signed numbers if it makes the number look “nice”. Currently (as of
IDA 7.7), the following rules are used:

1. values matching 2" and 2"-1 (typical bitmasks) are printed as hexadecimal.

2. 64-bit values which have not all-zero or all-one high 32 bits are printed as hexadecimal unless they end with more
than 3 zeroes in decimal representation.

3. -1is printed as decimal.

Changing the radix manually
You can always change the representation for a specific number in pseudocode from the context menu or via a hotkey.

To toggle between decimal and hex, use the H hotkey. Octal is available only via the context menu by default, but it’s
possible to add a for the action name hx:0ct.
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Setting preferred radix
By changing Default radix in the decompiler options, you can have decompiler always use decimal (10) or hexadeci-
mal(16) for all numbers without an explicitly set radix. Note that in this case the “nice” number detection will be disabled.

To change the default for all new databases, set the value DEFAULT_RADIX in hexrays.cfg as described in the previous
post4.

More info: Configuration (Hex-Rays Decompiler User Manual)®

1 https://en.wikipedia.org/wiki/Radix

2 https://hex-rays.com/blog/igors-tip-of-the-week-45-decompiler-types/

3 https://hex-rays.com/blog/igor-tip-of-the-week-02-ida-ui-actions-and-where-to-find-them/

4 https://hex-rays.com/blog/igors-tip-of-the-week-82-decompiler-options-pseudocode-formatting/
5 https://www.hex-rays.com/products/decompiler/manual/config.shtml



#84:

08 Apr2022

& https://hex-rays.com/blog/igors-tip-of-the-week-84-array-indexes/

We've covered arrays previously’, but one feature briefly mentioned there is worth a separate highlight.

Complex programs may use arrays of data, either of items such as integers or floats, or of complex items such as
structures. When the arrays are small, it’s not too difficult to make sense of them, but what to do if your task requires, for
example, to find the value of the item #567 in a 3000-item array?

You can of course try to count the items manually or copy the array into a text editor (=xport Data? can help here) and
import into a spreadsheet but there are ways to do it inside IDA without too much trouble.

Resizing the array
Let’s say we have an array of 88 items:

and we need the item #25. Manual counting is possible but tedious, especially because we need to account for the
repeated items in the dup expressions. There is a different approach to solve this. Because the items are counted from O
and we have 88 of them, the last one has index 87. To make it so that the last item is number 25, we can resize the array
to 26(25+1) items. For this, press * to open the array parameters dialog and change the Array size field:

Now the array contains 26 items from #0 to #25 so we can see that the item we needed has the value 35h.

Array index display
Alternatively, we can enable the Display indexes option.
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With the option on, index of the first element is displayed as a comment for each line:

While still not very obvious, it is a little easier to find the necessary element by counting from the start of a line. You can
also set the ltems on a line value to 1 or another small value so that each line contains fewer elements and it’s easier to
find the necessary one.

Indexes and arrays of structures

When you have an array of structures and they can be displayed in terse form?, the indexes are printed for each line
similarly to the array of simple values.

However, if you unhide/uncollapse the array to show the structs in verbose form, each field gets a comment with an array
notation:

See also: IDA Help: Convert to array?

1 https://hex-rays.com/blog/igor-tip-of-the-week-10-working-with-arrays/

2 https://hex-rays.com/blog/igors-tip-of-the-week-39-export-data/

3 https://hex-rays.com/blog/igors-tip-of-the-week-31-hiding-and-collapsing/
4 https://www.hex-rays.com/products/ida/support/idadoc/455.shtml
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Although IDA has been created first and foremost to analyze binaries in “black box” mode, i.e. without any symbols or
debug information, it does have the ability to

The debugger functionality was also initially optimized to debug binaries on the assembly level, but nowadays can work
with source code too.

Source-level debugging
Source-level debugging is enabled by default but can be turned off or on manually via Debugger > Use source-level
debugging menu item, or the button on the Debug toolbar.

If the input file has debugging info in the format supported by IDA (e.g. PDB or DWARF), it will be automatically used
when the debugging starts and the code being executed is covered by the debug info.

Source code files

If source files are present in the original locations, IDA will open them in separate source view windows and highlight

the currently executing line. The assembly instructions are still shown in the IDA View, and you can continue to use it

for analysis independently of source code view. Note that IDA may automatically switch to disassembly when stepping
through instructions which do not have a correspondence in the source code (for example, compiler helper functions, or
auxiliary code such as prolog or epilog instructions).

When, after stepping through disassembly, the execution returns to the area covered by the source code, you can ask
IDA to show the corresponding source code again via the action Debugger > Switch to source (also available in context
menu and toolbar). This action can be used even for code away from the current execution point.

Source path mappings

Sometimes the source code corresponding to the binary may be available but in a different location from what is record-
ed in the debug info (e.g. you may be debugging the binary on a different machine or even remotely from a different OS).
The files which were not found in expected location are printed in Output window:
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warning: read file failed: source file not found: minkesrnelcrts\ucrthinchcorecrt internal stdic_output.h
warning: read file failed: source file not found: minkernel\crts\ucrt\inc\corecrt_internal stdio_output.h
warning: read file failed: source file hoc found: minkernslhcrts\ucrriinchcorecrt_internal stdio_output.h
. n

h

warning: read file failed: source file not found: minkernel\crts\ucrtlinc\corecrt_internal stdio_output.

warning: read_file failed: source file not found: minkernel\crts\ucrtlinc\corecrt_internal_ stdio_output.

Using Options > Source paths..., you can set up mappings for IDA to find the source files in new locations.

Locals
When the debug info includes information about local variables, IDA can use it to show their values. A short, one-line
version is shown when you hover mouse over the variables in source code view.

const pylib entry t &e = entries.entries[i];
out("#%" FMT_Z ": %s (%s)\n",

L |9x1AEDBSF5FASiE4 t{version={major=3,mincr=8xA,revision=8,mo
e.version.str(&buf), T

For more complex objects it may be more convenient to open the dedicated view where you can expand and inspect
fields and sub-objects. This view is available via the menu Debugger > Debugger windows > Locals.

Watches

In addition to locals, you can also watch only specific variables you need instead of all locals, or values of global vari-
ables. This view can be opened via Debugger > Debugger windows > Watch view. Variables can be added using Ins or
context menu.
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Debugging pseudocode

Even if you don’t have debug info for the code you’re debugging but do have a decompiler, it is possible to debug
pseudocode as if it were a source file. IDA will automatically use pseudocode if source-level debugging is enabled but
there is no debug info for the specific code fragment you're stepping through. You can also always switch to pseudo-
code during debugging using the usual Tab hotkey. Locals, Watches, and source-level breakpoints are available when
debugging pseudocode in the same way as with “real” source code.

P.S. attentive reader may discover an additional surprise in this post. Happy Easter!

1 https://hex-rays.com/blog/igors-tip-of-the-week-55-using-debug-symbols
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In IDA, function is a sequence of instructions grouped together. Usually it corresponds to a high-level function or

it can be called from other places in the program, usually using a dedicated processor instruction;
it has an entry and one or more exits (instruction(s) which return to the caller);

it can accept arguments (in registers or on the stack) and optionally return values;

it can use local (stack) variables.

HON

However, IDA’s functions can group any arbitrary sequence of instructions, even those not matching the above criteria.
The only hard requirement is that the function must start with a valid instruction.

Creating functions

IDA usually creates functions automatically, based on the call instructions or debug information, but they can also be
created manually using the Create Function action (under Edit > Functions or from context menu), or P shortcut. This can
be done only for instructions not already belonging to functions. By default IDA follows the cross-references and tries

to determine the function boundaries automatically, but you can also a range beforehand to force creation of a
function, for example, if there are some invalid instructions or embedded data.

Function range
In the most common case, a function occupies a contiguous address range, from the entry to the last return instruction.
This is the start and end address specified in function properties available via the Edit Function dialog (A1t-P).

Chunked functions

A single-range function is not the only option supported by IDA. In real-life programs, a function may be split into several
disjoint ranges. For example, this may happen as a result of , which can put cold (rarely exe-
cuted) basic blocks into a separate part of binary from hot (often executed) ones. In IDA, such functions are considered
to consist of multiple chunks (each chunk being a single contiguous range of instructions). The chunk containing the
function entry is known as entry chunk, while the others are called tail chunks or simply tails.

In disassembly view, the functions which have additional chunks have additional annotations near the function’s entry,
listing the tail chunks which belong to the function.

The tail chunks themselves are marked with “START OF FUNCTION CHUNK” and “END OF FUNCTION CHUNK”
annotations, mentioning which function they belong to. This is mostly useful in text view, as in the graph view they are
displayed as part of the overall function graph.
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Sometimes a tail chunk may be shared by multiple functions. In that case, one of them is designated tail owner and oth-
ers are considered additional parents. Such chunk will appear in the function graph for every function it belongs to.

Managing chunks manually

Usually IDA handles chunked functions automatically, either detecting them during autoanalysis or by making use of
other function range metadata (such as .pdata function descriptors in x64 PE files, or debug information). However,
there may be situations where you need to add or remove chunks manually, for example to fix a false positive or handle
an unusual compiler optimization.

To remove (detach) a tail chunk, position cursor inside it and invoke Edit > Functions > Remove function tail. If the tail has
only one owner, it will be removed immediately and converted to standalone instructions (not belonging to any function).
If it has multiple owners, IDA will offer you to choose from which function(s) it should be detached.

To add a range of instructions as a tail to a function, select the range and invoke Edit > Functions > Append function tail,
then select a function to which it should be added. This can be done multiple times to attach a tail to several functions
(whole tail must be selected again in such case).

More info:
IDA Help: Append Function Tail4
IDA Help: Remove Function Tail®

1 https://en.wikipedia.org/wiki/Subroutine

2 https://hex-rays.com/blog/igor-tip-of-the-week-03-selection-in-ida/

3 https://devblogs.microsoft.com/cppblog/profile-guided-optimization-pgo-under-the-hood/
4 https://www.hex-rays.com/products/ida/support/idadoc/687.shtml

5 https://www.hex-rays.com/products/ida/support/idadoc/688.shtml
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We've covered function chunks and today we’ll show an example of how to use them in practice to handle a
common compiler optimization.

Shared function tail optimization
When working with some ARM firmware, you may sometimes run into the following situation:

We have decompilation of sub_8098C which ends with a strange JUMPOUT statement and if we look at the disassembly, we
can see that it corresponds to a branch to a POP.W instruction in another function (sub_8092C). What happened here?

This is an example of a code size optimization. The POP.W instruction is 4 bytes long, while the B branch is only two, so by
reusing it the compiler saves two bytes. It may not sound like much, but such savings can accumulate to something sub-
stantial over all functions of the binary. Also, sometimes longer sequences of several instructions may be reused, leading
to bigger savings.

Can we fix the database to get clean decompilation and get rid of JuUMPOUT? Of course, the answer is yes, but the specific
steps may be not too obvious, so let’'s describe some approaches.

Creating a chunk for the shared tail instructions

First we need to create a chunk for the shared instructions (in our example, the POP.W instruction). A chunk can be cre-
ated only from instructions which do not yet belong to any function, thus the easiest way is to delete the function so that
instructions become “free”. This can be done either from the Functions window, via Edit > Functions > Delete function
menu entry, or from the modal “jump to function” list (Ctrl- P, Del ).

Once deleted, the shared tail instructions can be added as a chunk to the other function. This can be done manually:

1. select the instruction(s),
2. invoke Edit > Functions > Append function tail...
3. pick the referencing function (in our case, sub_8098C). Normally IDA should suggest it automatically.

Or (semi)automatically:

1. jump to the referencing branch (e.g. by double-clicking the CODE XREF: sub_8098C+3E!j comment)
2. the branch (press C). IDA will detect that execution continues outside the current function bounds and
automatically create and add the chunk for the shared tail instructions.
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Either solution will create the chunk and mark it as belonging to the referencing function.

We can check that it is contained in the function graph:

And the pseudocode no longer has a JUMPOUT:

Attaching the chunk to the original function
We “solved” the problem for one function, but in the process we’ve destroyed the function which contained the shared
tail. If we need to decompile it too, we can try to recreate it:
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However, IDA ends it before the chunk, because it's now a part of another function:

And if we decompile it, we get the same JUMPOUT issue:

The solution is simple: as mentioned in the previous post, a chunk may belong to multiple functions, so we just need to
attach the chunk to this function too:

1. Select the instructions of the tail;
2. invoke Edit > Functions > Append function tail...
3. select the recreated function (in our example, sub_8092C).

The chunk gains one more owner, appears in the function graph, and the decompilation is fixed:

Complex situations
The above example had a tail shared by two functions, but of course this is not the limit. Consider this example:
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Here, the POP.W instruction is shared by seven functions, and two of them also reuse the ADD SP, SP, #9x10 instruction
preceding it. There is also a chunk which belongs only to one function but it had to be separated because the function
was no longer contiguous. Still, IDA’s approach to fragmented functions was flexible enough to handle it with some man-
ual help and all involved functions have proper control flow graphs and nice decompilation.

To summarize, the suggested algorithm of handling shared tail optimization is as follows:
1. Delete the function containing the shared tail instructions.

2. Attach the shared tail instructions to the other function(s) (manually or by reanalyzing the branches to the tail).
3. Recreate the deleted function and attach the shared tail(s) to it too.

1 https://hex-rays.com/blog/igors-tip-of-the-week-86-function-chunks/
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We've mentioned before but today we’ll use a specific one to find the Easter egg hidden in the

More specifically, it was this screenshot:

The function surprise calls printf, but the arguments being passed to it seem to all be numbers. Doesn’t printf() usu-
ally work with strings? What’s going on?

Numbers and characters

As you probably know, computers do not actually distinguish numbers from characters - to them they’re all just a set of
bits. So it’s all a matter of interpretation or representation. For example, all of the following are represented by the same
bit pattern:

65 (decimal number)
. Ox41, 41h, H’ 41 (hexadecimal number)
. 9101 or 1010 (octal number)
. 1000001b or 8b1000001 (binary number)
. ‘A’ (ASCII character)
. WM_COMPACTING (Win32 API constant)
. (and many other variations)

NoOoOo~ONDA

Character operand representation
In fact, listing in the screenshot has been modified from the defaults to make the Easter egg less obvious. Here’s the
original version as text:

.text:00401010 ; int surprise(...)
.text:00401010 _surprise proc near ; CODE XREF: _mainftp
.text:00401010

.text:00401010 var_24= dword ptr -24h
.text:00401010 var_20= dword ptr -20h
.text:00401010 _Format= byte ptr -1Ch
.text:00401010 var_18= dword ptr -18h
.text:00401010 var_14= dword ptr -14h
.text:00401010 var_10= dword ptr -10h
.text:00401010 var_C= dword ptr -0Ch
.text:00401010 var_8= dword ptr -8
.text:00401010 var_4= dword ptr -4
.text:00401010

.text:00401010 sub esp, 24h

.text:00401013 mov eax, __ security cookie
.text:00401018 xor eax, esp

.text:0040101A mov [esp+24h+var_4], eax
.text:0040101E lea eax, [esp+24h+var_24]

.text:00401021 mov dword ptr [esp+24h+_Format], 70747468h
.text:00401029 push eax

.text:0040102A lea eax, [esp+28h+_Format]

.text:0040102E mov [esp+28h+var_18], 2F2F3A73h
.text:00401036 push eax ; _Format
.text:00401037 mov [esp+2Ch+var_14], 2D786568h
.text:0040103F mov [esp+2Ch+var_10], 73796172h
.text:00401047 mov [esp+2Ch+var_C], 6D6F632Eh

.text:0040104F mov [esp+2Ch+var_8], 73252Fh
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.text:00401057 mov [esp+2Ch+var_24], 74736165h
.text:0040105F mov [esp+2Ch+var_20], 7265h
.text:00401067 call _printf

.text:0040106C mov ecx, [esp+2Ch+var_4]
.text:00401070 add esp, 8

.text:00401073 xor ecx, esp ; StackCookie
.text:00401075 xor eax, eax
.text:00401077 call @__security_check_cookie@4 5 __security_check_cookie(x)

.text:0040107C add esp, 24h
.text:0040107F retn
.text:0040107F _surprise endp

In hexadecimal it’s almost immediately obvious: the “numbers” are actually short fragments of ASCII text. The code is
building strings on the stack piece by piece. This can be made more explicit by converting numbers to the character
operand type (shortcut R).

To help you decide whether such operand type makes sense, IDA shows a preview in the context menu:

This way it’s pretty clear that the “humber” is actually a text fragment. After converting all “numbers” to character con-
stant, a pattern begins to emerge:

Due to the little-endian memory organization of the x86 processor family, the individual fragments have to be read back-
wards (i.e. character literal ‘ptth’ corresponds to the string fragment “http”).

Decompiler and optimized string operations
Now it’s almost obvious what the result is supposed to be but there’s in fact an even easier way to discover it.

Because the approach of processing short strings in register-sized chunks is often used by compilers to implement
common C runtime functions inline instead of calling the library function, the decompiler uses heuristics to detect such
code patterns and show them as equivalent function calls again. If we decompile this function, the decompiler reassem-
bles the strings and shows them as if they were like that in the pseudocode:
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int surprise()

char v1[8]; // [esp+Bh] [ebp-24h] BYREF
char _Format[24]; // [esp+8h] [ebp-1Ch] BYREF

strcpy(_Format, "https://hex-rays.com/¥s");
strepy(vl, "easter™);

vi[7] = "\8";

printf({_Format, v1);

return @;

Stack strings

Malware often uses a similar approach of building strings by small pieces (most often character by character) on the
stack because this way the complete string does not appear in the binary and can’t be discovered by simply searching
for it. Thanks to the automatic comments shown by IDA for operands not having explicitly assigned type, they are usually
obvious in the disassembly:

Jtext: 28482288 push ebp

Ltext: 28482281 mov ebp, esp
.text:88482283 sub esp, 28h
.text:@8402286 mov [ebp+var_28], 46h ; 'F’
Ltext: 88482284 mov [ebp+var_27], 4Ch ; "L’
.text:8848228E mov [ebp+var_26], 41h ; "A°
Ltext:884822C2 mov [ebp+var_25], 47h ; "G’
Jtext:0e402206 mov [ebptvar_24], 78h ; "{’
Ltext:@84822CA mov [ebp+var_23], 53h ; 'S’
Ltext:@84822CE mov [ebp+var_22], 54h ; 'T’
Ltext: 08482202 mov [ebp+var_21], 41h ; "A&°
.text:88402206 mov [ebp+var_28], 43h ; 'C’
Ltext: 28482204 mov [ebp+var_1F], 4Bh ; "K'
.text:8848220E mov [ebp+var_ 1E], 2Dh ; "-'
Ltext:@84822E2 mov [ebp+var_1D], 53h ; 'S’
Jtext:884822E6 mov [ebp+var_1C], 54h ; 'T’
Ltext:@84822EA mov [ebp+var_1B], 52h ; 'R’
Ltext:@84822EE mov [ebp+var_1A], 4%h ; "I’
Ltext:@84822F2 mov [ebp+var_19], 4Eh ; "W’
Ltext:@84822F6 mov [ebp+var_18], 47h ; "G’
Ltext:@84822FA mov [ebp+var_17], 53h ; 'S’
Ltext:@84822FE mov [ebp+var_16], 2Dh ; "-'
Ltext:88482382 mov [ebp+var_15], 41h ; "A’
Ltext:88482306 mov [ebp+var_14], 52h ; 'R’
Jtext:0e4e2304 mov [ebp+var_13], 45h ; "E’
Ltext:@848230E mov [ebp+var_12], 2Dh ;
Ltext: 28482312 mov [ebp+var_11], 42h ;
Ltext: 28482316 mov [ebp+var_18], 45h ; 'E
Ltext: 28482314 mov [ebp+var_F], 53h ; 'S’
.text:8848231E mov [ebp+var_E], 54h ; 'T'
Ltext:88482322 mov [ebp+var D], 2Dh ; "-'
Ltext:88482326 mov [ebp+var €], 53h ; 'S’
Ltext:@e482324 mov [ebp+var_EB], 54h ; 'T"
Jtext:0848232E mov [ebp+var_al, 52h ; 'R’
Ltext: 28482332 mov [ebp+var_9], 4%h ; 'I'
Ltext: 28482336 mov [ebp+var_8], 4Eh ; "N’
Ltext: 28482334 mov [ebp+var_7], 47h ; 'G’
Ltext:@848233E mov [ebp+var_6], 53h ; 'S’
Ltext:28482342 mov [ebp+var_ 5], 7Dh ; '}'
Jtext:88482346 lea eax, [ebp+var_28]

And the decompiler easily recovers the complete string:

void _ noreturn start()

{
char vO[36]; // [esp+6h] [ebp-28h] BYREF

gmemcpy (v0, “FLAG{STACK-STRINGS-ARE-BEST-STRINGS}”, sizeof(ve));
[...]

}

P.S. If you want to play with the Easter egg binary and reproduce the results in this post, download it here:easter2022.
Zip3

1 https://hex-rays.com/blog/igors-tip-of-the-week-46-disassembly-operand-representation/
2 https://hex-rays.com/blog/igors-tip-of-the-week-85-source-level-debugging/
3 https://hex-rays.com/wp-content/uploads/2022/05/easter2022.zip
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Last time we used operand types to make a function more readable and understand its behavior better. Converting op-
erands one by one is fine if you need to do it a few times, but can quickly get tedious if you need to do it for a long piece
of code.

En masse operation
To convert operands of several instruction at once, before triggering the operation (either using the corre-
sponding hotkey (e.g. R), or from the Edit > Operand type menu.

If you have a selection when triggering one of these actions, it won’t be performed immediately but another dialog will
pop up first:

Here, you can tell IDA which operands you want to actually convert. The following options are available:

¢ All operands: all operands of selected instructions will be converted to the selected type (or back to the default/
number type if they already had the chosen type);

e Operand value range: only operands with values between Lower value and Upper value below will be converted. For
example, you could enter ‘0x20’ and ‘Ox7F’ to have IDA only consider single ASCII characters like the last example
from the ;

o <type> operands: only convert operands which already have the selected type (they will be converted back to the
default/number type);

¢ Not <type> operands: only convert operands not already having the selected type. Both untyped and having another
type (e.g. decimal/enum/offset) operands will be converted to the desired type;

¢ Not typed operands: only convert operands not assigned a specific type (default/number). All operands already
having an assigned type will be left as is.

P.S. you can use this feature not only with instructions but also data. For example, for converting several separate inte-
gers in the data section to decimal or octal. In such case, the ‘operands’ will be the data items.

See also:

1 https://hex-rays.com/blog/igor-tip-of-the-week-03-selection-in-ida/
2 https://hex-rays.com/blog/igors-tip-of-the-week-88-character-operand-type-and-stack-strings/
3 https://hex-rays.com/products/ida/support/idadoc/459.shtml
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Although in general case the problem of correct disassembly is unsolvable, in practice it can get pretty close. IDA uses
various heuristics to improve the disassembly and make it more readable, such as converting numerical values to offsets
when it “looks plausible”. However, this is not always reliable or successful and it may miss some. To help you improve
things manually, in some cases IDA can give you a hint.

Suspiciousness Limits
In IDA’s Options dialog on the Disassembly tab, there are two fields: Low suspiciousness limit and High suspiciousness
limit. What do they mean?

Whenever IDA outputs an instruction operand with the numerical value in that range, and it does not yet have an explicit-
ly set type (i.e. it has the default AKA void type), it will use a special color (orange in the default color scheme):

In such situation, you could, for example, hover your mouse’ over the value to see if the target looks like a valid destina-
tion, and convert it to an offset either using a hotkey (O) or via the context menu.

Changing the Suspiciousness Limits

Initial values of the limits are taken from the input file’s loaded address range. If the valid address range changes (for
example, if you rebase the database or create additional segments), it may make sense to update the ranges so you can
see more of potential addresses. Conversely, you can also change the values to exclude some ranges which are unlikely
to be valid addresses to reduce the false positives.

See also: IDA Help: Low & High Suspicious Operand Limits?

1 https://hex-rays.com/blog/igors-tip-of-the-week-47-hints-in-ida/
2 https://www.hex-rays.com/products/ida/support/idadoc/606.shtml
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When changing operand representation’, you may need to check what are the operand types currently used by IDA for
a specific instruction. In some cases it is obvious (e.g. for offset or character type), but the hex and default, for example,
look exactly the same in most processors so it’s not easy to tell them apart just by look.

Internally, this information is stored by IDA in the item flags. To check the current flags of an instruction (or any other
address) in the database, use View > Print internal flags (hotkey F) .

When you invoke this action, IDA prints flags for the current address to the Output window. It only prints info about
non-default operand types — the default ones are omitted (except for suspicious operands? which are printed as void).

Output
s
code flow
code flow immd_arg l:|vuid 2:void 3:void 4:void S5:void &:void
code flow immd arg
code flow immd arg l:stkvar Z:stkvar 3:stkvar 4:stkvar S:stkvar 6:stkvar
code flow
code flow immd arg 1:0FF32 base=0 OUTER OFF32 base=0 2:0ff(?) 3:0ff(?) 4:0ff(?) S5:0ff(?) 6:0ff(?)
code flow immd arg 1:0FF32 base=0 COULER OFF32 base=0 2:0ff(?) 3:o0ff(?) 4:0ff(?) S5:0ff(?) 6:0ff(?)

code and flow are generic instruction flags: they mean that the current item is marked as code (instruction) and the exe-
cution reaches it from the previous address (this is the case for most instructions in the program).

Whenever IDA prints information about the second operand (number 1 since they are counted from 0), the operands
2,3...6 (even if they do not actually exist) are also printed as having the same type. This happens because of a limitation

in IDA: it originally supported user-specified representation only for two operands (0 and 1) and this limitation is not com-
pletely lifted yet as of IDA 7.7.

Besides operand types, the feature may show other low-level info about the current address: for example, the type infor-
mation if it’s set for current location, the function arguments layout similarly to what you can see in decompiler annota-
tions®, structure name for structure data items, and so on.

[sub_30DDFF] code func xrefd

type: int _ cdecl su.b_30DDFFtint}|
0: 0004 ~0.4 int;
RET 0004 eax int;
TCOTAL STERRGS SIZE: 4

ti hr determined

function does not modify the stack

1 https://hex-rays.com/blog/igors-tip-of-the-week-46-disassembly-operand-representation/
2 https://hex-rays.com/blog/igors-tip-of-the-week-77-mapped-variables/
3 https://hex-rays.com/blog/igors-tip-of-the-week-66-decompiler-annotations/
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The address details pane is a rather recent addition to IDA so probably not many users are familiar with it yet. However, it
can be a quite useful addition to the standard workflow, permitting you to perform some common tasks faster.

Address details view

On invoking View > Open subview > Address details (you can also use the Quick view selector), a new pane appears, by
default on the right side of the main window. Obviously, it can be moved and docked elsewhere if you prefer. It will auto-
matically update itself using the current address in any address-based view (IDA View, Hex View, Pseudocode).

The pane consists of three sections, each of which can be collapsed and expanded using the triangle icon in the top left
corner.

Name section
This is basically a non-modal version of the standard Rename address dialog (N hotkey). It allows you to quickly rename
locations by entering a new name in the edit box as well as view and change various name attributes.

Flags section
This is an expanded version of the Print internal flags' action, however currently it does not provide details of instruction
operands.

Data inspector section

This section shows how the bytes at the current address can be interpreted in various formats: integers, floating-point
values, or string literals. It can be especially useful when exploring unknown file formats or arrays of unknown data in
programs.

1 https://hex-rays.com/blog/igors-tip-of-the-week-91-item-flags/
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COM aka Component Object Model is the technology used by Microsoft (and others) to create and use reusable soft-
ware components in a manner independent from the specific language or vendor. It uses a stable and well-defined ABI
which is mostly compatible with Microsoft C++ ABI, allowing easy implementation and usage of COM components in
C++.

COM basics

COM components and their interfaces are identified by — unique 128-bit IDs usually represented as string
of several hexadecimal number groups. For example, {00000000-0000-0000-C000-000000000046 } represents IUnknown — the
base interface which must be implemented by any COM-conforming component.

Each COM interface provides a set of functions in a way similar to a C++ class. On the binary level, this is represented by
a structure with function pointers, commonly named <name>V1tbl. For example, here’s how the t is laid out:

struct IUnknownVtbl
{
HRESULT (__stdcall *QueryInterface)(IUnknown *This, const IID *const riid, void **ppvObject);
ULONG (__stdcall *AddRef)(IUnknown *This);
ULONG (__stdcall *Release)(IUnknown *This);
b
struct IUnknown
{
struct IUnknownVtbl *1pVtbl;

s

IDA'’s standard type libraries include most of the COM interfaces defined by the Windows SDKs, so you can import these
structures from them. Here’s how to do it manually:

1. Open the Structures window (Shift- F9);

2. Use “Add struct type...” from the context menu, or Ins;

3. Type the name of the interface and/or its vtable (e.g. IUnknownVtbl) and click OK. If the interface is known, it will be
imported from the type library automatically. If you are not sure it is available, you can click “Add standard structure”
and use incremental search (start typing the name) to check if it’s present in the list of available types.

Once imported, the struct can be used, for example, to label indirect calls performed using the interface pointer.

How to know which interface is being used in the code? There are multiple ways it can be done, but one common ap-
proach is to use the APL. It returns a pointer to the interface defined by the interface ID (IID) which is a
kind of GUID. You can check what IID is used, then search for it in Windows SDK headers and hopefully find the interface
name.

For example, consider this call:

.text:30961A4D push eax 5 ppv
.text:30961A4E push offset riid ; riid
.text:30961A53 push 1 ; dwClsContext
.text:30961A55 push esi ; pUnkOuter
.text:30961A56 push offset rclsid ; rclsid

.text:30961A5B mov [ebp+ppv], esi
.text:30961A5E call ds:CoCreatelnstance

If we follow riid, we can see that it’s been formatted by IDA nicely as an instance of the IID structure:

.text:30961C18 riid dd OEC5EC8ASh ; Datal

.text:30961C18 ; DATA XREF: sub_30961A2E+20T0
.text:30961C18 ; sub_30DECD76+1Dlo
.text:30961C18 dw ©C395h ; Data2

.text:30961C18 dw 4314h ; Data3

.text:30961C18 db 9Ch, 77h, 54h, @D7h, @ASh, 35h, OFFh, 70h; Data4

In the text form, this corresponds to ECSEC8A9-C395-4314-9C77-54D7A935FF70, but since it’s quite awkward to convert from
the struct representation, a quick way is to search for EC5EC8A9 and see if you can find a match.

There is one in wincodec.h:
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MIDL_INTERFACE(“ec5ec8a9-c395-4314-9¢77-54d7a935ff70”)
IWICImagingFactory : public IUnknown

virtual HRESULT STDMETHODCALLTYPE CreateDecoderFromFilename(

/*
/*
/*
/*
/*

{
public:
[....]

[in] */ __RPC__in LPCWSTR wzFilename,
[unique][in] */ __RPC__in_opt const GUID *pguidVendor,
[in] */ DWORD dwDesiredAccess,

[in] */ WICDecodeOptions metadataOptions,
[retval][out] */ _ RPC__deref_out_opt IWICBitmapDecoder **ppIDecoder) = 0;

Now that we know we’re dealing with IWICImagingFactory, we can import IWICImagingFactoryvtbl and use it to label the

calls made later by dereferencing the ppv variable:

IDA uses type information of the structure’s function pointer to label and propagate argument information®:

Jlext:
Jtext:
Jext:
Jext:
Jewt:
Lext:
Lext:
LRext:
JRext:
Jlext:
Jlext:
Jlext:
Jlext:
Jtext:
Jext:
Jext:
Jewt:
SRext:
Lfext:

3@8981A44
38961840
3B961A4E
3@961A53
3@961A55
3@961A56
3@961A56
3@961A5E
38961A64
3B961A66
3@8961AC
3@8961ABF
3@8981A72
3@961A73
3@961A74
3@961A76
3@961A79
3@8961A7E
3@8961A7C

lea
push
push
push
push
push
mov
call
test
jl
mov
lea
push
push
push
mov
mov
push
call

eax, [ebpt+ppv]

eax

offset riid

1

esi

offset rclsid

[ebp+ppv], esi
ds:CoCreatelnstance

eax, eax

loc_3@961BFC

eax, [ebp+ppv]

edx, [ebp+ppIEnumUnknown]
edx

esi

1

[ebp+ppIEnumUnknown], esi
ecx, [eax]

eax

ppv

riid
dwClsContext
pUnkOuter
rclsid

;. ppIEnumUnknown
; ocpticons

componentTypes

i This

I[ecx+INICImaglngFactoryvtbl,CreatECOmponentEnumera

tor |

While this process works, it is somewhat tedious and error prone. Is there something better?

COM helper
IDA ships with a standard plugin which can automate some parts of the process. If you invoke Edit > Plugins > COM
Helper, it shows a little help about what it does:
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Invoke the menu again to re-enable it. The default state is on for new databases, so normally you do not need to do that.
With plugin enabled, we can do the following:

1. Undefine/delete the IID instance at riid.
2. Redefine it as a GUID (Alt-Q, choose “GUID”).

If the GUID is known, the instance is renamed to CLSID_<name>, and the corresponding <name>Vtbl is imported into the
database automatically (if available in loaded type libraries). You can then use it to resolve the indirect calls from the

interface pointer.

Extending the known interface list

To detect known GUIDs, on Windows the COM Helper uses the registry (HKLM\Software\Classes\Interface subtree). If
the GUID is not found in registry (or not running on Windows), the file cfg/clsid.cfgin IDA’s install directory is consulted.
It is a simple text file with the list of GUIDs and corresponding names. If you are dealing with lesser-known interfaces,
you can add their GUIDs to this file so that they can be labeled nicely.

1 https://en.wikipedia.org/wiki/Universally_unique_identifier
2 https://docs.microsoft.com/en-us/windows/win32/api/combaseapi/nf-combaseapi-cocreateinstance
3 https://hex-rays.com/blog/igors-tip-of-the-week-74-parameter-identification-and-tracking-pit/
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Variable-sized structures is a construct used to handle binary structures of variable size with the advantage of com-
pile-time type checking.

In source code
Usually such structures use a layout similar to following:

struct varsize_t

{

// some fixed fields at the start

int id;

size_t datalen;

//[more fields]

unsigned char data[];// variable part

s
In other words, a fixed-layout part at the start and an array of unspecified size at the end.

Some compilers do not like [] syntax so [@] or even [1] may be used too. At runtime, the space for the structure is allo-
cated using the full size, and the array can be accessed as if it had expected size. For example:

struct varsize t* allocvar(int id, void *data, size_t datalen);
{
size t fullsize = sizeof(varsize_t)+datalen+l;
struct varsize t *var = (struct varsize_t*) malloc(fullsize);
var->id = id;
var->datalen = datalen;
memcpy (var->data, data, datalen);
var->data[datalen]=0;
return var;

}

Can such structs be handled by IDA? Yes, but there are some peculiarities you may need to be aware of.

In the decompiler

In the decompiler everything is pretty simple: just add the struct using C syntax to and use it for types of
local variables and function arguments. The decompiler automatically detects accesses to the variable part and rep-
resents them accordingly.

varsize_t *_ cdecl allocvar(int al, void *Src, size t Size)
varsize_t *v3; // esi
v3 = (varsize_t *)malloc(Size + B);
vi->dword® = al;
vi->dword4 = Size;
memcpy{v3->char8, Src, Size);

v3->char8[size] = @;
return v3;

In disassembly
However, disassembly view is trickier. You can import the struct from Local Types to the IDB Structures, or create one
manually by explicitly adding an array of O elements at the end:

00000000 varsize_t struc ; (sizeof=0x8, align=0x4, copyof_1, variable size)
00000000 id dd ?

00000004 datalen dd ?

00000008 data db @ dup(?)

00000008 varsize_t ends

But when you have instances of such structs in data area, using this definition only covers the fixed part. To extend the
struct, use * (Create/resize array action) and specify the full size of the struct.

Example

Recent Microsoft compilers add so-called “COFF group” info to the PE executables. It is currently not fully parsed by
IDA but is labeled in the disassembly listing with the comment IMAGE_DEBUG_TYPE_POGO:
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.rdata:004199E4 ; Debug information (IMAGE_DEBUG_TYPE_POGO)

.rdata:004199E4 dword_4199E4 dd © ; DATA XREF: .rdata:004196BCTo

.rdata:004199E8 dd 100eh, 25Fh, 7865742Eh, 74h, 1260h, OBCh, 7865742Eh, 69642474h, ©
.rdata:00419A0C dd 1320h, 11BE2h, 7865742Eh, 6E6D2474h, ©

.rdata:00419A20 dd 12F10h, 12Ch, 7865742Eh, 782474h, 13040h, 164h, 7865742Eh, 64792474h
.rdata:00419A20 dd o

.rdata:00419A44 dd 14000h, 11Ch, 6164692Eh, 35246174h, ©

.rdata:00419A58 dd 1411Ch, 4, 6330302Eh, 6766h, 14120h, 4, 5452432Eh, 41435824h, ©
.rdata:00419A7C dd 14124h, 4, 5452432Eh, 41435824h, 41h, 14128h, 1Ch, 5452432Eh, 55435824h

On expanding the array or looking at the hex view, it becomes apparent that it stores info about the original section
names of the executable, before they are merged by the linker. So it can be useful to format this info. It seems to consist
of a list of following structures:

struct section_info

{
int start; // RVA

int size;
char name[]; // zero-terminated

b
The string is padded with zeroes if necessary to align each struct on a 4-byte boundary.

After creating a local type and importing the struct to IDB, we can undefine the array created by IDA and start creating
struct instances in the area using Edit > Struct var... (ALt- Q). However, only the fixed part is covered by default:

To extend the struct, press * and enter full size. For example, the first one should be 14 (8 for the fixed part and 6 for
“text” and terminating zero), although you can also use the suggested 16:
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Now the struct has correct size and covers the string but it is printed as hex bytes and not text. Why and how to fix it?

When IDA converts C type to assembly-level (IDB) struct, it only relies on the sizes of C types, because on the assembly
level there is no difference between a a byte and character?. Thus a char array is the same as a byte array. However, you
can still apply additional representation flags to influence formatting of the structure. For example, you can go to the

imported definition in Structures list and mark the name field as a string literal, either from context menu or by pressing A:

The field is now commented correspondingly and the data instances show the string as text:

aopeeene section_info struc ; (sizeof=6x8, align=@x4, copyof_ 5@, variable size)
oaBRoBBE 3 XREF: .rdata:@@4199EE/r
baspoaee ; .rdata:®e4199F8/r

20060008 start dd ?

fGapapens size dd ?

eeeee208 name db @ dup(?)

Bepa0008 section_info ends

Baaaoaes

.rdata:@e4199c4 dword_4199E4 dd @ DATA XREF: .rdata:®@e4196BCTo
.rdata:@e4199c8 dd 18@6h start

size
name

.rdata:@e4199e8 dd 25Fh
.rdata:@@4199E8 db '.text',®
.rdata:884199F6 db ]
.rdata:884199F7 db ]

In fact, once you mark the field as string, newly declared instances will be automatically sized by IDA using the zero
terminator.

See also:

Variable Length Structures Tutorial®

IDA Help: Convert to array#

IDA Help: Assembler level and C level types5
IDA Help: Structures window®

1 https://hex-rays.com/blog/igor-tip-of-the-week-11-quickly-creating-structures/

2 https://hex-rays.com/blog/igors-tip-of-the-week-46-disassembly-operand-representation/
3 https://hex-rays.com/products/ida/support/tutorials/varstr/

4 https://www.hex-rays.com/products/ida/support/idadoc/455.shtml

5 https://www.hex-rays.com/products/ida/support/idadoc/1042.shtml

¢ https://www.hex-rays.com/products/ida/support/idadoc/593.shtml
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As we've , the same numerical value can be used represented in different ways even if it's the same bit
pattern on the binary level. One of the representations used in IDA is offset.

Offsets
In IDA, an offset is a numerical value which is used as an address (either directly or as part of an expression) to refer to
another location in the program.

The term comes from the keyword used in MASM (Microsoft Assembler) to distinguish an address expression from a
variable.

For example:
mov eax, g varl
Loads the value from the location g_varl into register eax. In C, this would be equivalent to using the variable’s value.
While
mov eax, offset g_varl
Loads the address of the location g_var1 into eax. In C, this would be equivalent to taking the variable’s address.
On the binary level, the second instruction is equivalent to moving of a simple integer, e.g.:
mov eax, 0x40002000

However, during analysis the offset form is obviously preferred, both for readability and because it allows you to see
cross-references to variables and be able to quickly identify other places where the variable is used.

In general, distinguishing integer values used in instructions from addresses is impossible without whole program anal-
ysis or runtime tracing, but the majority of cases can be handled by relatively simple heuristics so usually IDA is able to
recover offset expressions and add cross-references. However, in some cases they may fail or produce false positives
so you may need to do it manually.

Converting values to offsets
All options for converting to offsets are available under Edit > Operand type > Offset:

In most modern, flat-memory model binaries such as ELF, PE, Mach-O, the first two commands are equivalent, so you
can usually use shortcut 0 or Ctrl-o0.

The most common/applicable options are also shown in the context (right-click) menu:
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Fixing false positives

There may be cases when IDA’s heuristics convert a value to an offset when it’s not actually being used as one. One
common example is bitwise operations done with values which happen to be in the range of the program’s address
space, but it can also happen for data values or simple data movement, like on the below screenshot.

.text:@1COATF@ EB 6B C3 FD+call __errno |

Ltext:@1C9ATFA FF

Ltext:@1C0A7FS C7 8@ @1 ee+mov dword ptr [eax], offset loc_3B@esl
.text:@1COATFS 3B @@

Ltext:B1C9AYFE 31 (@ xor eax, eax

Ltext:@1C9ATFD E9 98 @@ ee+jmp loc 1C9A892

In this example, IDA has converted the second operand of the mov instruction to an offset because it turned out to
match a program address. However, we can see that it is being moved into a location returned by the call to __errno
function. This is a common way compilers implement setting of the errno pseudo-variable (which can be thread-specific
instead of a global), so obviously that operand should be a number and not an offset. Besides being a wrong representa-
tion, this also lead to bogus cross-references:

You have the following options to fix the false positive:

1. Press 0 or Ctrl- 0 to reset the “offset” attribute of the operand and let IDA show the default representation (hex).
Note that the number will be printed in orange to hint that its value falls into the address space of the program, i.e. it
is suspicious?;

2. Use Q / * (for hex), H (for decimal), or select the corresponding option from the context menu to explicitly mark the
operand as a number and also avoid flagging it as suspicious;

3. If you have created an enumeration to represent such numbers as symbolic constants, you can use the M shortcut or
the context menu to convert it to a symbolic constant.

See also:
IDA Help: Edit|Operand types|Offset submenu3
IDA Help: Edit|Operand types|Number submenu#

1 https://hex-rays.com/blog/igors-tip-of-the-week-46-disassembly-operand-representation/
2 https://hex-rays.com/blog/igors-tip-of-the-week-90-suspicious-operand-limits/

3 https://www.hex-rays.com/products/ida/support/idadoc/1381.shtml

4 https://www.hex-rays.com/products/ida/support/idadoc/1382.shtml
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Although most of the time IDA is used to work on single, self-contained file (e.g. an executable, library, or a firmware
image), this is not always the case. Sometimes the program may refer to or load additional files or data, and it may be
useful to have that data in the database and analyze it together with the original file.

Load Additional Binary File
For simple cases where you have a raw binary file with the contents you want to add to the database, you can use File >
Load file > Additional binary file...

Please note that any file you select will be treated as raw binary, even for formats otherwise supported by IDA (e.g. PE/
ELF/Mach-0). Once you select a file, IDA will show you the dialog to specify where exactly you want to load it:

Loading segment and Loading offset together specify the location where you want to load the file’s data. By default, IDA
tries to pick the values which are located just after the end of the last segment of the database in such a way that the
newly loaded data starts at offset O in the new segment. However, if you are working with flat memory layout binary
such as the case with most of modern OSes, you should instead set the segment value to 0 and offset to the linear
address where you need to have the data loaded.

File offset in bytes and Number of bytes specify what part of the file you need loaded. With the default values IDA will
load the whole file from the beginning, but you can also change them to load only a part of it.

Create segments is checked by default because in most cases the file is being loaded into a new address range which
does not exist in the database. If you've already created a segment for the file’s data or plan to do it after loading the
bytes, you can uncheck this checkbox.

See also:

1 https://www.hex-rays.com/products/ida/support/idadoc/1372.shtml
2 https://hex-rays.com/blog/igors-tip-of-the-week-41-binary-file-loader/
3 https://hex-rays.com/blog/several-files-in-one-idb-part-3/
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We have covered basic usage of cross-references before!, but there are situations where they may not behave as you
may expect.

Accessing large data items

If there is a large structure or an array and the code reads or writes data deep inside it, you may not see cross-referenc-
es from that code listed at the structure definition.

Example

For example, in the Microsoft CRT function __report_gsfailure, there are writes to the fields _Rip and _Rsp of the Con-

textRecord variable (an instance of a structure _CONTEXT), but if we check the cross-references to ContextRecord, we will
not see those writes listed.

This happens because these fields are situated rather far from the start of the structure (offsets @x98 and oxF8).

mov cs:ContextRecord._Rip, rax

lea rax, [rsp+EER]

add rax, 8 .

mov cs:ContextRecord. Rsp,@eeseece RO dg
.text:poBoBEREBELBOAET 8 _R1@ dgq ?

loc_489AB7: lee@BED® R11 dg 2

mov rax, cs:ContextRecord@@eeeens R12 dq °

mov cs:excRec.ExceptionAdd@@eeeeEe R1S dq ©

mov rax, [rsp+88ht+arg_ @] |@@@eeRES R14 dq °

mav cs:ContextRecord. Rcx,@@@000F8 R1S dg 7

mov cstexcRec.ExceptionCode@eepers Rip dq °

mov cs:excRec.ExceptionFls

As a speed optimization, IDA only checks for direct accesses into large data items up to a limited depth. The default
value is 16(0x10), so any accesses beyond that offset will not be shown. The value for current database can be changed
via Options > General... Cross-references tab.

For example, after setting it to 256, the accesses to _Rip and _Rsp are shown in the cross-references to ContextRecord :
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To change the limit for all new databases, change the parameter MAX_TAIL in ida.cfg.

See also:
IDA Help: Cross References Dialog?

1 https://hex-rays.com/blog/igor-tip-of-the-week-16-cross-references/
2 https://www.hex-rays.com/products/ida/support/idadoc/607.shtml
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The autoanalysis engine is the heart of IDA’s disassembly functionality. In most cases it “just works” but in rare situations
tweaking it may be necessary.

Analysis options
The generic analysis options are available in Options > General, Analysis tab, Kernel Options 1..3.

The same settings are also available at the initial load time.

You can even turn off the autoanalysis completely by unchecking the “Enabled” checkbox. This can be useful, for ex-
ample, if you have some custom analysis scripts or plugins specific to the target and want to run them before IDA’s own
analysis. After running the scripts, analysis can be re-enabled to handle the remaining parts of the binary.
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Processor-specific options
Some processor modules have additional options which are accessible via the “Processor options” button.

Toggling autoanalysis

In some situations where IDA does not behave correctly or even getting in your way, instead of looking for a specific
setting to disable, it may suffice to quickly disable autoanalysis, perform some action, then enable it again for default be-
havior. For example, if you try to use the technique described in the tip #87" without deleting the function first, you may
find yourself fighting the autoanalysis:

1. try to truncate the function at the start of the shared tail using “Set Function End” (shortcut E);

2. IDA truncates the main function and creates a separate tail chunk;

3. because the function (head chunk) and the tail are adjacent, the autoanalysis immediately merges them back into
one big function.

To prevent the undesired merging, you can disable autoanalysis, perform the necessary manipulations, then re-enable
it. This can be done by unchecking the “Enabled” checkbox in the Options dialog but there is a faster way: autoanalysis
indicator button on the toolbar.

It is usually either a yellow circle with hourglass (autoanalysis in progress) or green circle (autoanalysis idle, waiting for
user action). If you click the button, it will turn into a crossed red circle to indicate that autoanalysis has been disabled.

Click on the crossed circle again to re-enable autoanalysis.

See also:
IDA Help: Analysis options (hex-rays.com)?2
Igor’s tip of the week #09: Reanalysis — Hex Rays (hex-rays.com)3

1 https://hex-rays.com/blog/igors-tip-of-the-week-87-function-chunks-and-the-decompiler/
2 https://www.hex-rays.com/products/ida/support/idadoc/620.shtml
3 https://hex-rays.com/blog/igor-tip-of-the-week-09-reanalysis/
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In IDA, an enum (from “enumeration”) is a set of symbolic constants with numerical values. They can be thought of as a
superset of C/C++ enum types and preprocessor defines.

These constants can be used in disassembly or pseudocode to replace specific numbers or their combinations with
symbolic names, making the listing more readable and understandable.

Creating enums manually
The Enums view is a part of the default IDA desktop layout, but it can also be opened via View > Open subviews > Enu-

merations, or the shortcut shift-F1e.

To add a new enum, use “Add enum...” from the context menu, or the shortcut Ins ( I on Macs).

In the dialog you can specify the name, width (size in bytes), and numerical radix for the symbolic constants.

Once the enum has been created, you can start adding constants to it. For this, use “Add enum member...” from the con-
text menu, or the shortcut N.
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An enum may have multiple constants with the same value but the names of all constants must be unique.

YFFFFFFFF # -----------mmmmmmmmmmmmm oo
FFFFFFFF
FFFFFFFF # enum myenum, mappedto_5
FFFFFFFF CONSTO: = @
FFFFFFFF ZERO: = @
FFFFFFFF CONST1: =
FFFFFFFF ONE: = 1
FFFFFFFF

1

Creating enums via Local Types
Local Types view can also be used for creating enums. Simply press Ins, write a C syntax definition in the text box and
click OK.

To make the enum available in the Enums view, so that it can be used in the disassembly, use “Synchronize to idb” from
the context menu, or simply double-click the newly added enum type.

Importing enums from type libraries

Instead of creating an enum from scratch, you can also make use of type libraries shipped with IDA, which include enums
from system headers and SDKs. If you know a name of the enum or one of its members, you can check if they’re present
in the loaded type libraries. For this, use one of the two link buttons available in the “Add enum” dialog:
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If you click one or the other, IDA will show you the list of all enums or members(symbols) available in the currently loaded
type libraries!.

If you know the standard enum name beforehand, simply enter it in the “Add enum” dialog and IDA will automatically
import it if a match is found in a loaded type library.

Using enums
Enums can be used to replace (almost) any numerical value in the disassembly or pseudocode by a symbolic constant.

This can be done from the context menu on a number:
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Or by pressing the shortcut M, which shows a chooser:

The list of enum members is automatically narrowed down to those matching the number in the disassembly/pseudo-
code.

To see the value of the symbolic constant after conversion, hover the mouse? over it:

See also:
IDA Help: Enums windows3
IDA Help: Convert operand to symbolic constant (enum)#4

1 https://hex-rays.com/blog/igors-tip-of-the-week-60-type-libraries/
2 https://hex-rays.com/blog/igors-tip-of-the-week-47-hints-in-ida/

3 https://www.hex-rays.com/products/ida/support/idadoc/594.shtml
4 https://www.hex-rays.com/products/ida/support/idadoc/473.shtml
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When working with big functions in the decompiler, it may be useful to temporarily hide some parts of the pseudocode to
analyze the rest. While currently it’s not possible to hide arbitrary lines like in disassembly’, you can hide specific sec-
tions of it.

Collapsing local variable declarations

While the local variable declarations are useful to see the overall layout of the stack frame and other interesting info?, in
big functions they may take up a lot of valuable screen estate. To get them out of the way, you can use “Collapse decla-
rations...” from the context menu, or the - key on the numpad.

This replaces the declarations with a single comment line. To show them again, use “Uncollapse declarations..” or the
numpad + key.

To always collapse the declarations by default, set COLLAPSE_LVARS option in cfg/hexrays.cfg.

Collapsing statements
Compound statements can be collapsed too: if and switch statements, as well as for, while, and do loops. This can be
done using the “Collapse item” context menu command, or the same numpad - shortcut.
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After collapsing, the whole statement is replaced by one line with the keyword and ellipsis:

if...
w58 = ©LL;

do...
if ( v59 < BxF )

gcoto LABEL_ 45;
va3 = *(_QWORD *)(v37 + 8);

And can be uncollapsed again from context menu or the numpad + key.
You can use this approach to progressively hide analyzed code and tackle long functions piece by piece

See also
Hex-Rays interactive operation: Hide/unhide C statements (hex-rays.com)3

1 https://hex-rays.com/blog/igors-tip-of-the-week-31-hiding-and-collapsing/
2 https://hex-rays.com/blog/igors-tip-of-the-week-66-decompiler-annotations/
3 https://www.hex-rays.com/products/decompiler/manual/cmd_hide.shtml
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are functions which accept different number of arguments depending on the needs of the caller. Typ-
ical examples include printf and scanf in C and C++ but there are other functions, or even some custom ones (specific
to the binary being analyzed). Because each call of a variadic function may have a different set of arguments, they need
special handling in the decompiler. In many cases the decompiler detects such functions and their arguments automati-
cally but there may be situations where user intervention is required.

Changing the function prototype

For standard variadic functions IDA usually applies the prototype from a but if there’s a non-standard
function or IDA did not detect that a function is variadic, you can do it manually. For example, a decompiled prototype of
unrecognized variadic function on ARM64 may look like this:

void _ fastcall logfunc(

const char *al,
__int64 a2,
__int64 a3,
__int64 a4,
__int64 a5,
__int64 a6,
__int64 a7,
__int64 a8,

char a9)

But when you inspect the call sites, you see that most of the passed arguments are marked as possibly uninitialized
(orange color):

Togfunc(
“waitpid thread (): waitpid (pid = %i. &status, @) => %i. status = %i. errno = %i"

void _ fastcall(const char *al, _int64 a2, _ int64 a3, _ int64 ad, __int6d a5, _ int64 a6, _ int64 a7, _ int64 a8, char a9)
: @008 X0 const char *al;

2]

v7, 1: 0008 X1 __int64 a2;

8, 2: @088 X2 __intea a3;
3: 0088 X3 __int64 a4;
4: 008 X4 __int64 a5;
5: 0088 X5 __int64 ab;
6: 9088 X6 __inte4 a7;
7: 0088 X7 __inte4 a8;
8: @001 "0.1 char ag9;

The first argument looks like a format string so the rest are likely variadic. So we can try to to:

void logfunc(const char *, ...);

which results in clean decompilation:
if ( (~v13 & @x7F) != @ || (v13 & BxFFFFFFe@) == 4864 )
if ( log_enabled(2) )

logfunc("waitpid_thread (): setting exit status for pid = %i to %i", v4, (unsigned int)vi3);

o o

v13;
= va |v0id(const char *, ...)

= v

Adjusting variadic arguments

With correct prototypes, decompiler usually can guess the actual arguments passed to each invocation of the function.
However, in some cases the autodetection can misfire, especially if the function uses non-standard format specifiers or
does not use a format string at all. In such case, you can adjust the actual number of arguments being passed to the call.
This can be done via the context menu commands “Add variadic argument” and “Delete variadic argument”, or the
corresponding shortcuts Numpad + and Numpad -.

Variadic calls and tail branch optimization

In some rare situations you may run into the following issue: when trying to add or remove variadic arguments, the
decompiler seems to ignore the action. This may occur in functions subjected to a specific optimization. For example,
here’s pseudocode of a function which seems to have two calls to a logging function:
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if (lal)
{
LogFunc(@, @, "../../../components/: src/ c", 176, "ab_time_stop", "DATA_INVALID_PARM", a3);
return -2;
void(const char *pModuleName, int loglevel, const char *filename, int fileline, const char *funcName, const char *fmt, ...)
w5 = *(_DWf  @: @ee4 Re const char *ploduleName;
if (1vs )| 1: eee4 R1 int loglevel;
2: 0004 R2 const char *filename;
LogFunc( 3: @004 R3 int fileline;
return -/ 4: @ee4 “0.4 const char *funcName;
5: 0004 4.4 const char *fmt;
if ( *(uns| RET void;
TOTAL STKARGS SIZE: 8

The decompiler has decided that a3 is also passed to the calls, however we can see that the format strings do not have
any format specifiers so a3 is a false positive and should be removed. However, using “Delete variadic argument” on the
first call seems to have no effect. What’s happening?

This is one of the rare cases where switching to disassembly can clear things up. By pressing Tab, we can see a curious
picture in the disassembly: there is only one call!

PUSH {R®-R4, LR}
MOVs R2, RO
MOvs R3, R1
CMP Re, #0
BNE loc_4DDAE
LDR R3, =str_CdTimeStop ; "ab_time_stop”
Movs R1, R2 Arguments 1
STR R3, [SP,#8x18+funchame]
LDR R3, =str OprtInvalid ; "DATA INVALID PARM"
LDR R2, =str_ComponentsA ; "../../../components/xxxxxxxxxxxx/src/aa". ..
STR R3, [SP,#0x18+errorsStr]
MOVS R3, #0xB@
B Toc_4DDC2
§ m e
loc_4DDAE ; CODE XREF: ab_time_stop+8Tj
LDR R1, [Re,#8] ; loglevel
CMP R1, #0
BNE loc_4DDCC
LDR R3, =str_CdTimeStop ; "ab_time_stop”
MOVS RO, R1 ; pModulelName
STR RB: [SP,#B;1§+funcName] ; funcName Argumentsz
LDR R3, =str_OprtComErro ; "DATA_COM_ERROR"
LDR R2, =str_ComponentsA ; filename
STR R3, [SP,#0x18+errorStr] ; fmt
MOVS R3, #0xB6 ; fileline
loc_4DDC2 ; CODE XREF: ab_time_stop+181j
©ooBL _ Llogfunc| Actual Call
Movs RB, #2
NEGS Re, Re
B loc_ADDFE

This is an example of so-called tail branch merging optimization, where the same function call is reused with different
arguments. For better code readability, the decompiler detects this situation and creates a duplicate call statement with
the second set of arguments. Because the information about the number of variadic arguments is attached to the actual
call instruction, it can’t be changed for the “fake” call inserted by the decompiler. You can change it for the “canonical”
one which can be discovered by pressing Tab on the call (BL instruction). Removing the argument there affects both calls
in the pseudocode.

If you’re curious to see the “original” code, it can be done by turning off “Un-merge tail branch optimization” in the de-
compiler’s Analysis Options 14,
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With it off, there is only one call just like in the disassembly, at the cost of an extra goto and some local variables:

if ( lal )
{
errorStr = "DATA_INVALID_PARM";
vs = 176;
LABEL_5:
LogFunc(®, ©, "../../../components/xxxxxxxxxxxx/src/aaaaaaaaaaaaa.c", v5, "ab_time_stop", errorStr);
return -2;
}
v6 = *(_DWORD *)(al + 8);
if ( lve
1
errorStr = "DATA_COM_ERROR";
v5 = 182;
goto LABEL_S;
i
See also:

Hex-Rays interactive operation: Add/del variadic arguments (hex-rays.com)5

1 https://en.wikipedia.org/wiki/Variadic_function

2 https://hex-rays.com/blog/igors-tip-of-the-week-60-type-libraries/

3 https://hex-rays.com/blog/igors-tip-of-the-week-42-renaming-and-retyping-in-the-decompiler/
4 https://hex-rays.com/blog/igors-tip-of-the-week-56-string-literals-in-pseudocode/

5 https://www.hex-rays.com/products/decompiler/manual/cmd_variadic.shtml
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While working with pseudocode, you may make various changes to it, for example:

add comments!

rename local variables and change their types?
collapse code blocks?

map variables4

mark skippable instructions®

split expressions®

adjust variadic arguments’

select union members®

e andsoon

If the results of some actions do not look better, you can always undo, but what to do if you discover a problem long after
the action which caused it?

In fact, there is a way to reset specific or all user customizations at once.

Reset decompiler information
By Invoking Edit > Other > Reset decompiler information... you get the following dialog:

Here, you can pick what kinds of information to reset. The fist several options reset information specific to the current
function while the last one also resets caches, such as the microcode and pseudocode caches, for all functions, as well
as the global cross references® cache.

See also:
Decompiler Manual: Interactive operation'©

1 https://hex-rays.com/blog/igors-tip-of-the-week-43-annotating-the-decompiler-output/

2 https://hex-rays.com/blog/igors-tip-of-the-week-42-renaming-and-retyping-in-the-decompiler/
3 https://hex-rays.com/blog/igors-tip-of-the-week-100-collapsing-pseudocode-parts/

4 https://hex-rays.com/blog/igors-tip-of-the-week-77-mapped-variables/

5 https://hex-rays.com/blog/igors-tip-of-the-week-68-skippable-instructions/

6 https://hex-rays.com/blog/igors-tip-of-the-week-69-split-expression/

7 https://hex-rays.com/blog/igors-tip-of-the-week-101-decompiling-variadic-function-calls/

8 https://hex-rays.com/blog/igors-tip-of-the-week-75-working-with-unions/

9 https://hex-rays.com/blog/igors-tip-of-the-week-18-decompiler-and-global-cross-references/
10 https://www.hex-rays.com/products/decompiler/manual/interactive.shtml#07
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As of the time of writing, IDA does not have a built-in plugin manager, so third-party plugins have to be installed manually.

Installing into IDA directory

The standard location for IDA plugins is the plugins directory in IDA’s installation (for example, C:\Program Files\IDA
Pro 8.0\plugins on Windows). So this is the most common way of installing them — just copy the plugin file(s) there and
they’ll be loaded on next start of IDA. However, this only makes them available for this specific IDA install. If you install a
new version of IDA (which by default uses a version-specific directory name), you'll need to re-copy plugins to the new
location.

Installing into user directory
In addition to IDA’s own directory, IDA also checks for plugins in the user directory’. So you can put them in:

e %APPDATA%\Hex-Rays\IDA Pro\plugins on Windows
e $HOME/.idapro/plugins on Linux/Mac

You can find out the exact path for your system by executing idaapi.get_ida_subdirs(“plugins®) in IDA.

Such plugins will be loaded by any IDA, so there may be issues if they use functionality which is not available or changed
between versions, but the advantage is that there’s no need to reinstall them when upgrading IDA (or using multiple
versions).

See also:
Igor’s tip of the week #33: IDA’s user directory (IDAUSR)?2
IDA Help: Environment variabless

1 https://hex-rays.com/blog/igors-tip-of-the-week-33-idas-user-directory-idausr/
2 https://hex-rays.com/blog/igors-tip-of-the-week-33-idas-user-directory-idausr/
3 https://www.hex-rays.com/products/ida/support/idadoc/1375.shtml
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Immediate search is one of three main search types’ available in IDA. While not that known, it can be very useful in some
situations. Here are some examples.

Unique (magic) constants

If you know some unique constants used by the program, looking for them can let you narrow down the range of code
you have to analyze. For example, if a program reports a numerical error code, you could look for it to find the possible
locations which may be returning this error.

Undiscovered cross-references in RISC processors

Many RISC processors use fixed-width instructions which does not leave enough space for encoding full address values
in the instruction. Thus they have to resort to building address values out of small pieces. For, example, in SPARC, load-
ing of a 32-bit value has to be done as a pair of instructions?:

sethi %hi(Prompt),%ol
or %01,%lo(Prompt), %ol

Where %hi returns top 22 bits of the value and %1o returns the low 10 bits. Because such instructions may be not im-
mediately next to each other, IDA may fail to “connect” them and recover the full 32-bit value, leading to missing cross
references. So if you have, for example, a string constant at address N, which you think should be referenced from some-
where, doing an immediate search for N&@x3FF should produce a list of potential candidates for instructions referring to
that address.

Structure field references

Sometimes you may have a structure with a field at a specific offset which is pretty unique (not a small or round value)
and want to find where it is used in the program. For example, let’s look at a recent Windows kernel and the structure
_KPRCB. At offset 63ENh, it has a field CoresPerPhysicalProcessor:

0000808638 MinorVersion dw
BeBEBE3A MajorVersion dw
B8BeP63C BuildType db
260000630 CpuVeandor db
6000463E CoresPerPhysicalPPocessorIdb ?
BeBEOE3F LogicalProcessorsPerCore db ?

S ]

PEBEPE4A8 ParentNode dg ? ; offset
00000648 GroupSetMember dq ?

80000658 Group db ?

888e0651 GroupIndex db ?

PBBEBE52 PrcbPadds db 2 dup(?)

80000654 InitialApicId dd ?

000080658 ScbOffset dd ?

BeBees5C ApicMask dd ?

PEPEPE6A AcpiReserved dg ? ; offset
PBBEPE68 CFlushSize dd ?

0008eceC PrcbPadle dd ?

80000670 LockQueue _KSPIN_LOCK_QUEUE 17 dup(?)

@0000780 PPLookasidelist PP_LOOKASIDE_LIST 16 dup(?)

©PBPP8EE PPNxPagedlLookasidelist GEMWERAL_LOOKASIDE POOL 32 dup(?)
090001480 PPNPagedlLookasidelist _GENERAL_LOOKASIDE_POOL 32 dup(?)
60002080 PPPagedlLookasidelist _GENERAL_LOOKASIDE_POOL 32 dup(?)
P8Be2C88 PrcbPad28 dg ?

800802C88 DeferredReadylistHead _SINGLE_LIST_ENTRY ?

20002C90 MmPageFaultCount dd ?

88802C94 MmCopyOnWriteCount dd 7

200802C98 MmTransitionCount dd ?

205 I _KPRE:BIDDDDUESE

How to find where it is used? Searching for the value 0x63e gives a list of instructions using that value.
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You can then inspect these instructions and see if they indeed reference the _KPRCB field and not something else.
This is probably one of the best uses for immediate search but it does not replace manual analysis. For example:

1. it may miss references which do not use the value directly but calculate it one way or another;

2. false positives may happen, especially for common or small values

3. the field may be referenced indirectly via a bigger containing structure (e.g. _KPCR includes _KPRCB as a member,
so references from _KPCR will have an additional offset).

See also:
IDA Help: Search for next instruction/data with the specified operand3

1 https://hex-rays.com/blog/igors-tip-of-the-week-48-searching-in-ida/
2 https://arcb.csc.ncsu.edu/~mueller/codeopt/codeopt00/notes/sparc.html
3 https://www.hex-rays.com/products/ida/support/idadoc/574.shtml
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