
#133: Alignment items
#134: ARM BL jumps
#137: Processor modes and segment registers
#150: Extract function

Decompiler: related to the Hex-Rays decompiler
#106: Outlined functions
#107: Multiple return values
#108: Raw memory accesses in pseudocode
#112: Matching braces
#117: Reset pointer type
#118: Structure creation in the decompiler
#138: Pointer math in the decompiler
#143: Fixing wrong address references in the decompiler
#147: Fixing "stack frame is too big"
#148: Fixing "call analysis failed"
#149: Using symbolic constants in the decompiler
#151: Fixing "function frame is wrong"
#153: Copying pseudocode to disassembly
#155: Splitting stack variables in the decompiler

Automation: automating repetitive tasks
#124: Scripting examples
#156: Command-line options for firmware loading

Customization: customizing IDA UI to better suit your workflow
#116: IDA startup files

Usage: basic and advanced usage of IDA features
#109: Hex view text encoding
#111: IDA Keyboard Shortcuts cheat sheet
#121: Limiting search to an address range
#122: Manual load
#123: Opcode bytes
#126: Non-returning functions
#127: Changing function bounds
#128: String list
#129: Searching for text in database
#130: Source line numbers
#131: Advanced filters in choosers
#135: Exporting disassembly from IDA
#136: Changing assembler syntax
#139: License borrowing
#144: Macros and simplified instructions
#145: HTML export
#146: Graph printing
#152: Force-creating functions
#154: Synchronized views

Types: working with types
#125: Structure field representation
#140: Loading PDB types
#141: Parsing C files
#142: Mapping local types

Hidden: hidden gems, not widely known but useful functionality
#105: O�sets with custom base
#110: Self-relative o�sets
#113: Image-relative O�sets (RVA)
#114: Split o�sets
#115: Set callee address
#119: Force call type
#120: Set call type
#132: Finding "hidden" cross-references

from 20/08/2021  to 26/08/2022

__text:FFFFFF8000039F88 STP X22, X21, [SP,#-0x10+var_20]!
__text:FFFFFF8000039F8C STP X20, X19, [SP,#0x20+var_10]
__text:FFFFFF8000039F90 STP X29, X30, [SP,#0x20+var_s0]
__text:FFFFFF8000039F94 ADD X29, SP, #0x20
__text:FFFFFF8000039F98 MOV X19, X0
__text:FFFFFF8000039F9C BL sub_FFFFFF80000415E4
__text:FFFFFF8000039FA0 B.HI loc_FFFFFF800003A01C
__text:FFFFFF8000039FA4 MOV W20, #0
__text:FFFFFF8000039FA8 ADR X9, byte_FFFFFF8000048593
__text:FFFFFF8000039FAC NOP
__text:FFFFFF8000039FB0 ADR X10, loc_FFFFFF8000039FC0
__text:FFFFFF8000039FB4 LDRB W11, [X9,X8]
__text:FFFFFF8000039FB8 ADD X10, X10, X11,LSL#2
__text:FFFFFF8000039FBC BR X10
__text:FFFFFF8000039F88 STP X22, X21, [SP,#-0x10+var_20]!
__text:FFFFFF8000039F8C STP X20, X19, [SP,#0x20+var_10]
__text:FFFFFF8000039F90 STP X29, X30, [SP,#0x20+var_s0]
__text:FFFFFF8000039F94 ADD X29, SP, #0x20
__text:FFFFFF8000039F98 MOV X19, X0
__text:FFFFFF8000039F9C BL sub_FFFFFF80000415E4
__text:FFFFFF8000039FA0 B.HI loc_FFFFFF800003A01C
__text:FFFFFF8000039FA4 MOV W20, #0
__text:FFFFFF8000039FA8 ADR X9, byte_FFFFFF8000048593
__text:FFFFFF8000039FAC NOP
__text:FFFFFF8000039FB0 ADR X10, loc_FFFFFF8000039FC0
__text:FFFFFF8000039FB4 LDRB W11, [X9,X8]
__text:FFFFFF8000039FB8 ADD X10, X10, X11,LSL#2

01010000110010111100110110111100011
10001010110100101101110011001111000
11101011001111000010010100100010100
11011100101101010110111101011100001
10101011000001111000101000111111001
01101000101101100111001001011000100
01100011001000010111100001110101000
11100011000101110100011110111010010
10110100010111011110110111010001001
00000001000110011100100011100001000
10001001101011111000000011000100101
11100001110101010110010000000010111
01000010101101110111100010001111000
10010101000001110101110111000011101

f885 eea4 1d22 df51 bdd3 a1f7 fbdd 
3510 25b4 e463 3b32 b77a e823 4002 
211c 7729 c632 782d 7c01 a5f4 d25f 
4cfc 007a fab3 c232 8cf1 39a1 386f 
652b 05af 1a7b adc7 a497 b0ee 20d8 
ae9e bc22 79b5 df2f 9d2b 5e0c 24cb 
f885 eea4 1d22 df51 bdd3 a1f7 fbdd 
3510 25b4 e463 3b32 b77a e823 4002 
211c 7729 c632 782d 7c01 a5f4 d25f 
4cfc 007a fab3 c232 8cf1 39a1 386f 

f885 eea4 1d22 df51 bdd3 a1f7 fbdd 
3510 25b4 e463 3b32 b77a e823 4002 
211c 7729 c632 782d 7c01 a5f4 d25f 
4cfc 007a fab3 c232 8cf1 39a1 386f 
652b 05af 1a7b adc7 a497 b0ee 20d8 
ae9e bc22 79b5 df2f 9d2b 5e0c 24cb 
f885 eea4 1d22 df51 bdd3 a1f7 fbdd 
3510 25b4 e463 3b32 b77a e823 4002 
211c 7729 c632 782d 7c01 a5f4 d25f 
4cfc 007a fab3 c232 8cf1 39a1 386f bdd3 a1f7 fbdd 3510 25b4 e463 3b32 

b77a e823 4002 211c 7729 c632 782d 
7c01 a5f4 d25f 4cfc 007a fab3 c232 
8cf1 39a1 386f 652b 05af 1a7b adc7 
a497 b0ee 20d8 ae9e bc22 79b5 df2f 
9d2b 5e0c 24cb f885 eea4 1d22 df51 
bdd3 a1f7 fbdd 3510 25b4 e463 3b32 
b77a e823 4002 211c 7729 c632 782d 
7c01 a5f4 d25f 4cfc 007a fab3 c232 
8cf1 39a1 386f 652b 05af 1a7b adc7 

f885 eea4 1d22 df51 bdd3 
a1f7 fbdd 3510 25b4 e463 
3b32 b77a e823 4002 211c 
7729 c632 782d 7c01 a5f4 
d25f 4cfc 007a fab3 c232 
8cf1 39a1 386f 652b 05af 
1a7b adc7 a497 b0ee 20d8 

01010000110010111100110110111100011
10001010110100101101110011001111000
11101011001111000010010100100010100
11011100101101010110111101011100001
10101011000001111000101000111111001
01101000101101100111001001011000100
01100011001000010111100001110101000
11100011000101110100011110111010010
10110100010111011110110111010001001
00000001000110011100100011100001000
10001001101011111000000011000100101
11100001110101010110010000000010111
01000010101101110111100010001111000
10010101000001110101110111000011101

01010000110010111100110110111100011
10001010110100101101110011001111000
11101011001111000010010100100010100
11011100101101010110111101011100001
10101011000001111000101000111111001
01101000101101100111001001011000100
01100011001000010111100001110101000
11100011000101110100011110111010010
10110100010111011110110111010001001
00000001000110011100100011100001000
10001001101011111000000011000100101
11100001110101010110010000000010111
01000010101101110111100010001111000
10010101000001110101110111000011101

01010000110010111100110110111100011
10001010110100101101110011001111000
11101011001111000010010100100010100
11011100101101010110111101011100001
10101011000001111000101000111111001
01101000101101100111001001011000100
01100011001000010111100001110101000
11100011000101110100011110111010010
10110100010111011110110111010001001
00000001000110011100100011100001000
10001001101011111000000011000100101
11100001110101010110010000000010111
01000010101101110111100010001111000
10010101000001110101110111000011101

01010000110010111100110
11011110001110001010110
10010110111001100111100
01110101100111100001001
01001000101001101110010
11010101101111010111000
01101010110000011110001
01000111111001011010001
01101100111001001011000

__text:FFFFFF8000039F88 STP X22, X21, [SP,#-0x10+var_20]!
__text:FFFFFF8000039F8C STP X20, X19, [SP,#0x20+var_10]
__text:FFFFFF8000039F90 STP X29, X30, [SP,#0x20+var_s0]
__text:FFFFFF8000039F94 ADD X29, SP, #0x20
__text:FFFFFF8000039F98 MOV X19, X0
__text:FFFFFF8000039F9C BL sub_FFFFFF80000415E4
__text:FFFFFF8000039FA0 B.HI loc_FFFFFF800003A01C
__text:FFFFFF8000039FA4 MOV W20, #0
__text:FFFFFF8000039FA8 ADR X9, byte_FFFFFF8000048593
__text:FFFFFF8000039FAC NOP
__text:FFFFFF8000039FB0 ADR X10, loc_FFFFFF8000039FC0
__text:FFFFFF8000039FB4 LDRB W11, [X9,X8]
__text:FFFFFF8000039FB8 ADD X10, X10, X11,LSL#2
__text:FFFFFF8000039FBC BR X10
__text:FFFFFF8000039F88 STP X22, X21, [SP,#-0x10+var_20]!
__text:FFFFFF8000039F8C STP X20, X19, [SP,#0x20+var_10]
__text:FFFFFF8000039F90 STP X29, X30, [SP,#0x20+var_s0]
__text:FFFFFF8000039F94 ADD X29, SP, #0x20
__text:FFFFFF8000039F98 MOV X19, X0
__text:FFFFFF8000039F9C BL sub_FFFFFF80000415E4
__text:FFFFFF8000039FA0 B.HI loc_FFFFFF800003A01C
__text:FFFFFF8000039FA4 MOV W20, #0
__text:FFFFFF8000039FA8 ADR X9, byte_FFFFFF8000048593
__text:FFFFFF8000039FAC NOP
__text:FFFFFF8000039FB0 ADR X10, loc_FFFFFF8000039FC0
__text:FFFFFF8000039FB4 LDRB W11, [X9,X8]
__text:FFFFFF8000039FB8 ADD X10, X10, X11,LSL#2

__text:FFFFFF8000039F88 STP X22, X21, [SP,#-0x10+var_20]!
__text:FFFFFF8000039F8C STP X20, X19, [SP,#0x20+var_10]
__text:FFFFFF8000039F90 STP X29, X30, [SP,#0x20+var_s0]
__text:FFFFFF8000039F94 ADD X29, SP, #0x20
__text:FFFFFF8000039F98 MOV X19, X0
__text:FFFFFF8000039F9C BL sub_FFFFFF80000415E4
__text:FFFFFF8000039FA0 B.HI loc_FFFFFF800003A01C
__text:FFFFFF8000039FA4 MOV W20, #0
__text:FFFFFF8000039FA8 ADR X9, byte_FFFFFF8000048593
__text:FFFFFF8000039FAC NOP
__text:FFFFFF8000039FB0 ADR X10, loc_FFFFFF8000039FC0
__text:FFFFFF8000039FB4 LDRB W11, [X9,X8]
__text:FFFFFF8000039FB8 ADD X10, X10, X11,LSL#2
__text:FFFFFF8000039FBC BR X10
__text:FFFFFF8000039F88 STP X22, X21, [SP,#-0x10+var_20]!
__text:FFFFFF8000039F8C STP X20, X19, [SP,#0x20+var_10]
__text:FFFFFF8000039F90 STP X29, X30, [SP,#0x20+var_s0]
__text:FFFFFF8000039F94 ADD X29, SP, #0x20
__text:FFFFFF8000039F98 MOV X19, X0
__text:FFFFFF8000039F9C BL sub_FFFFFF80000415E4
__text:FFFFFF8000039FA0 B.HI loc_FFFFFF800003A01C
__text:FFFFFF8000039FA4 MOV W20, #0
__text:FFFFFF8000039FA8 ADR X9, byte_FFFFFF8000048593
__text:FFFFFF8000039FAC NOP
__text:FFFFFF8000039FB0 ADR X10, loc_FFFFFF8000039FC0
__text:FFFFFF8000039FB4 LDRB W11, [X9,X8]
__text:FFFFFF8000039FB8 ADD X10, X10, X11,LSL#2

__text:FFFFFF8000039F88 STP X22, X21, [SP,#-0x10+var_20]!
__text:FFFFFF8000039F8C STP X20, X19, [SP,#0x20+var_10]
__text:FFFFFF8000039F90 STP X29, X30, [SP,#0x20+var_s0]
__text:FFFFFF8000039F94 ADD X29, SP, #0x20
__text:FFFFFF8000039F98 MOV X19, X0
__text:FFFFFF8000039F9C BL sub_FFFFFF80000415E4
__text:FFFFFF8000039FA0 B.HI loc_FFFFFF800003A01C
__text:FFFFFF8000039FA4 MOV W20, #0
__text:FFFFFF8000039FA8 ADR X9, byte_FFFFFF8000048593
__text:FFFFFF8000039FAC NOP
__text:FFFFFF8000039FB0 ADR X10, loc_FFFFFF8000039FC0
__text:FFFFFF8000039FB4 LDRB W11, [X9,X8]
__text:FFFFFF8000039FB8 ADD X10, X10, X11,LSL#2
__text:FFFFFF8000039FBC BR X10
__text:FFFFFF8000039F88 STP X22, X21, [SP,#-0x10+var_20]!
__text:FFFFFF8000039F8C STP X20, X19, [SP,#0x20+var_10]
__text:FFFFFF8000039F90 STP X29, X30, [SP,#0x20+var_s0]
__text:FFFFFF8000039F94 ADD X29, SP, #0x20
__text:FFFFFF8000039F98 MOV X19, X0
__text:FFFFFF8000039F9C BL sub_FFFFFF80000415E4
__text:FFFFFF8000039FA0 B.HI loc_FFFFFF800003A01C
__text:FFFFFF8000039FA4 MOV W20, #0
__text:FFFFFF8000039FA8 ADR X9, byte_FFFFFF8000048593
__text:FFFFFF8000039FAC NOP
__text:FFFFFF8000039FB0 ADR X10, loc_FFFFFF8000039FC0
__text:FFFFFF8000039FB4 LDRB W11, [X9,X8]
__text:FFFFFF8000039FB8 ADD X10, X10, X11,LSL#2

__text:FFFFFF8000039F88 STP X22, X21, [SP,#-0x10+var_20]!
__text:FFFFFF8000039F8C STP X20, X19, [SP,#0x20+var_10]
__text:FFFFFF8000039F90 STP X29, X30, [SP,#0x20+var_s0]
__text:FFFFFF8000039F94 ADD X29, SP, #0x20
__text:FFFFFF8000039F98 MOV X19, X0
__text:FFFFFF8000039F9C BL sub_FFFFFF80000415E4
__text:FFFFFF8000039FA0 B.HI loc_FFFFFF800003A01C
__text:FFFFFF8000039FA4 MOV W20, #0
__text:FFFFFF8000039FA8 ADR X9, byte_FFFFFF8000048593

__text:FFFFFF8000039F88 STP X22, X21, [SP,#-0x10+var_20]!
__text:FFFFFF8000039F8C STP X20, X19, [SP,#0x20+var_10]
__text:FFFFFF8000039F90 STP X29, X30, [SP,#0x20+var_s0]
__text:FFFFFF8000039F94 ADD X29, SP, #0x20
__text:FFFFFF8000039F98 MOV X19, X0
__text:FFFFFF8000039F9C BL sub_FFFFFF80000415E4
__text:FFFFFF8000039FA0 B.HI loc_FFFFFF800003A01C
__text:FFFFFF8000039FA4 MOV W20, #0
__text:FFFFFF8000039FA8 ADR X9, byte_FFFFFF8000048593

Igor’s Tip Season 3 has arrived! Fuelled by the triumph of the previous seasons, we embark on a mission to showcase 
the full extent of IDA’s capabilities. In keeping with tradition, Igor presents a blend of fundamental and advanced IDA 
features, catering to novices and seasoned experts alike. This season, we venture deep into the realm of working with 
data types, unveiling less-known operations, and unleashing the full potential of the Decompiler. In the concluding 
sections, Igor discloses strategies for automating repetitive tasks and personalizing IDA’s User Interface to harmonize 
with your distinct workflow.

We cordially invite you to join us for this promising Season 3, and keep following Igor’s Tip every Friday!
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#105:   Offsets with custom base

We’ve already covered simple offsets1, where an operand value or a data value matches an address in the program and 
so can be directly converted to an offset. However, programs may also employ more complex, or indirect ways of refer-
ring to a location. One common approach is using a small offset from some predefined base address.

Offset (displacement) from a register
Many processors support instructions with addressing modes called “register with displacement”, “register with offset” 
or similar. Operands in such mode may use syntax similar to following:

1.	reg(offset)
2.	offset(reg)
3.	reg[offset]
4.	[reg, offset]
5.	[reg+offset]
6.	etc.

The basic logic is the same in all cases: offset is added to the value of the register and then used as a number or (more 
commonly) as an address. In the latter case it may be useful to have IDA calculate the final address for you and add the 
cross-reference to it. If you know the value of the register at the time this instruction is executed (e.g. it is set in the pre-
ceding instructions), it is very simple to do:

1.	With the cursor on the operand, Invoke Edit > Operand type > Offset > Offset (user-defined), or press Ctrl–R;

2.	Enter the register value in the Base address field;

3.	Click OK;
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#105:  Offsets with custom base

1 https://hex-rays.com/blog/igors-tip-of-the-week-95-offsets/
2 https://www.hex-rays.com/products/ida/support/idadoc/470.shtml
3 https://www.hex-rays.com/products/ida/support/idadoc/471.shtml

4.	IDA will calculate the final address, replace the offset value by an equivalent expression, and add a cross-refer-
ence to destination:

Now it is obvious that the location being referenced is  dword_E01FC0C4.

See also:
IDA Help: Convert operand to offset (user-defined base)2
IDA Help: Complex Offset Expression3
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#106:   Outlined functions

The release notes for IDA 8.01 mention outlined functions. What are those and how to deal with them in IDA?

Function outlining is an optimization that saves code size by identifying recurring sequences of machine code and re-
placing each instance of the sequence with a call to a new function that contains the identified sequence of operations. 
It can be considered an extension of the shared function tail2 optimization by sharing not only tails but arbitrary common 
parts of functions.

Function outlining example
For example, here’s a function from iOS’s debugserver with some calls to outlined fragments:

The first fragment contains only two instructions besides the return instruction so it may not sound like we’re saving 
much, but by looking at the cross-references you’ll see that it is used in many places:

So the savings accumulated across the whole program can be quite substantial.

Handling outlined functions in decompiler
If we decompile the function, the calls to outlined fragments are shown as is, and the registers used or set by them show 
up as potentially undefined (orange color):
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#106:   Outlined functions

To tell the decompiler that the calls should be inlined into the function’s body, all the OUTLINED_FUNCTION_NN should be 
marked as outlined code. This can be done manually, via the Edit Function (Alt–P) dialog:

The added attribute is also displayed in the listing:

Once all outlined functions are marked up, the decompiler inlines them and there are no more possibly undefined 
variables:

Automating outlined function processing
If you have a big binary with hundreds or thousands of functions, it may become pretty tedious to mark up outlined func-
tions manually. In such case, making a small script may speed things up. For example, if you have symbols and outlined 
functions have a known naming pattern, the following Python snippet should work:
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1 https://hex-rays.com/products/ida/news/8_0/
2 https://hex-rays.com/blog/igors-tip-of-the-week-87-function-chunks-and-the-decompiler/
3 https://www.hex-rays.com/products/ida/support/idadoc/485.shtml
4 https://www.hex-rays.com/products/ida/support/idadoc/1729.shtml

import idautils
import ida_name
import ida_funcs
for f in idautils.Functions():
    nm = ida_name.get_name(f)
    if nm.startswith(“_OUTLINED_FUNCTION”) or nm.find(“.cold.”) != -1:
        print (“%08X: %s”% (f, nm))
        pfn = ida_funcs.get_func(f) 
        pfn.flags |= idaapi.FUNC_OUTLINE 
        ida_funcs.update_func(pfn)

It can be executed using File > Script command… (Shift+F2)

See also:
IDA Help: Edit Function3 
IDA Help: Function flags4
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#107:  Multiple return values

The Hex-Rays decompiler was initially created to decompile C code, so its pseudocode output uses (mostly) C syntax. 
However, the input binaries may be compiled using other languages: C++, Pascal, Basic, ADA, and many others. While 
the code of most of them can be represented in C without real issues, some have peculiarities which require language 
extensions1 or have to be handled with user input2. Still, some languages use approaches so different from standard 
compiled C code that special handling for that is necessary. For example, Go3 uses a calling convention4 (stack-based or 
register-based) so different from standard C calling conventions, that custom support for it had to be added to IDA5. 

Multiple return values
Even with custom calling conventions, one fundamental limitation of IDA’s type system remains (as of IDA 8.0): a function 
may return only a single value. However, even in otherwise C-style programs you may encounter functions which return 
more than one value. One example is compiler helpers like idivmod/uidivmod. They return simultaneously the quotient 
and remainder of a division operation. The decompiler knows about the standard ones (e.g. __aeabi_idivmod for ARM 
EABI) but you may encounter a non-standard implementation, or an unrelated function using a similar approach (e.g. a 
function written manually in assembly).

Because the decompiler does not expect that function returns more than one value, you may need to inspect the 
disassembly or look at the place of the call to recognize such functions. For example, here’s a fragment of decompiled 
ARM32 code which seems to use an undefined register value:

The function seems to modify the R1 register, although normally the return values (for 32-bit types) are placed in R0. Pos-
sibly this is an equivalent of divmod function which returns quotient in R0 and remainder in R1?

To handle this, we can use an artificial structure and a custom calling convention specifying the registers and/or stack 
locations where it should be placed. For example, add such struct to Local Types:

struct divmod_t
{
  int quot;
  int rem;
};

and set the function prototype: divmod_t __usercall my_divmod@<R1:R0>(int@<R0>, int@<R1>);

The decompiler then interprets the register values after the call as if they were structure fields:

A similar approach may be used for languages with native support for functions with multiple return values: Go, Swift, 
Rust etc.

See also:
Igor’s tip of the week #51: Custom calling conventions6

1 https://hex-rays.com/blog/igors-tip-of-the-week-51-custom-calling-conventions/
2 https://hex-rays.com/blog/igors-tip-of-the-week-71-decompile-as-call/ 
3 https://go.dev/ 
4 https://go.dev/src/cmd/compile/abi-internal
5 https://hex-rays.com/products/ida/news/7_6/
6 https://hex-rays.com/blog/igors-tip-of-the-week-51-custom-calling-conventions/
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#108:  Raw memory accesses in pseudocode

Sometimes in pseudocode you may encounter strange-looking code:

The code seems to dereference an array called MEMORY and is highlighted in red. However, this variable is not defined 
anywhere. What is it?

Such notation is used by the decompiler when the code accesses memory addresses not present in the database. In 
most cases it indicates an error in the original source code. If we look at the disassembly for the example above, we’ll 
see this:

The variable pfont is loaded into register edx which is then compared against zero using test edx, edx/jz sequence. 
The jump to loc_4060D3 can only occur if edx is zero, which means that the mov eax, [edx+10h] instruction will try to 
dereference the address 0x10. Because the database does not contain the address 0x10, it can’t be represented as a 
normal or a dummy variable so the decompiler represents it as a pseudo-variable MEMORY and uses the address as the 
index. The dereference is shown in red to bring attention to the potential error in the code. For example, judging by the 
assembly, in this binary the programmer tried reading a structure pointer even if it is NULL. A more modern compiler 
would probably even remove such code as dereferencing NULL pointer is undefined behavior.

In cases where such access is not an error (for example, the code directly accesses memory-mapped hardware regis-
ters), creating a new segment for the accessed address range is usually the correct approach.
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#109:  Hex view text encoding

The Hex view is used to display the contents of the database as a hex dump. It is also used during debugging to display 
memory contents.

By default it has a part on the right with the textual representation of the data. Usually the text part shows Latin letters or 
dots for unprintable characters but you may also encounter something unusual:

Why is there Chinese among English? Is it a hidden message and the binary actually comes from China?

In fact, the mystery has a very simple explanation: the encoding used for showing text data in hex view uses the data-
base1 default which is usually UTF-8, so a valid UTF-8 byte sequence may decode to Chinese, Japanese, Russian, Kore-
an, or even emoji. If you prefer to see only the plain ASCII text, you can change the encoding using these simple steps:

1.	 From the hex view’s context menu, invoke Text > Add encoding…

2.	 Enter “ascii”;
3.	 the new encoding will be added to the list and made default, so any bytes not falling into the ASCII range will be 
shown as unprintable:

Instead of “ascii” you can use another encoding which matches the type of binary you’re analyzing. For example, if you 
work with legacy Japanese software, encodings like “Shift-JIS”, “cp932” or “EUC-JP” may help you discover otherwise 
hidden text.

See also:
Igor’s tip of the week #13: String literals and custom encodings2

1 https://hex-rays.com/blog/igor-tip-of-the-week-13-string-literals-and-custom-encodings/ 
2 https://hex-rays.com/blog/igor-tip-of-the-week-13-string-literals-and-custom-encodings/
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#110:  Self-relative offsets

We’ve covered offsets with base1 previously. There is a variation of such offsets commonly used in position-independent 
code which can be handled easily with a little trick.

Let’s consider this ARM function from an ARM32 firmware:

ROM:00000058 ; int sub_58()
ROM:00000058 sub_58                                  ; CODE XREF: sub_10A4:loc_50↑j
ROM:00000058                                         ; DATA XREF: sub_8D40+20↓r ...
ROM:00000058                 ADR             R0, off_88 ; R0 = 0x88
ROM:0000005C                 LDM             R0, {R10,R11} ; R10 = 0x3ADC0, R11 = 0x3AE00
ROM:00000060                 ADD             R10, R10, R0 ; R10 = 0x3ADC0+0x88
ROM:00000064                 SUB             R7, R10, #1
ROM:00000068                 ADD             R11, R11, R0 ; R11 = 0x3AE00+0x88
ROM:0000006C
ROM:0000006C loc_6C                                  ; DATA XREF: sub_58+20↓o
ROM:0000006C                 CMP             R10, R11
ROM:00000070                 BEQ             sub_D50
ROM:00000074                 LDM             R10!, {R0-R3}
ROM:00000078                 ADR             LR, loc_6C
ROM:0000007C                 TST             R3, #1
ROM:00000080                 SUBNE           PC, R7, R3
ROM:00000084                 BX              R3
ROM:00000084 ; End of function sub_58
ROM:00000084
ROM:00000084 ; ---------------------------------------------------------------------------
ROM:00000088 off_88          DCD dword_3ADC0         ; DATA XREF: sub_58↑o
ROM:00000088                                         ; sub_58+4↑o
ROM:0000008C                 DCD off_3AE00

 
IDA has converted the values at addresses 88 and 8C to offsets because they happen to be valid addresses, but if you 
look at what the code does (I’ve added comments describing what happens), we’ll see that both values are added to the 
address from which they’re loaded (0x88), i.e. they’re relative to their own position (or self-relative). 

To get the final value they refer to, we can use the action Edit > Operand type > Offset >Offset (user-defined) (shortcut 
Ctrl–R), and enter as the base either the address value (0x88), or, for the case of the value at 00000088, the IDC keyword 
here, which expands to the address under the cursor.

IDA calculates the final address and replaces the value with an expression which uses a special symbol ., which denotes 
the current address on ARM:
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1 https://hex-rays.com/blog/igors-tip-of-the-week-105-offsets-with-custom-base/ 
2 https://hex-rays.com/blog/igors-tip-of-the-week-105-offsets-with-custom-base/ 
3 https://hex-rays.com/blog/igors-tip-of-the-week-21-calculator-and-expression-evaluation-feature-in-ida/

ROM:00000088 off_88          DCD off_3AE48 - .       ; DATA XREF: sub_58↑o

For the value at 0000008C, here will not work since it expands to 0x8c while the addend is 0x88. There are several op-
tions we can use:

1.	 use the actual value 0x88 as the base
2.	 use the expression here-4 which resolves to 0x88.
3.	 use here, but specify 4 in the Target delta field. 

IDA will use the delta as an additional adjustment for the expression:

ROM:0000008C                 DCD byte_3AE88+4 - .

Now we can see what addresses the function is actually using and analyze it further.

See also:
Igor’s tip of the week #105: Offsets with custom base2
Igor’s tip of the week #21: Calculator and expression evaluation feature in IDA3
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#111:  IDA Keyboard Shortcuts cheat sheet

Many keyboard shortcuts1 have been described on this blog, but they may be difficult to retain, especially if you don’t use 
them every day. To remedy that, we have been publishing a cheat sheet with the most common ones.

You can find it linked from our documentation page2 in HTML3 or PDF4 format.

NOTE: the shortcuts described are for the default configuration; you can modify them5 to your liking.

See also:
Igor’s tip of the week #01: Lesser-known keyboard shortcuts in IDA6 
Igor’s tip of the week #02: IDA UI actions and where to find them7

1 https://hex-rays.com/blog/tag/shortcuts/
2 https://hex-rays.com/documentation/
3 https://hex-rays.com/products/ida/support/idapro_cheatsheet.html
4 https://hex-rays.com/products/ida/support/freefiles/IDA_Pro_Shortcuts.pdf
5 https://hex-rays.com/blog/igor-tip-of-the-week-02-ida-ui-actions-and-where-to-find-them/
6 https://hex-rays.com/blog/igor-tip-of-the-week-01-lesser-known-keyboard-shortcuts-in-ida/
7 https://hex-rays.com/blog/igor-tip-of-the-week-02-ida-ui-actions-and-where-to-find-them/
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#112:  Matching braces

When working with big functions in the decompiler, it may be difficult to find what you need if the listing is long. While you 
can use cross-references1 to jump between uses of a variable or collapse2 parts of pseudocode to make it more com-
pact, there is one simple shortcut which can make your life easier.

The shortcut is not currently (IDA 8.1) shown in the context menu, but it was mentioned in the release notes for IDA 7.43:

You can also discover it by opening the Options > Shortcuts… dialog while the cursor is positioned on a brace or paren-
thesis:

This dialog can also be used to modify the shortcut to something you may find more convenient, for example Ctrl–]

See also:
Igor’s tip of the week #06: IDA Release notes – Hex Rays4
Igor’s tip of the week #02: IDA UI actions and where to find them – Hex Rays5

1 https://hex-rays.com/blog/igors-tip-of-the-week-18-decompiler-and-global-cross-references/ 
2 https://hex-rays.com/blog/igors-tip-of-the-week-100-collapsing-pseudocode-parts/
3 https://hex-rays.com/products/ida/news/7_4/
4 https://hex-rays.com/blog/igor-tip-of-the-week-06-release-notes/
5 https://hex-rays.com/blog/igor-tip-of-the-week-02-ida-ui-actions-and-where-to-find-them/
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#113:  Image-relative Offsets (RVA)

Image-relative offsets are values that represent an offset from the image base of the current module (image) in memory. 
This means that they can be used to refer to other locations in the same module regardless of its real, final load address, 
and thus can be used to make the code position-independent (PIC), similarly to the self-relative offsets1. The alternative 
name RVA means “Relative virtual address” and is often used in the context of the PE file format.

However, PIC is not the only advantage of RVAs. For example, on x64-bit platforms RVA values usually use 32 bits in-
stead of 64 like a full pointer. While this makes their range more limited (4GiB from imagebase), the savings from point-
er-type values can be substantial when accumulated over the whole binary.

For known RVA values, such as those in the PE headers or EH structures, IDA can usually convert them to an assem-
bler-specific expression automatically:

However, sometimes there may be a need to do it manually, for example, when dealing with another update of the file 
format not yet handled by IDA, or a custom format/structure which uses RVAs for addressing. In that case, you can use 
yet another variation of the User-defined offset2. The option to turn on is Use image base as offset base. When it’s 
enabled, IDA will ignore the entered offset base and will always use the imagebase.

However, even if you use this approach in a 64-bit program, you may fail to reach the desired effect: the value will be 
displayed in red to indicate an error and not show a nice expression with the final address, as expected.
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1 https://hex-rays.com/blog/igors-tip-of-the-week-110-self-relative-offsets/
2 https://hex-rays.com/blog/igors-tip-of-the-week-105-offsets-with-custom-base/ 
3 https://hex-rays.com/blog/igors-tip-of-the-week-105-offsets-with-custom-base/
4 https://hex-rays.com/blog/igors-tip-of-the-week-110-self-relative-offsets/

This happens because the command defaults to OFF32 for 32-bit values, but the final address does not fit into 32 bits. 
The fix is simple: select OFF64 instead of OFF32.

NOTE: for ARM binaries, the imagerel keyword is used instead of rva.

See also:
Igor’s tip of the week #105: Offsets with custom base3
Igor’s tip of the week #110: Self-relative offsets4
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Previously, we have covered offset expressions1 which fit into a single instruction operand or data value. But this is not 
always the case, so let’s see how IDA can handle offsets which may be built out of multiple parts.

8-bit processors
Although slowly dying out, the 8-bit processors — especially the venerable 8051 — can still appear in current hardware, 
and of course we’ll be dealing with legacy systems for many years to come. Even though their registers can store only 8 
bits af data, most of them can address 16-bit (64KiB) or more of memory which means that the addresses may need to 
be built by parts.

For example, consider this sequence of instructions from an 8051 firmware:

code:CF22    mov     R3, #0xFF
code:CF24    mov     R2, #0xF6
code:CF26    mov     R1, #0xA6
code:CF28    sjmp    code_CF36

The code for 8051 is often compiled using Keil C51 compiler, and this pattern is a typical way of initializing a generic 
pointer to code memory2. The address being referenced is 0xF6A6, but can we make the instructions look “nice” and 
create cross references to it?

One possibility is to use offset with custom base3 on the last move and specify the base of 0xF600:

This does calculate the final address and create a cross-reference but the code is not quite “nice looking” and the other 
instruction remains a plain number:

In fact, a better option is to use the high8/low8 offsets for the two instructions. Because each instruction provides only 
a part of the full offset, it alone cannot be used by IDA for calculating the full address which needs to be provided by the 
user.
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R2 provides the top 8 bits of the address, so we should use the HIGH8 offset type for it. We also need to fill in the full 
address (0xF6A6) in the Target address field. Base address should be reset to 0.

For R1, LOW8 and the same target can be used:
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After applying both offsets, IDA displays them using matching assembler operators:

RISC processors
RISC processors often use fixed-width instructions and may not be able to reach the full range of the address space 
with the limited space for the immediate operand in the instruction. This include SPARC, MIPS, PowerPC and some oth-
ers. As an example, let’s look at this PowerPC VLE snippet:

seg001:0000C156         e_lis     r3, 1 # Load Immediate Shifted
seg001:0000C15A         e_add16i  r3, r3, -0x1650 # 0xE9B0
seg001:0000C15E         se_mtlr   r3
seg001:0000C160         se_blrl

The code calculates an address of a function in r3 and then calls it. IDA helpfully shows the final address in a comment, 
but we can also use custom offsets to represent them nicely. For the e_add16i instruction, we can use the LOW16 type, as 
expected, but in case of e_lis, the processor-specific type HIGHA16 should be used instead of HIGH16. This is because the 
low 16 bits are used here not as-is but as a sign-extened addend, with the high 16 bits of the final address becoming 0 
after the addition (0x10000-0x1650=0xE9B0).

After converting both parts, IDA uses special assembler operators to show the final address:

Now we can go to the target and create a function there.
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1 https://hex-rays.com/blog/igors-tip-of-the-week-110-self-relative-offsets/
2 https://www.keil.com/support/man/docs/c51/c51_le_genptrs.htm
3 https://hex-rays.com/blog/igors-tip-of-the-week-105-offsets-with-custom-base/

Note: specifically for PowerPC, IDA will automatically convert such sequences to offset expression if the target address 
exists and has instructions or data. But the manual approach can still be useful for other processors or complex situa-
tions (for example, the two instructions are too far apart).
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#115:  Set callee address

Cross-references1 is one of the most useful features of IDA. For example, they allow you to see where a particular func-
tion is being called or referenced from, helping you to see how the function is used and understand its behavior better or 
discover potential bugs or vulnerabilities. For direct calls, IDA adds cross-references automatically, but in modern pro-
grams there are also many indirect calls which can’t always be resolved at disassembly time. In such cases, it is useful to 
have an option to set the target call address manually.

Indirect call types
Most instruction sets have some kind of an indirect call instruction. The most common one uses a processor register 
which holds the address of the function to be called:

x86/x64 and ARM can use almost any general-purpose register:

call edi (x86)
call rax (x64)
BLX R12 (ARM32)
BLX R3
BLR X8 (ARM64)

PowerPC is more limited and has to use dedicated ctr or lr registers:

mtlr r12
blrl

mr r12, r9
mtctr r9
bctrl

in MIPS, in theory any register can be used, but binaries conforming to the standard PIC ABI tend to use the register t9:

la      $t9, __cxa_finalize
lw      $a0, (_fdata - 0x111E0)($v0)  # void *
jalr    $t9 ; __cxa_finalize

In addition to simple register, some processors support more complex expressions. For example, on x86/x64 it is possi-
ble to use a register with offset, allowing to read a pointer value and jump to it in a single instruction:

call    dword ptr [eax+0Ch] (x86)
call    qword ptr [rax+98h] (x64)

Setting callee address
In some simple situations (e.g. the register is initialized shortly before the call), IDA is able to resolve it automatically and 
adds a comment with the target address, like in the MIPS example above, or this one:
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1 https://hex-rays.com/blog/igor-tip-of-the-week-16-cross-references/

In more complicated situations, especially involving multiple memory dereferences or runtime calculations, it is possible 
to specify the target address manually.  For this, use the standard plugin command available in Edit > Plugins > Change 
the callee address. The default shortcut is Ctrl– F11.

The plugin will ask you to enter the target address (you can also use a function name):

The call instruction will gain a comment with the target address, as well as a cross-reference:

Currently the plugin is implemented for x86/x64, ARM and MIPS. If you need to set or access this information program-
matically, you can check how it works by consulting the source code in the SDK, under plugins/callee.
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#116:  IDA startup files

IDA’s behavior and defaults can be configured using the Options1 dialog, saved desktop layouts2, or config files3. Howev-
er, sometimes the behavior you need depends on something in the input file and can’t be covered by a single option, or 
you may want IDA to do something additional after the file is loaded. Of course, there is always the possibility of making 
a plugin or a loader using IDA SDK or IDAPython, but it could be an overkill for simple situations. Instead, you can make 
use of several startup files used by IDA every time it loads a new file or even a previously saved database, and do the 
necessary work there.

The following files can be used for such purpose:

ida.idc
This file in idc subdirectory if IDA’s install is automatically loaded on each run of IDA and can be used to perform any 
actions you may need. The default implementation defines a utility class for managing breakpoints and a small helper 
function, but you can add there any other code you need. As an example, it has  a commented call to change a global 
setting:

// uncomment this line to remove full paths in the debugger process options:
// set_inf_attr(INF_LFLAGS, LFLG_DBG_NOPATH|get_inf_attr(INF_LFLAGS));

Instead of editing the file itself (which may have been installed in a read-only location), you can create a file idauser.idc 
with a function user_main() and put it in the user directory4. If found, IDA will parse it and the main function of ida.idc 
will try to call user_main(). This feature allows you to keep the custom behaviour across multiple IDA installs and ver-
sions, without having to edit ida.idc every time.

onload.idc
This file is similar to ida.idc, but is only executed for newly loaded files. In it you can, for example, do some additional 
parsing and formatting to augment the behavior of the default file loader(s). The default implementation detects when a 
DOS driver (EXE or COM file with .sys or .drv extension) is loaded and tries to format its header.

Similarly to ida.idc, instead of editing the file itself, you can create a file named userload.idc in the user directory and 
define a function userload.

//      If you want to add your own processing of newly created databases,
//      you may create a file named “userload.idc”:
//
//      #define USERLOAD_IDC
//      static userload(input_file,real_file,filetype) {
//              ... your processing here ...
//      }
//

#softinclude <userload.idc>

// Input parameteres:
//      input_file - name of loaded file
//      real_file  - name of actual file that contains the input file.
//                   usually this parameter is equal to input_file,
//                   but is different if the input file is extracted from
//                   an archive.
//      filetype   - type of loaded file. See FT_.. definitions in idc.idc
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idapythonrc.py
Unlike the previous examples, this a Python file, so it is only loaded if you have IDAPython installed and working. If the file 
is found in the user directory5, it will be loaded and executed on startup of IDAPython, so you can put there any code to 
perform fine-tuning of IDA, add utility functions to be called from the CLI6, or run any additional scripts.

Useful functions
Some functions which can be called from the startup files to configure IDA:

get_inf_attr()7 / set_inf_attr()8 / set_flag()9: read and set various flags controlling IDA’s behavior. For example, 
INF_AF can be used to change various analysis options.

process_config_directive()10: change a setting using keyword=value syntax. Most settings from ida.cfg can be used, 
as well as some processor-specific or debugger-specific ones.  A few examples:

•	 process_config_directive(“ABANDON_DATABASE=YES”);: do not save the database on exit. Please note that this 
setting has a side effect in that it disables most user actions which change the database, for example MakeUnknown (U) 
or MakeCode (C).
•	 process_config_directive(“PACK_DATABASE=2”);: set the default database packing option to “deflate”;
•	 process_config_directive(“GRAPH_OPCODE_BYTES=4”);: enable display of opcode bytes in graph mode;
•	 for more examples, see ida.cfg (open it in any text editor).

 

1 https://hex-rays.com/blog/igors-tip-of-the-week-25-disassembly-options/
2 https://hex-rays.com/blog/igors-tip-of-the-week-22-ida-desktop-layouts/
3 https://hex-rays.com/blog/igors-tip-of-the-week-33-idas-user-directory-idausr/
4 https://hex-rays.com/blog/igors-tip-of-the-week-33-idas-user-directory-idausr/
5 https://hex-rays.com/blog/igors-tip-of-the-week-idas-user-directory-idausr/
6 https://hex-rays.com/blog/igors-tip-of-the-week-73-output-window-and-logging/
7 https://www.hex-rays.com/products/ida/support/idadoc/285.shtml 
8 https://www.hex-rays.com/products/ida/support/idadoc/285.shtml 
9 https://www.hex-rays.com/products/ida/support/idadoc/285.shtml
10 https://www.hex-rays.com/products/ida/support/idadoc/642.shtml
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While currently (as of version 8.1) the Hex-Rays decompiler does not try to perform full type recovery, it does try to 
deduce some types based on operations done on the variables, or using the type information for the API calls from type 
libraries1.

One simple type deduction performed by the decompiler is creation of typed pointers when a variable is being derefer-
enced, for example:

_QWORD *__fastcall sub_140006C94(_QWORD *a1)
{
  a1[2] = 0i64;
  a1[1] = “bad array new length”;
  *a1 = &std::bad_array_new_length::`vftable’;
  return a1;
}

Unfortunately, such conversions are not always correct, as can be seen in the example: we have a mix of integer and 
pointer elements in one array, so it’s more likely a structure. Also, due to C’s array indexing rules, the array indexes are 
multiplied by the element size (so, for example, a1[2] actually corresponds to  the byte offset 16). If you prefer seeing 
“raw” offsets, you can  change the variable’s type to a plain integer. This can, of course, be done by manually changing 
the variable’s type but there is a convenience command in the context menu which can be used to do it quickly:

After resetting, the variable becomes a simple integer type and all dereferences now use explicit byte offsets and casts:

Now you can, for example, create a structure corresponding to these accesses, or choose an existing one.

See also: 
Hex-Rays Decompiler: Interactive operation2

 

1 https://hex-rays.com/blog/igors-tip-of-the-week-60-type-libraries/
2 https://www.hex-rays.com/products/decompiler/manual/interactive.shtml
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We’ve covered structure creation using disassembly or Local Types1, but there is also a way of doing it from the decom-
piler, especially when dealing with unknown, custom types used by the program.

Whenever you see code dereferencing a variable with different offsets, it is likely a structure pointer and the function is 
accessing different fields of it.

You can, of course, create the structure manually and change the variable’s type, but it is also possible to ask the 
decompiler to come up with a suitable layout. For this, use “Create new struct type…” from the context menu on the 
variable:

If you don’t see the action, you may need to reset the pointer type2 first. After you invoke it, the decompiler will analyze 
accesses to the variables and come up with a candidate structure type which matches them:

You can accept the suggestion as-is, or make any suitable adjustments (for example, change the structure name, or edit 
some of the fields). After confirming, the structure is added to Local Types and the variable is converted to the corre-
sponding pointer type:
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You can, of course, keep refining the structure as you continue with your analysis and discover how the fields are used in 
other functions and what they mean. Renaming fields can be done directly from the pseudocode view, while for adding 
or rearranging them you’ll likely need to use Local Types or Structures window.

See also: 
Hex-Rays interactive operation: Create new struct type3

1 https://hex-rays.com/blog/igor-tip-of-the-week-11-quickly-creating-structures/
2 https://hex-rays.com/blog/igors-tip-of-the-week-117-reset-pointer-type/
3 https://www.hex-rays.com/products/decompiler/manual/cmd_new_struct.shtml
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When dealing with compile binary code, the decompiler lacks information present in the source code, such as function 
prototypes and so must guess it or rely on the information provided by the user (where its interactive features come 
handy).

One especially tricky situation is indirect calls: without exact information about the destination of the call, the decompiler 
can only try to analyze registers or stack slots initialized before the call and try to deduce the potential function proto-
type this way. For example, check this snippet from a UEFI module:

For several indirect calls involving qword_21D40, the decompiler had to guess the arguments and add casts.

If we analyze the module from the entry point, we can find the place where the variable is initialized and figure out that it 
is, in fact, the standard UEFI global variable gBS of the type EFI_BOOT_SERVICES *:

EFI_STATUS __fastcall UefiBootServicesTableLibConstructor(EFI_HANDLE ImageHandle, EFI_SYSTEM_TABLE 
*SystemTable)
{
  gImageHandle = ImageHandle;
  if ( DebugAssertEnabled() && !gImageHandle )
    DebugAssert(
      “u:\\MdePkg\\Library\\UefiBootServicesTableLib\\UefiBootServicesTableLib.c”,
      0x33ui64,
      “gImageHandle != ((void *) 0)”);
  gST = SystemTable;
  if ( DebugAssertEnabled() && !gST )
    DebugAssert(
      “u:\\MdePkg\\Library\\UefiBootServicesTableLib\\UefiBootServicesTableLib.c”,
      0x39ui64,
      “gST != ((void *) 0)”);
  // gBS was qword_21D40	  
  gBS = SystemTable->BootServices;
  if ( DebugAssertEnabled() && !gBS )
    DebugAssert(
      “u:\\MdePkg\\Library\\UefiBootServicesTableLib\\UefiBootServicesTableLib.c”,
      0x3Fui64,
      “gBS != ((void *) 0)”);
  return 0i64;
}

After renaming and changing the type of the global variable, the original function is slightly improved thanks to the type 
information from the standard UEFI type library:
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Even though the decompiler now has prototypes of function pointers such as LocateDevicePath (shown in the pop-up) 
or FreePool, it has to add casts because the arguments which are passed to the calls do not match the prototype. To tell 
the decompiler to rely on the type information instead of guessing the arguments, use the command Force call type from 
the context menu:

When running the command on the indirect calls, the decompiler also uses the type information to update the types of 
the arguments (except those already set by the user), making the pseudocode much cleaner:

See also:
Hex-Rays interactive operation: Force call type1

1 https://www.hex-rays.com/products/decompiler/manual/cmd_force_call_type.shtml
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#120: Set call type

Previously we’ve described how to use available type info to make decompilation of calls more precise when you have 
type information1, but there may be situations where you don’t have it or the existing type info does not quite match the 
actual call arguments, and you still want to adjust the decompiler’s guess.

One common example is variadic functions (e.g. printf, scanf and several others from the C runtime library, as well as 
custom functions specific to the binary being analyzed). The decompiler knows about the standard C functions and 
tries to analyze the format string to guess the actually passed arguments. However, such guessing can still fail and show 
wrong arguments being passed.

For simple situations, adjusting variadic arguments2 may work, but it’s not always enough. For example, some call-
ing conventions pass floating-point data in different registers from integers, so the decompiler needs to know which 
arguments are floating-point and which are not. You can, of course, change the prototype of the function to make the 
additional arguments explicit instead of variadic, but this affects all call sites instead of just the one you need.

Another difficulty can arise when dealing with the scanf family functions. Because the variadic arguments to such func-
tions are usually passed by address, any variable type may be used for a specific format specifier. Consider the following 
example source code:

struct D
{
  int d;
  int e;
};

#include 
int main()
{
 D d;
 scanf(“%d”, &d.d);
}

When we decompile the compiled binary, even after creating the struct and changing the local variable type, the follow-
ing output is shown:

We get &d instead of &d.d because d is situated at the very start of the structure so both expressions are equivalent on 
the binary level. To get the desired expression, we need to hint the decompiler that the extra argument is actually an int 
*. This can be done using the “Set call type…” action from the context menu on the call site:
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1 https://hex-rays.com/blog/igors-tip-of-the-week-119-force-call-type/
2 https://hex-rays.com/blog/igors-tip-of-the-week-101-decompiling-variadic-function-calls/
3 https://www.hex-rays.com/products/decompiler/manual/cmd_set_call_type.shtml

We can explicitly specify type of the extra argument:

The decompiler takes it into account and uses the proper expression to match the new prototype:

See also: Hex-Rays interactive operation: Set call type3
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#121: Limiting search to an address range

When performing a search1 in IDA, it by default starts from the current position and continues up to the maximum ad-
dress in the database (or to the minimal for searches “Up”). This works well enough for small to average files, but can get 
pretty slow for big ones, or especially in case of debugging where the database may include not just the input file but 
also multiple additional modules loaded at runtime.

To skip areas you’re not interested in and improve the speed, you can limit the search to an address range. For this, IDA 
relies on selection. For example, consider this disassembly snippet:

If you perform a binary search for the value 93, the instruction at 00000514 will be found:

Searching down CASE-INSENSITIVELY for binary pattern:
	 93
Search completed. Found at 00000514.

However, if you select a range which does not include that address before invoking the search, the search will fail:

Searching down CASE-INSENSITIVELY for binary pattern:
	 93
Search failed.
Command “AskBinaryText” failed

Selecting large areas with the mouse or by holding Shift can be quite tedious, so it may be more convenient to use the 
anchor selection2:

1.	 Move to the start or end of the intended selection and invoke Edit > Begin selection (or press Alt–L ).
2.	 Navigate to the other end of the selection using any means (cursor keys, Jump actions, Functions or Sgments 
window, Navigation bar etc.).
3.	 Invoke the binary search command. The search will be performed in the selection only.

 

1 https://hex-rays.com/blog/igors-tip-of-the-week-48-searching-in-ida/
2 https://hex-rays.com/blog/igor-tip-of-the-week-03-selection-in-ida/
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#122: Manual load

To save on analysis time and database size, by default IDA only tries to load relevant parts of the binary (e.g. those that 
are expected or known to contain code). However, there may be cases when you want to see more, or even everything 
the binary contains. You can always load the file as plain binary and mark it up manually, using IDA as a sort of a hybrid 
hex editor, but this way you lose the features handled by the built-in loaders such as names from the symbol table, auto-
matic function boundaries from the file metadata and so on. So it may be interesting to have more granular control over 
the file loading process.

To support such scenarios, IDA offers the Manual load checkbox in the initial load dialog.

What happens when the option is checked depends on the loader. For example, the PE loader may allow you to pick an-
other load base (image base), choose which sections to load, and whether to parse some optional metadata which could, 
for example, be corrupted and result in bad analysis.

The ELF loader behaves in a similar manner

If you want IDA to always load all PE sections, you can edit cfg/pe.cfg and set the option PE_LOAD_ALL_SECTIONS:

// Always load all sections of a PE file?
// If no, sections like .reloc and .rsrc are skipped

PE_LOAD_ALL_SECTIONS = YES

See also: IDA Help: Load file dialog1

1 https://www.hex-rays.com/products/ida/support/idadoc/242.shtml
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#123: Opcode bytes

When disassembling, you are probably more interested in seeing the code (disassembly or pseudocode) rather than the 
raw file data, but there may be times you need to see what actually lies behind the instructions.

One option is to use the Hex View1, possibly docked and synchronized with IDA View.

But probably a simpler solution is the disassembly option2 Number of opcode bytes.

By setting it to a non-zero value, IDA will use the specified number of columns to display the bytes of the instructions at 
the start of the disassembly line.

If the instruction is longer than the specified number of bytes, extra lines will be used to display the remainder of the 
opcode:

If you prefer to have IDA simply truncate the long opcodes instead of using extra lines, specify a negative value (e.g. -4).

Showing opcode bytes by default
If you prefer to always see opcode bytes, you can use the OPCODE_BYTES setting in ida.cfg (either the one in your IDA 
install, or the override in user directory3). This enables opcode bytes in the text view only; for the graph view use the 
setting GRAPH_OPCODE_BYTES.
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1 https://www.hex-rays.com/products/ida/support/idadoc/605.shtml
2 https://hex-rays.com/blog/igors-tip-of-the-week-38-hex-view/
3 https://hex-rays.com/blog/igors-tip-of-the-week-25-disassembly-options/
4 https://hex-rays.com/blog/igors-tip-of-the-week-22-ida-desktop-layouts/

Another possibility is set up the opcode bytes (and other disassembly options) as you like and save the current desktop 
layout as default4; it will be used for all new databases.
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#124: Scripting examples

Although IDA was initially created for interactive usage and tries to automate as much of the tedious parts of RE as pos-
sible, it still cannot do everything for you and doing the still necessary work manually can take a long time. To alleviate 
this, IDA ships with IDC and IDAPython scripting engines, which can be used for automating some repetitive tasks. But it 
can be difficult to know where to start, so let’s see where you can find some examples to get started.

IDC samples
Although IDC is quite old fashioned, it has the advantage of being built-in into IDA and does not require any additional 
software. It is also the only scripting language available in IDA Free1. For some sample IDC scripts, see the idc directory 
in IDA’s install location:

Please note that some of these files are not stand-alone scripts but are used by IDA for various tasks such as custom-
ized startup actions2 (ida.idc, onload.idc) or batch analysis (analysis.idc).

A few user-contributed scripts are also available under the “User contributions” section in our Download center3. Note 
that due to their age and the big API refactoring4 which unified IDA API  and IDC, some of them may need adjustments to 
run in recent IDA versions.

IDAPython examples
IDAPython project had examples from the beginning, and you can find them in the source repository5, but we’re also 
shipping them with IDA, in the python/examples directory.

The provided index.html can be opened in a browser to see the list of the examples with short descriptions and also a 
list of used IDAPython APIs/keywords to help you find examples of a specific API’s usage.
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There are also countless examples of IDAPython scripts and plugins created by our users. Some of then can be found 
on our plugin contest pages6 and plugin repository7, while even more might be found on code-sharing websites (GitHub, 
GitLab etc.), or individual authors’ websites and blogs. Oftentimes, searching for an API name on the Web can bring you 
to examples of its usage.

In addition to the examples made just for demonstration purposes, there are a few Python-based loaders and proces-
sors modules shipped with IDA. They can be found by looking for .py files under loader and procs directories of IDA.

 

1 https://hex-rays.com/blog/igors-tip-of-the-week-116-ida-startup-files/
2 https://hex-rays.com/blog/igor-tip-of-the-week-08-batch-mode-under-the-hood/
3 https://hex-rays.com/download-center/
4 https://hex-rays.com/products/ida/news/7_0/docs/api70_porting_guide/
5 https://github.com/idapython/src/tree/master/examples
6 https://hex-rays.com/contests/ 
7 https://plugins.hex-rays.com/
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#125: Structure field representation

When dealing with structure instances in disassembly, sometimes you may want to change how IDA displays them, but 
how to do it is not always obvious. Let’s have a look at some examples.

Win32 section headers
Let’s say you have loaded the PE file header using manual load1, or found an embedded PE file in your binary, and want 
to format its PE header nicely. Thanks to the standard type libraries2, you can import standard Win32 structures such as 
IMAGE_NT_HEADERS3 or IMAGE_SECTION_HEADER4 and apply them to the header area:

However, because the Name field is declared simply as a BYTE array in the original structure, IDA shows them as bytes 
instead of nice readable string. Without the struct, we could use  the Create string (A) command, but it is also possible to 
show the string as part of the structure instance.

Changing structure field representation
To change how a specific fiield should be formatted in the disassembly, go to it in the structure definition in the Struc-
tures window and use Edit or the context menu. For example,  use the String (A) action to have IDA format the Name byte 
array as a string.

When you edit an imported structure for the first time, you may get this warning:

Because the field type representation cannot be specified in Local Types, we have to edit the structure, so answer Yes 
to continue. A dialog to specify the string length will be displayed, just confirm it:
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1 https://hex-rays.com/blog/igors-tip-of-the-week-122-manual-load/
2 https://hex-rays.com/blog/igors-tip-of-the-week-60-type-libraries/
3 https://learn.microsoft.com/en-us/windows/win32/api/winnt/ns-winnt-image_nt_headers32
4 https://learn.microsoft.com/en-us/windows/win32/api/winnt/ns-winnt-image_section_header
5 https://hex-rays.com/blog/igors-tip-of-the-week-46-disassembly-operand-representation/
6 https://www.hex-rays.com/products/ida/support/idadoc/1042.shtml 
7 https://hex-rays.com/blog/igors-tip-of-the-week-46-disassembly-operand-representation/

The field will gain a comment indicating that the array is now a string:

And the struct instances in the binary will now show the first field as a string:

In addition to strings, you can ofcourse change representation of other structure fields similarly to operand representa-
tion5 for instructions. For example, you can change the SizeOfRawData field to be printed in decimal  instead of the default 
hex.

See also: 
IDA Help: Assembler level and C level types6
Igor’s tip of the week #46: Disassembly operand representation7 
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#126: Non-returning functions

Some functions in programs do not return to caller: well-known examples include C runtime functions like exit(), 
abort(), assert() but also many others. Modern compilers can exploit this knowledge to optimize the code better: for 
example, the code which would normally follow such a function call does not need to be generated which decreases the 
program size. Other functions, which call non-returning functions unconditionally also become non-returning, which can 
lead to further optimizations.

Well-known functions
IDA uses function names to mark well-known non-returning functions. The list of such names is stored in the file cfg/
noret.cfg, which can be edited to add more names if necessary:

Marking non-returning functions manually
Instead of editing noret.cfg, you can also mark a function as non-returning manually on a case-by-case basis. This can 
be done by editing function properties: Edit > Functions > Edit Function… in the main menu, Edit Function… in the context 
menu or the Alt– P shortcut.

Another option is to edit the function’s prototype and add the __noreturn keyword¹.

Identifying no-return calls
Incorrectly identified non-returning calls may lead to various problems during analysis: functions being truncated too 
early; decompiled pseudocode missing big parts of the function and so on. One option is to inspect each function being 
called to see if it has the Does not return flag set (or Attributes: noreturn mentioned in a comment) but this can take a 
long time with many calls. So there are indicators which may be easier to spot:

•	 In the text view, look for dashed line after a call; it indicates a break in the code flow which means that the execu-
tion does not continue after the call, i.e. it does not return.
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1 https://hex-rays.com/blog/igors-tip-of-the-week-52-special-attributes/
2 https://hex-rays.com/blog/igors-tip-of-the-week-98-analysis-options/
3 https://www.hex-rays.com/products/ida/support/idadoc/1729.shtml

•	 In the graph view, when a node which ends with a call has no outgoing edge, this means that the call does not 
return.

•	 In the pseudocode it’s not always obvious, but calls to no-ret functions usually end a compound statement or the 
whole function. You can also switch to the disassembly if the function looks suspiciously short and look for the above 
tell-tales.

Enabling or disabling no-return analysis
If you find that IDA’s treatment of non-returning functions does not work well with your specific binary or set of binaries, 
you can turn it off. This can be done in the first set of the analysis options2 at the initial load time or afterwards. Con-
versely, you can enable it for processors which do not enable it by default.

If you need to permanently enable or disable it for all new databases, edit the ANALYSIS value in ida.cfg to include or not 
the AF_ANORET flag. NB: you should edit the value under #ifdef for the specific processor you need.

See also: IDA Help: Function flags3
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#127: Changing function bounds

When analyzing regular, well-formed binaries, you can usually rely on IDA’s autoanalysis to create functions and detect 
their boundaries correctly. However, there may be situations when IDA’s guesses need to be adjusted.

Non-returning calls
One example could be calls to non-returning functions1. Let’s say a function has been misdetected by IDA as non-return-
ing:

But on further analysis you realize that it actually returns and remove the no-return flag. However, IDA has already trun-
cated the function after the call and now you need to extend it to include the code after call. How to do it?

Recreating the function
This is probably the quickest approach which can be used in simple situations:

1.	 Go to the start of the function (for example, by double-clicking the function in the Functions list2), or via key se-
quence Ctrl– P, Enter.
2.	 Delete the function (from the Functions list), or Ctrl–P, Del. If you were in Graph view, IDA will switch to the text 
view.
3.	 Create it again (Create function… from context menu), or press P.

This works well if the changes were enough to fix the original problem. You may need to repeat this a few times when 
fixing problems one by one. Note that deleting the function may destroy some of the information attached to it (such as 
the function comment), so this is not always the best choice.

Editing function bounds
The Edit function dialog has fields for function’s start and end addresses:

They can be edited to expand or shrink the function, but there are some limitations:

1.	 The new function bounds may not intersect with another function or a function chunk3. They also may not cross a 
segment boundary.
2.	 The function start must be a valid instruction.

Keep in mind that the end address is exclusive, i.e. it is the address after the last instruction of the function.
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1 https://hex-rays.com/blog/igors-tip-of-the-week-126-non-returning-functions/ 
2 https://hex-rays.com/blog/igors-tip-of-the-week-28-functions-list/ 
3 https://hex-rays.com/blog/igors-tip-of-the-week-86-function-chunks/
4 https://www.hex-rays.com/products/ida/support/idadoc/485.shtml
5 https://www.hex-rays.com/products/ida/support/idadoc/487.shtml

Changing the function end
To move the current or preceding function’s end only, you can use the hotkey E (Set function end). If there is a function 
or a chunk at the current address, it is truncated to end just after the current instruction. If the current address does 
not belong to a function, the nearest preceding function or chunk is extended instead. If the extension causes function 
chunks to be immediately next to each other, they’re merged together.

For example, consider this situation:

The instructions in the red rectangle should be part of the function but they’re currently “independent” (this can also 
be seen by the color of the address prefix which is brown and not black like for instructions inside a function). To make 
them part of the function, we can move its end to the last one (0027FD6A). Putting the cursor there and invoking Edit > 
Functions > Set function end (shortcut E) will move the function end from 0027FD44 to 0027FD6A. Because this makes the 
function adjacent to its own chunk, IDA merges the chunk with the function and the function is expanded to cover all 
newly reachable instructions.

See also: 
IDA Help: Edit Function4
IDA Help: Set Function End5
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When exploring an unfamiliar binary, it may be difficult to find interesting places to start from. One common approach 
is to check what strings are present in the program – this might give some hints about its functionality and maybe some 
starting places for analysis. While you can scroll through the listing and look at the strings as you come across them, it is 
probably more convenient to see them all in one place. IDA offer this functionality as the Strings view.

Opening String list
To open the list, use the menu View > Open subviews > Strings, or the shortcut Shift– F12. Note that the first time IDA 
will scan the whole database so it may take some time on big files. If you have a really big binary, it may be useful to se-
lect a range1 before invoking the command will so that the scan is limited to the selection.

The view includes the string’s address, length (in characters, including the terminating one), type (e.g. C for standard 
8-bit strings or C16 for Unicode (UTF-16)), and the text of the string. Double-clicking an entry will jump to the string in the 
binary, and you can, for example, check the cross-references2 to see where it’s used.

String list options
The default settings are somewhat conservative so if you think some items are missing (or, conversely, you see a lot of 
useless entries), changing scan options can be useful. For this, use “Setup..” from the context menu.

•	 Display only defined strings will have IDA include only explicitly 
defined string literals (e.g. strings discovered in a middle of undefined 
areas won’t be included).
•	 Ignore instructions/data definitions makes IDA look for text inside 
code or non-string data.
•	 Strict ASCII (7-bit) strings option shows only strings with characters 
in the basic ASCII range. 
•	 Allowed string types lets you choose what string types you are inter-
ested in.
•	 Minimal string length sets the lower limit on the length the string must 
have to be included in the list. Raising the limit may be useful to filter 
out false positives.

Note that you will likely need to invoke “Rebuild…” from the context menu to 
refresh the list after changing the options.

 

See also: IDA Help: Strings window3

1 https://hex-rays.com/blog/igor-tip-of-the-week-03-selection-in-ida/
2 https://hex-rays.com/blog/igor-tip-of-the-week-16-cross-references/
3 https://www.hex-rays.com/products/ida/support/idadoc/1379.shtml
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Using the string list1 is one way to look for text in the binary but it has its downsides: building the list takes time for big 
binaries, some strings may be missing initially so you may need several tries to get the options right, and then you need 
to actually find what you need in the list.

If you already know the text you want to find (e.g. from the output of the program), there is a quicker way.

Using binary search for text
The binary search action can be invoked via Search > Sequence of bytes… menu, or the Alt– B shortcut. Although its 
primary use is for binding known byte sequences, you can also use it for finding text embedded in the binary. For this, 
surround the text string with double quotes (“). The closing quote is optional.

Once a quote is present in the input box, the String encoding dropdown is enabled. It allows you to choose in which 
encoding2(s) to look for the string.

After confirming, IDA will print in the Output window the exact byte patterns it’s looking for:

Searching down CASE-INSENSITIVELY for binary patterns:

UTF-8: 4A 61 6E
UTF-16LE: 4A 00 61 00 6E 00
UTF-32LE: 4A 00 00 00 61 00 00 00 6E 00 00 00
Search completed. Found at 1001A9C4.

You can also mix string literals and byte values. For example, to find “Jan” but not “January”, add 0 for the C string termi-
nator:

To continue the search, use Search > Next sequence of bytes…, or shortcut Ctrl– B.

See also:
Igor’s tip of the week #48: Searching in IDA3
IDA Help: Search for substring in the file4
IDA Help: Binary string format5

1 https://hex-rays.com/blog/igors-tip-of-the-week-128-strings-list/
2 https://hex-rays.com/blog/igor-tip-of-the-week-13-string-literals-and-custom-encodings/
3 https://hex-rays.com/blog/igors-tip-of-the-week-48-searching-in-ida/
4 https://www.hex-rays.com/products/ida/support/idadoc/579.shtml
5 https://www.hex-rays.com/products/ida/support/idadoc/528.shtml
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#130: Source line numbers

Debug information, whether present in the binary or loaded separately1, can contain not only symbols such as function or 
variable names, but also mapping of binary’s instructions to the original source files. It can be used by IDA’s debugger for 
source-level debugging2, but what if you want to see this mapping during static analysis?

Enabling source line number display
Assuming the line number info was available and has been imported, it can be enabled in the Options > General… dialog, 
Disassembly tab:

Once enabled, IDA will add automatic comments with the file name and line number in the disassembly listing:

To enable this for all new databases by default, change SHOW_SOURCE_LINNUM setting in ida.cfg.

Importing line numbers from DWARF
DWARF debug format can also include line number information, but by default it’s skipped because it’s rarely needed in 
the database itself and can take a long time to load for big files. If you do need it, you should enable the corresponding 
option when prompted by IDA:
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1 https://hex-rays.com/blog/igors-tip-of-the-week-55-using-debug-symbols/ 
2 https://hex-rays.com/blog/igors-tip-of-the-week-85-source-level-debugging/ 
3 https://hex-rays.com/blog/igors-tip-of-the-week-55-using-debug-symbols/
4 https://hex-rays.com/blog/igors-tip-of-the-week-85-source-level-debugging/

To always import line numbers from DWARF debug info, enable DWARF_IMPORT_LNNUMS in cfg/dwarf.cfg.

See also:
Igor’s tip of the week #55: Using debug symbols3
Igor’s tip of the week #85: Source-level debugging4
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#131: Advanced filters in choosers

We’ve covered choosers previously1 and talked about searching, sorting and filtering. The default filter (Ctrl– F shortcut) 
is pretty simple: it performs case-insensitive match on any column of the list.

Advanced filters 
Advanced filter dialog is accessible via the context menu entry “Modify filters…” or the shortcut Ctrl–Shift–F

In the dialog you can:

•	 match any or a specific column;
•	 perform an exact match (is/is not) or partial (contains/doesn’t contain, begins/ends with);
•	 perform a lexicographical comparison (less than/more than);
•	 decide whether a specific filter excludes, includes, or highlights matches;
•	 disable and enable filters individually;
•	 use case-sensitive matching or regular expressions.

Examples
The following set of filters excludes functions which start with sub_, or situated in segments extern (external functions) 
and .plt (PLT thunks for external functions). This way only the functions defined inside the binary which have non-dum-
my names2 are shown:

Highlight any function with name ending in _NNN where NNN is a sequence of decimal numbers:

The highlight color can be changed by clicking the “Highlight button”.

Show only functions which were detected by IDA as non-returning3:
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1 https://hex-rays.com/blog/igors-tip-of-the-week-36-working-with-list-views-in-ida/ 
2 https://hex-rays.com/blog/igors-tip-of-the-week-34-dummy-names/
3 https://hex-rays.com/blog/igors-tip-of-the-week-126-non-returning-functions/
4 https://hex-rays.com/blog/igors-tip-of-the-week-36-working-with-list-views-in-ida/

NOTE: the examples listed apply to the Functions list but these filters are available in any chooser (list view) in IDA: Im-
ports, Exports, Names, Local Types etc.
 

See also: Igor’s tip of the week #36: Working with list views in IDA4
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#132: Finding “hidden” cross-references

When analyzing firmware or other binaries without metadata, IDA is not always able to discover and analyze all functions 
which means the cross-references can be missing. Let’s say you found a string in the binary (e.g. in the String list1) which 
has no cross references, but you’re reasonably sure it’s actually used. How to discover where?

Finding addresses using binary search
One possibility is that the string is referred to by its address value, either from a pointer somewhere, or as an immediate 
value embedded directly in the instruction (the latter case is more common for CISC instruction sets such as x86). In 
such case, looking for the address value should discover it.

For example, here’s a string in an ARM firmware which currently has no cross-references:

We can try the following:

1.	 Select and copy to clipboard the string’s address (C3E31B49);
2.	 Go to the start of the database (Ctrl– PgUp or Home, Home, Home);
3.	 Invoke binary search (Search > Sequence of bytes…, or Alt–B);
4.	 Paste the address and make sure that Hex is selected. It is also recommended to enable Match case to avoid false 

positives:

5.	 Click OK. IDA will automatically convert the value into a byte sequence corresponding to the processor endianness 
and look for it in the database:

The value may be initially displayed as a raw number or even separate bytes. To convert it to an offset so that xref is 
created you can usually use the O or Ctrl– O shortcuts, or the context menu:

Now the string has a cross-reference and you can look further at where exactly it is used: 

Finding addresses using immediate search
Binary search works for addresses embedded as-is into the binary. However, there may be situations where an address 
is embedded into an instruction not on a byte boundary, or split between several instructions. For example, RISC-V usu-
ally has to use at least two instructions to load a 32-bit value into a register (high 20 bits and low 12 bits). In case these 
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1 https://hex-rays.com/blog/igors-tip-of-the-week-128-strings-list/
2 https://hex-rays.com/blog/igor-tip-of-the-week-04-more-selection/
3 https://hex-rays.com/blog/igors-tip-of-the-week-110-self-relative-offsets/
4 https://hex-rays.com/blog/igors-tip-of-the-week-95-offsets/
5 https://hex-rays.com/blog/igors-tip-of-the-week-114-split-offsets/

instructions are next to each other, IDA can combine them into a single macroinstruction and calculate the full value, but 
because it’s split between two instructions, binary search won’t find it. However, immediate search (Search > Immediate 
value…, or Alt– I) should work. Note that if you copy the address from the listing, you’ll need to add 0x so that it can be 
parsed as hexadecimal by IDA.

NOTE: this approach will succeed only under the following conditions:

1.	the instruction(s) using the address were actually decoded. You can try the approach described in Tip #042 to try 
disassembling the whole binary before looking for cross-references;

2.	the instructions were actually combined into a macro with the full address. For example, if they are interleaved with 
unrelated instructions, IDA won’t be able to combine them and you may need to look for each part separately.

 
Unfortunately, even the methods described here are not always enough. For example, self-relative offsets3 will likely 
require analyzing the code to figure out what they refer to.

See also: 
Igor’s tip of the week #95: Offsets4
Igor’s Tip of the Week #114: Split offsets5
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#133: Alignment items

Sometimes you may see mysterious align keywords in the disassembly, which can appear both in code and data areas:

Usually they’re only apparent in the text view.

These directives are used by many assemblers to indicate alignment to a specific address boundary, usually a power of 
two. IDA uses it to replace potentially irrelevant bytes by a short one-liner, both for more compact listing and to indicate 
that this part of the binary is probably not interesting. 

Depending on the processor and the assembler chosen, different keyword can be used (e.g. align or .align), and the 
number after the directive can mean either the number of bytes or the power of two (i.e. 1 means aligning to two bytes, 2 
to four, 4 to sixteen and so on).

The alignment items can appear in the following situations:

Code alignment padding
Many processors use instruction caches which speed up execution of often-executed code (for example, loops). This 
is why it may be useful to ensure that start of a loop is aligned on a specific address boundary (usually 16 bytes). For 
this, the compiler needs to insert instructions which do not affect the behavior of the function, i.e. NOP (no-operation) 
instructions. Which specific instructions are used depends on the processor and compiler. 

For example, here GCC used a so-called “long NOP” to align the loop on 16 bytes (obvious thanks to the hexadecimal 
address ending with 0). Because this instruction is actually executed, IDA shows it as code and not as an align expres-
sion (which is considered non-executable and would break disassembly), but you can still convert it manually.

There may also be hardware requirements. On some processors the interrupt handlers must be aligned, like in this ex-
ample from PowerPC:

Here, 4 is a power-of-two value, i.e. alignment to 16-byte boundary.
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Function padding
Similarly to loops, whole functions can benefit from the alignment, so they’re commonly (but not always!) aligned to at 
least four bytes. Because the functions are usually placed one after the other but the function size is not always a mul-
tiple of the alignment, extra padding has to be inserted by the compiler and/or the linker. Two common approaches are 
used:

1.	executable NOP instructions, just like for the loop alignment. This is the approach commonly used by GCC and 
derived compilers:

2.	invalid or trapping instructions. This can be useful to catch bugs where execution is diverted to an address between 
functions, for example due to a bug or an exploit. Microsoft Visual C++, for example, tends to use 0xCC (breakpoint 
instruction) to pad the space between functions on x86:

Data alignment padding
Many processors have alignment requirements: some can’t even load data from unaligned addresses, and others can 
usually fetch aligned data faster. So the compilers often try to ensure that data items are placed on an aligned address 
boundary (usually at least 4 bytes). Most commonly, zero-fill padding is used:

Although NOP-like fillers may be used by some compilers too, especially for constant data placed in executable areas:

Converting alignment items
While rare, it may be necessary for you to change IDA’s decision concerning an alignment item. Because they’re mostly 
equivalent to data items, you can use the usual shortcut U to undefine them (convert to plain bytes), and then C to convert 
to code (in case they correspond to valid instructions).

To go the other way (convert instructions or undefined bytes) to an alignment item, use Edit > Other > Create alignment 
directive…, or just the shortcut L. IDA will check at what address is the next defined instruction or data item and will offer 
possibly several alignment options depending on its address. For example, in this situation:
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The current address is divisible by 4 so any alignment less than 4 is not applicable. The following defined address ( 
7FF674A1A20) is divisible by 32, so IDA offers options 8, 16 and 32. Note that if you choose 8, the alignment item will only 
cover the first 4 bytes (up to 7FF674A1A18), so in this situation 16 or 32 makes the most sense.
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#134: ARM BL jumps

If you ever looked at IDA ARM module’s processor-specific settings1, you may have been puzzled by the option “Disable 
BL jumps detection”.

What is it and when to use it?

Background
The ARM instruction set initially used fixed-width 32-bit instructions. The relative branch instruction, B, allocated 24 bits 
for the offset, giving it a range of ±32MB.

Some time later, ARM introduced a a compact 16-bit encoding for a subset of instructions, called Thumb. Because most 
relative branches occur in the same function, the ±2KB range available for 16-bit B instructions was usually enough. In 
case longer distance was needed, a longer instruction sequence would have to be generated.

Some compiler writers realized, that the BL instruction, normally used for function calls, can be used for simple branch-
es as well. On ARM, the function calls do not use the stack, so the only side effect of BL as opposed to simple branch 
is that it sets the LR register to the address following the BL instruction. If the LR is saved at the start of the current 
function, it does not matter that if LR is clobbered by the intermediate BL instructions, since it can be restored from the 
saved area to return to the caller. The BL is encoded as pair of 16-bit instructions, which gives it a range of ±4MB.

A later extension of the Thumb, called Thumb-2, introduced a 32-bit version of B, giving it a range of ±16MB, so there is 
less need of such tricks in code compiled for modern processors which support Thumb-2. However, old code still needs 
to be analyzed sometimes, so it may be necessary to support such usage of BL. 

Example
Here’s an example of a Thumb mode program which looks a little strange…

IDA has created a function because of the BL instruction which normally implies a function call. But we see that func is 
not complete, so most likely sub_C is actually its continuation and BL is used only as a branch. Also, func saves LR on the 
stack, so BL clobbering it does not matter.
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1 https://hex-rays.com/blog/igors-tip-of-the-week-98-analysis-options/
2 https://hex-rays.com/blog/igors-tip-of-the-week-126-non-returning-functions/
3 https://hex-rays.com/blog/igors-tip-of-the-week-127-changing-function-bounds/
4 https://hex-rays.com/blog/igor-tip-of-the-week-09-reanalysis/
5 https://www.hex-rays.com/products/ida/support/idadoc/681.shtml

Marking single instructions
If the BL-as-branch approach is used only in few cases, you can handle them manually. For this, place the cursor on the 
line with BL and use Edit > Other > Force BL jump menu item. IDA will take this into account and indicate that this BL 
does not continue to the next instruction by adding a dashed comment line after it2. 

You can then delete the wrongly created function and extend3 or recreate the original one which had been truncated.

Changing analysis behavior
If the binary has multiple functions which use this technique, it may be worth it to let the analyzer check each BL destina-
tion before creating functions. For this, turn off Disable BL jumps detection in the processor specific options and reana-
lyze the program4. Note that you will likely have to delete the wrongly created functions, so it may be better to reload the 
file, changing the options in the initial Load File dialog.

To set this by default, change ARM_DISABLE_BL_JUMPS value in ida.cfg.

In cases where the BL jumps detection fails  (it marks a BL as a jump where it should be a call, or vice versa), you can 
always override its decision using Force BL jump and Force BL call menu options. In case you discover a specific code 
pattern and need to script it, you can also use IDC functions5 force_bl_jump(ea) and force_bl_call(ea).
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#135: Exporting disassembly from IDA

Although most of the time you can probably do all of the reversing inside IDA, occasionally you may need to continue it 
using other tools. While sometimes it may be enough to analyze the input file with another tool, or use the Export Data1 
feature, the disassembly listing is more convenient in many cases. Of course, you can use the clipboard to copy some 
snippets, but this can be awkward and slow if you need big chunks of the listing, or need to remove unnecessary parts of 
the listing such as the address prefixes.

ASM file
ASM files can be generated by using the menu entry File > Produce File > Create ASM File…, or the shortcut Alt–F10.

By default, the contents of the whole database is exported, but you can select a range2 before invoking the command to 
limit it to just what you need. If you need multiple fragments, you can repeat the action several time, choosing “Append” 
when IDA informs you that the file already exists.

In ideal circumstances, the ASM listing can be passed to the assembler to generate code equivalent to the original 
binary. It means it does not contain extra annotations which may be present in IDA, such as address prefixes or opcode 
bytes3. Of course, the reality is often not so simple, but minor modification to the ASM file may be enough to solve your 
problem.

LST file
The LST file can be generated via the menu entry File > Produce File > Create LST File… (no default shortcut). Unlike the 
ASM file, it contains all the information present in IDA’s text view, so it can be useful if you want to see opcode bytes3 or 
address prefixes.

Protip
The ASM or LST file usually needs at least one line of text per each instruction or data item. If your database contains 
large data areas, converting them to arrays4 before exporting can reduce the size of the output files significantly. Hiding 
or collapsing5 uninteresting areas or whole segments is another option.

1 https://hex-rays.com/blog/igors-tip-of-the-week-39-export-data/ 
2 https://hex-rays.com/blog/igor-tip-of-the-week-03-selection-in-ida/ 
3 https://hex-rays.com/blog/igors-tip-of-the-week-123-opcode-bytes/ 
4 https://hex-rays.com/blog/igor-tip-of-the-week-10-working-with-arrays/ 
5 https://hex-rays.com/blog/igors-tip-of-the-week-31-hiding-and-collapsing/
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#136: Changing assembler syntax

When exporting disassembly1, sometimes you need to modify it so that it is accepted by a specific assembler you’re 
using. One little-known fact is that some of IDA’s processor modules support different assembler syntaxes, so it may be 
useful to try a different one to see if it matches your needs better.

The assembler can be changed via Options > General…, Analysis tab:

For example, on x86 the TASM Ideal syntax may be selected instead of the default Generic one (based on MASM). One 
feature of this syntax is that it always uses brackets for instructions which dereference memory pointers.

For ARM, you can choose a legacy assembler, which was used before introduction of UAL (unified assembly language) 
with Thumb-2. For example, it used explicit STMFD and LDMFD instructions instead of the more convenient PUSH and POP 
introduced for Thumb. 

Nowadays, IDA defaults to the generic UAL assembler which is de-facto standard and easier to read.

For some of the older processors the selection of assemblers can be quite extensive; they often didn’t have a freely 
available official assembler so many third-party alternatives were available.

1 https://hex-rays.com/blog/igors-tip-of-the-week-135-exporting-disassembly-from-ida/
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#137: Processor modes and segment registers

Some of the processors supported by IDA support different ISA variants, in particular:

•	ARM processor module supports the classic 32-bit ARM instructions (A32), 16-bit Thumb or mixed 16/32-bit 
Thumb32 (T32) , as well as 64-bit A64 instructions (A64)

•	PPC processor module supports the standard 32-bit PowerPC instructions and mixed 16/32-bit Variable Length 
Environment (VLE)

•	MIPS module supports the classic 32-bit instructions as well as the compressed variants MIPS16 and microMIPS

Because sometimes these instructions sets may be present in the same binary, IDA needs a way to determine which 
subset to use. For this, it repurposes segment registers, originally used on 16-bit x86 processors to extend the 16-bit 
addressing. For example, if you load an ARM firmware binary, you will see the following informational box:

In many cases, IDA is able to determine the correct processor mode by analyzing the code and determining mode switch 
sequences (e.g. BX/BLX instructions), but you can also force its decision by using the described shortcut Alt– G (if you 
prefer menus, you can find it in Edit > Segments > Change segment register value…).

In the dialog, select the T register and specify 0 for ARM mode or 1 for Thumb (includes Thumb32 aka Thumb-2).

You can observe mode switches in the disassembly listing by the CODE32/CODE16 directives (usually text view only):
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1 https://www.hex-rays.com/products/ida/support/idadoc/524.shtml
2 https://www.hex-rays.com/products/ida/support/idadoc/547.shtml

If you need a global overview, use the View> Open subviews > Segment registers…. (Shift– F8) view or its modal version 
Jump > Jump to segment (Ctrl– G):

The Tag column gives a hint on how the specific changepoint was created: a denotes a changepoint added by IDA during 
autoanalysis while u is used for those specified by the user (or, sometimes a plugin).

If necessary, wrong changepoints can be deleted from the list (even many at a time, using the selection). When a change 
point is deleted, IDA uses the value of a preceding one (or the default for the current segment).

For MIPS, the mips16 pseudoregister is used to switch between standard MIPS and MIPS16 or microMIPS, and for PPC, 
vle is used to enable decoding of VLE instructions.

See also:
IDA Help: Segment Register Change Points1
IDA Help: Jump to the specified segment register change point2
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#138: Pointer math in the decompiler

While working with decompiled code and retyping variables (or sometimes when they get typed by the decompiler auto-
matically), you might be puzzled by the discrepancies between pseudocode and disassembly.

Consider the following example:

We see that X22 is accessed with offset 0x10 (16) in the disassembly but 2 in the pseudocode. Is there a bug in the de-
compiler?

In fact, there is no bug. The difference is explained by the C/C++pointer/array referencing rules: the array indexing or 
integer addition operation advances the pointer value by the value of index multiplied by the element size. In this case, 
the type of v4 is _QWORD*, which means that elements are _QWORDs (64-bit or 8-byte integers). Thus, 2*8=16(0x10), which 
matches the assembly code.

To confirm what’s really going on, you can do “Reset pointer type” on the variable so that it reverts to the generic integer 
variable and the decompiler is forced to use raw byte offsets:

See also:
Igor’s Tip of the Week #117: Reset pointer type1
Igor’s tip of the week #42: Renaming and retyping in the decompiler2
Igor’s Tip of the Week #118: Structure creation in the decompiler3

1 https://hex-rays.com/blog/igors-tip-of-the-week-117-reset-pointer-type/ 
2 https://hex-rays.com/blog/igors-tip-of-the-week-42-renaming-and-retyping-in-the-decompiler/ 
3 https://hex-rays.com/blog/igors-tip-of-the-week-118-structure-creation-in-the-decompiler/
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#139: License borrowing

Floating licenses allow additional flexibility for companies with many IDA users: IDA can be installed on as many comput-
ers as required, but only a limited number of copies can run simultaneously.  

This flexibility its downsides: IDA needs to have permanent connection to your organization’s license server which may 
make things problematic in some situations (e.g. working on an isolated network or in the field/while traveling). While 
the first issue can be handled by placing the license server inside that network, accessing the company network during 
travel may be problematic or impossible. In such situations, you can use license borrowing.

Borrowing allows the user to check out the license for a fixed period and work without connection to the server during 
that time.

Borrowing licenses
To borrow a license, in a floating-license IDA go to  Help > Floating licenses > Borrow licenses…

You will get a dialog like the following:

Here you can pick which licenses you want to borrow and the borrow period end date. By default, IDA offers one week 
but you can make it shorter or longer (by default we limit the maximum borrow period to 6 months but it can be limited 
further by the license server administrator). 

If you click “Borrow”, you  should see this confirmation:

and the details in the Output window:

Successfully borrowed licenses:
IDAPROFW (IDA Pro) [currently borrowed until 2023-05-12 23:59]

After this, you can disconnect from the network and IDA will continue working until the specified date.

NB: once borrowed, the license(s) remain checked out (“In Use”) on the license server and will not become available for 
others until the end of the borrow period or early return.
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1 https://hex-rays.com/products/ida/support/flexlm/#borrow
2 https://hex-rays.com/products/ida/support/flexlm/

Returning licenses
If you need to return borrowed licenses early (before the end of the borrow period):

1.	Reconnect to the network with the server from which you borrowed the license
2.	Go to Help > Floating licenses > Return licenses

3.	select the license(s) to return and click “Return and Exit”.
4.	IDA will exit since it has returned the license, but you can start it again to use the license server in online mode or 

borrow again for another period.

Borrowing and returning licenses from command line
If you prefer using command line, check the corresponding section on our support page1.

See also: Floating Licenses2
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#140: Loading PDB types

While IDA comes with a rich set of type libraries1 for Windows API, they don’t cover the whole set of types used in 
Windows. Our libraries are based on the official Windows SDK/DDK headers, which tend to only include public, stable 
information which is common to multiple Windows versions. A new Windows build may introduce new types or use some 
of the previously reserved fields. Because some of these structures are critical for proper debugging, Microsoft usually 
publishes a subset of actual, up-to-date types in the PDBs for the core Windows modules (kernel32.dll and ntdll.dll 
for user mode, ntoskrnl.exe for kernel mode). Thus, usually you can use these files to get types matching the Windows 
version you’re analyzing.

Loading types from PDB
To load an additional PDB file, use File > Load file > PDB File…

Here, you can specify either an already downloaded PDB, or a path to .exe or .dll. In the latter case, IDA will try to fetch 
the matching PDB from the symbol servers. Because we’re loading the PDB which does not actually match the currently 
loaded file, check “Types only” so that the global symbols from it are not applied unnecessarily.

After downloading and processing the PDB, the new types can be consulted in the Local Types view.

See also:
Igor’s tip of the week #55: Using debug symbols2

1 https://hex-rays.com/blog/igors-tip-of-the-week-60-type-libraries/ 
2 https://hex-rays.com/blog/igors-tip-of-the-week-55-using-debug-symbols/
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#141: Parsing C files

Previosuly, we’ve covered creating structures from C code using the Local Types window1, however this may be not very 
convenient when you have complex types with many dependencies (especially of scattered over several fiels or depend-
ing on preprocessor defines). In such case it may be nore convenient to parse the original header file(s) on disk.

Parsing header files
If you happen to have the types you need in a header file, you can try using IDA’s built-in C parser via the File > Load file 
> Parse C header file… (shortcut Ctrl+ F9).

Just like a compiler, IDA will handle the preprocessor directives (#include, #define, #ifdef and so on), and add any types 
discovered to the Local Types list, from where they can be used in the decompiler (or the disassembly, after importing 
into the IDB).

Setting compiler options
IDA’s built-in parser can mimic several popular compilers, including Visual C++, GCC (and compatibles), Borland C++ 
Builder, or Watcom. For many stuctured files the compiler is preset to a detected or guessed value, but you can also 
change or set it via Options > Compiler… dialog:

In this dialog you can also adjust settings necessary for the preprocessing 
step, such as the predefined preprocessor macros (#defines) or the include 
paths for the #include directives. They are pre-filled from the CC_PARMS set-
ting in ida.cfg.

Clang parser
The built-in parser is quite basic and handles mostly simple C syntax or very basic C++ (e.g templates are not support-
ed). If you have complex files employing new, modern C or C++ features, you may have more luck using the Clang-based 
parser added in IDA 7.7. It can be selected in the Source parser dropdown of the compiler options dialog  and will be 
used next time you invoke the Parse C header file command. For the details on using it, see the dedicated IDAClang 
tutorial2.

See also: 
IDA Help: Load C header3
IDA Help: Compiler4
Igor’s tip of the week #62: Creating custom type libraries5
Introducing the IDAClang Tutorial2

1 https://hex-rays.com/blog/igor-tip-of-the-week-11-quickly-creating-structures/ 
2 https://hex-rays.com/tutorials/idaclang/ 
3 https://www.hex-rays.com/products/ida/support/idadoc/1367.shtml 
4 https://www.hex-rays.com/products/ida/support/idadoc/1354.shtml 
5 https://hex-rays.com/blog/igors-tip-of-the-week-62-creating-custom-type-libraries/
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#142:  Mapping local types

When working on a binary, you often recover types used in it from many sources:

•	creating structures manually, from data1, or using decompiler2;
•	parsing header files3;
•	 importing them from type libraries4 or debug information5;

However, it may happen that eventually you discover duplicates. For example, you find out that the “custom” structure 
you’ve been building up is actually a well-known type and you found the correct definition in debug info or header files. 
Or, after analyzing two different functions, you only find out later that two structures are, in fact, one and the same. Of 
course, you can go and replace all references to the “wrong” one manually, which is doable if you discover this early, but 
if you already have hundreds of functions or other types referring to it, the process can become tedious.

Type mapping
To map a type to another, open the Local Types window (Shift-F1), and choose “Map to another type…” from the context 
menu on the type you want to map.

After choosing the type to replace it, the original type is deleted and all references to it are redirected to the new one. 
This is indicated by the arrow sign pointing to the new type’s definition.

All uses of the old type in the function prototypes, local variable types etc. are replaced by the new type automatically.

See also:

IDA Help: Local types window6

1 https://hex-rays.com/blog/igor-tip-of-the-week-11-quickly-creating-structures/ 
2 https://hex-rays.com/blog/igors-tip-of-the-week-118-structure-creation-in-the-decompiler/ 
3 https://hex-rays.com/blog/igors-tip-of-the-week-141-parsing-c-files/
4 https://hex-rays.com/blog/igors-tip-of-the-week-60-type-libraries/ 
5 https://hex-rays.com/blog/igors-tip-of-the-week-140-loading-pdb-types/
6 https://www.hex-rays.com/products/ida/support/idadoc/1259.shtml
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#143:  Fixing wrong address references in the decompiler

When decompiling code without high-level metadata (especially firmware), you may observe strange-looking address 
expressions which do not seem to make sense.

What are these and how to fix/improve the pseudocode?

Because on the CPU level there is no difference between an address and a simple number1, distinguishing addresses 
and plain numbers is a difficult task which is not solvable in general case without actually executing the code. IDA uses 
some heuristics to try and detect when a number looks like an address and convert such numbers to offsets2, but such 
heuristics are not always reliable and may lead to false positives. This can be especially bad when the database has valid 
addresses around 0, because then many small numbers look like addresses. The decompiler relies on IDA’s analysis and 
uses the information provided by it to produce the pseudocode which is supposed to faithfully represent behavior of the 
machine code. However, this can backfire in case the analysis made a mistake. Thankfully, IDA is interactive and allows 
you to fix almost anything.

In situation like above, usually the simplest algorithm is as follows:

1.	position cursor on the wrong address expression
2.	press Tab to switch to disassembly. You should land on or close to the wrong offset expression. Note that it does 

not always match what you see in the pseudocode.

3.	convert it to a plain number, e.g. by pressing Q (hex), H (decimal) or # (default).

4.	press Tab to switch back to pseudocode and F5 to refresh it. The wrong expression should be converted to plain 
number or another context-dependent expression.

1 https://hex-rays.com/blog/igors-tip-of-the-week-46-disassembly-operand-representation/ 
2 https://hex-rays.com/blog/igors-tip-of-the-week-95-offsets/
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#144:  Macros and simplified instructions

Many processors (especially RISC based) use instruction sets with fixed size (most commonly 4 bytes). Among exam-
ples are ARM, PPC, MIPS and a few others. This is also obvious in the disassembly when observing the instructions’ 
addresses – they increase by a fixed amount:

However, occasionally you may come across larger instructions:

What is this? Does A64 ISA have 8-byte instructions?

In fact, if you check ARM’s documentation1, you’ll discover that ADRL is a pseudo-instruction which generates two 
machine instructions, ADRP and ADD. IDA combines them to provide more compact disassembly and improve cross-ref-
erences.

In IDA’s terminology, a pseudo-instruction which replaces several simpler instructions is called a macro instruction.

Disabling macros
If you prefer to see the actual instructions, you can disable macros. This can be done in the Kernel Options 3 group of 
settings:

And now IDA no longer uses ADRL:
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#144:  Macros and simplified instructions

As can be seen in this example, it can produce misleading disassembly (ADRP can only use page-aligned addresses 
which is why it seems to refer to some unrelated string)

Simplified instructions
In addition to macros, sometimes IDA may transform single instructions to improve readability or make their behavior 
more obvious. For example, on ARM some instructions have preferred disassembly form and by default IDA uses it.

Instruction simplification feature is usually controlled by a processor-specific option.

Other disassembly improvements

Some processor modules may have other options which may change disassembly to improve readability even if it 
sometimes means the resulting listing is not strictly conforming. For example, MIPS has an option to simplify instructions 
which use the global register $gp which usually has a fixed value and using it makes disassembly much easier to read:
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1 https://developer.arm.com/documentation/dui0801/e/A64-General-Instructions/ADRL-pseudo-instruction?lang=en
2 https://hex-rays.com/blog/igors-tip-of-the-week-137-processor-modes-and-segment-registers/
3 https://hex-rays.com/blog/igors-tip-of-the-week-98-analysis-options/

If you are curious about what the options in the dialog do, clicking “Help” shows a short explanation:

See also:
Igor’s Tip of the Week #137: Processor modes and segment registers2
Igor’s tip of the week #98: Analysis options3
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#145:  HTML export

We’ve covered exporting disassembly from IDA1 before but it was in context of interoperability, when simple text is 
enough. If you want to preserve formatting and coloring of IDA View (e.g. for a web page or blog post), taking a screen-
shot is one option, but that has its downsides (e.g. no indexing for search engines). There is an alternative you can use 
instead.

HTML export
To export a fragment of disassembly as HTML, select2 the desired address range in the listing and invoke File > Produce 
file > Create HTML file…

IDA will ask you for a filename and write the formatted text to it. The result will look like similar to the following:

<!DOCTYPE HTML PUBLIC “-//W3C//DTD HTML 4.01 Transitional//EN” “http://www.w3.org/TR/html4/loose.dtd”>
<html>
<head>
<meta http-equiv=”Content-Type” content=”text/html; charset=ISO-8859-1”>
<title>IDA - riscv_lscolors64.elf </title>
</head>
<body class=”c41”>
<span style=”white-space: pre; font-family: Consolas,monospace;” class=”c1 c41”>
<span class=”c44”>.text:0000000000005528 </span><span class=”c5”>addi </span><span class=”c33”>s4</
span><span class=”c9”>, </span><span class=”c33”>sp</span><span class=”c9”>, </span><span 
class=”c12”>248h</span><span class=”c9”>+</span><span class=”c25”>var_1A0
</span><span class=”c44”>.text:000000000000552C </span><span class=”c5”>mv </span><span class=”c33”>a0</
span><span class=”c9”>, </span><span class=”c33”>s4
</span><span class=”c44”>.text:000000000000552E </span><span class=”c5”>mv </span><span class=”c33”>a1</
span><span class=”c9”>, </span><span class=”c33”>s0
</span><span class=”c44”>.text:0000000000005530 </span><span class=”c5”>li </span><span class=”c33”>a2</
span><span class=”c9”>, </span><span class=”c12”>0A0h
</span><span class=”c44”>.text:0000000000005534 </span><span class=”c5”>call </span><span class=”c37”>mem-
cpy
</span>
</span><style type=”text/css”>
/* line-fg-default */
.c1 { color: blue; }
/* line-bg-default */
.c41 { background-color: white; }
/* line-pfx-func */
.c44 { color: black; }
/* line-fg-insn */
.c5 { color: navy; }
/* line-fg-register-name */
.c33 { color: navy; }
/* line-fg-punctuation */
.c9 { color: navy; }
/* line-fg-numlit-in-insn */
.c12 { color: green; }
/* line-fg-locvar */
.c25 { color: green; }
/* line-fg-code-name */
.c37 { color: blue; }
</style></body></html>

As you can see, the color tags are represented by CSS classes which can be adjusted if necessary. When opened in 
browser, the result should look pretty close to IDA View:
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1 https://hex-rays.com/blog/igors-tip-of-the-week-135-exporting-disassembly-from-ida/ 
2 https://hex-rays.com/blog/igor-tip-of-the-week-03-selection-in-ida/ 
3 https://hex-rays.com/products/ida/processor-gallery/
4 https://www.hex-rays.com/products/ida/support/idadoc/1504.shtml
5 https://www.hex-rays.com/products/decompiler/manual/cmd_html.shtml
6 https://hex-rays.com/blog/hack-of-the-day-0-somewhat-automating-pseudocode-html-generation-with-idapython/

We use this feature on our web site to display disassembly snippets for the processor gallery3.

Pseudocode to HTML
HTML can be generated not only for disassembly but also for the decompiled pseudocode; for this use “Generate 
HTML…” from the context menu in the Pseudocode view.

 
See also:
IDA Help: Create HTML File4
Hex-Rays interactive operation: Generate HTML file5
Hack of the day #0: Somewhat-automating pseudocode HTML generation, with IDAPython.6
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#146:  Graph printing

While exporting text disassembly is enough in many cases, many users nowadays prefer IDA’s graph view1, and saving its 
representation may be necessary. What other options are there besides screenshots?

WinGraph
WinGraph is an external program shipped with IDA which can display graphs. It was used to show function (and other) 
graphs before introduction of the built-in graph view in IDA 5.0 (2006). You can still use it via the  View > Graphs menu. 

For example, Flowchart action displays the graph of the current function.

Once the graph is displayed in WinGraph, you can print it using File > Print…  or the first toolbar button. On most plat-
forms this supports printing to PDF in addition to real printers.

IDA graph view
If you prefer IDA’s graph layout, or have customized it to your liking (groups or custom layouts are ignored by WinGraph), 
you can also print it directly from IDA. For this, use the print buttion on the Graph View toolbar, or the context menu by 
right-clicking outside of  any node.
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1 https://hex-rays.com/blog/igors-tip-of-the-week-23-graph-view/ 
2 https://hex-rays.com/blog/igors-tip-of-the-week-23-graph-view/ 
3 https://hex-rays.com/blog/igors-tip-of-the-week-145-html-export/ 
4 https://hex-rays.com/blog/igors-tip-of-the-week-135-exporting-disassembly-from-ida/

You will be asked about the page layout – this can be useful when printing large graphs

See also:
Igor’s tip of the week #23: Graph view2
Igor’s Tip of the Week #145: HTML export3
Igor’s Tip of the Week #135: Exporting disassembly from IDA4
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#147:  Fixing “stack frame is too big”

The Hex-Rays decompiler has been designed to decompile compiler-generated code, so while it can usually handle 
hand-written or unusual assembly, occasionally you may run into a failure, especially if the code has been modified to 
hinder decompilation. Here is one of such errors:

If you have a genuine function with a huge stack frame, you’ll probably have to give up and RE it the hard way – from the 
disassembly. However, in some situations it is possible to fix the code and get the function decompiled.

Bogus stack variables
Stack variable with a large offset may be created by mistake (e.g. pressing K on an immediate operand), or induced 
deliberately (e.g. junk code referring to large stack offsets which are not used in reality). The fastest way to check for 
them is to look at the stack variable definitions at the start of the function and look for unusually large offsets:

To fix, double-click the variable or press Ctrl–K to open the stack frame editor1, then undefine (U) the wrong stackvar(s).

Then you need to edit the function properties2 (Alt– P) and reduce the local variables area to the actually used size (usu-
ally equival to the offset of the bottom-most actually used variable):
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1 https://hex-rays.com/blog/igors-tip-of-the-week-65-stack-frame-view/ 
2 https://hex-rays.com/blog/igors-tip-of-the-week-127-changing-function-bounds/
3 https://hex-rays.com/blog/igors-tip-of-the-week-37-patching/
4 https://hex-rays.com/blog/igors-tip-of-the-week-27-fixing-the-stack-pointer/
5 https://hex-rays.com/blog/igors-tip-of-the-week-27-fixing-the-stack-pointer/
6 https://www.hex-rays.com/products/decompiler/manual/failures.shtml

If you still get the error message after all that, the bogus variables may have been re-added during autoanalysis, so it 
may be necessary to patch out3 or otherwise exclude from analysis the instructions which refer to them.

Unusual stack pointer manipulation
This trick may cause IDA to decide that the stack pointer changes by a huge value, or not detect stack changes, causing 
it to grow the stack frame unnecessarily. This can be dealt with by adjusting the stack pointer delta4 manually, or patch-
ing the instructions involved.

See also: 
Igor’s tip of the week #27: Fixing the stack pointer5
Decompiler Manual: Failures and troubleshooting)6
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#148:  Fixing “call analysis failed”

This error is not very common but may appear in some situations. 

Such errors happen when there is a function call in the code, but the decompiler fails to convert it to a high-level function 
call, e.g.:

1.	the target function’s prototype is wrong;
2.	the decompiler failed to figure out the function arguments: how many of them, or how exactly they’re being passed 

to the callee;
3.	the usage of the stack by the call does not make sense.

Let’s look at some examples where it happens and how to fix it.

Wrong function info
The first action on seeing the error should be to inspect the address mentioned and the surrounding code. For example, 
here’s the snippet around the address in the first screenshot:

.text:0804D5CD                 push    [ebp+var_10]

.text:0804D5D0                 push    offset sub_804D6E8

.text:0804D5D5                 push    [ebp+var_28]

.text:0804D5D8                 push    offset sub_804CF24 ; oset

.text:0804D5DD                 call    sub_8058FF0

.text:0804D5E2                 mov     edx, [ebp+var_14]

.text:0804D5E5                 or      dword ptr [edx+28h], 10h

.text:0804D5E9                 mov     eax, [ebp+var_18]

.text:0804D5EC                 add     esp, 10h

.text:0804D5EF                 test    eax, eax

.text:0804D5F1                 jz      loc_804D1D3

.text:0804D5F7                 sub     esp, 0Ch

.text:0804D5FA                 push    [ebp+var_18]

.text:0804D5FD                 call    sub_8055A0C

At the first glance, there doesn’t seem to be anything unusual: four arguments are pushed on the stack before calling the 
function sub_8058FF0. However, if we go inside the function and try to decompile it, we get another error:

Also, the header of the function looks strange:

.text:08058FF0 ; =============== S U B R O U T I N E =======================================

.text:08058FF0

.text:08058FF0 ; Attributes: bp-based frame

.text:08058FF0

.text:08058FF0 ; int __cdecl sub_8058FF0(sigset_t oset)

.text:08058FF0 sub_8058FF0     proc near               ; CODE XREF: sub_804CF6C+671↑p

.text:08058FF0                                         ; sub_804F798+126↑p ...

.text:08058FF0

.text:08058FF0 var_48          = dword ptr -48h

.text:08058FF0 oset            = sigset_t ptr -38h

I.e. the function was detected not to take four arguments, but one structure by value. While this can indeed happen in 
some cases, the argument is in a wrong location: the local variables area (note the negative offset). 
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1 https://hex-rays.com/blog/igors-tip-of-the-week-42-renaming-and-retyping-in-the-decompiler/ 
2 https://hex-rays.com/blog/igors-tip-of-the-week-51-custom-calling-conventions/
3 https://hex-rays.com/blog/igors-tip-of-the-week-115-set-callee-address/
4 https://hex-rays.com/blog/igors-tip-of-the-week-27-fixing-the-stack-pointer/
5 https://hex-rays.com/blog/igors-tip-of-the-week-27-fixing-the-stack-pointer/ 
6 https://www.hex-rays.com/products/decompiler/manual/failures.shtml

Fixing the function itself is a topic for another post, but a quick fix for the original issue would be to delete the current 
prototype and let the decompiler fall back to guessing the arguments. For this, put the cursor on the function name or its 
first line, then press Y (edit type1), Del, Enter. This will clear the wrong prototype and decompilation should succeed, 
showing the four arguments we’ve seen in the disassembly:

Sometimes the decompiler’s guessing of the prototype still fails, so try to specify one based on the actual arguments 
being passed to the call (look at the assembly around the call). In some cases this may require the __usercall calling 
convention2.

Indirect calls
Instead of the direct function address, indirect calls use a register or a memory location which holds the destination 
address to perform the call. For example, on x86 it may look like one of the following:

call eax 
call dword ptr [edx+14h] 
call [ebp+arg_0] 
call g_myfuncptr

In rare cases, the decompiler may fail to detect the actual arguments being passed to the call, especially if optimizer 
interleaves arguments passed to different calls. In that case, you can give it a hint by adding a cross-reference to the 
actual function being called (if you know it), or a function of the matching type, for example using the Set callee address3 
feature. You should also check that the stack pointer is properly balanced4 before and after each call for stack-using 
calling conventions.
 

See also:
Igor’s tip of the week #27: Fixing the stack pointer5
Decompiler Manual: Failures and troubleshooting6
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#149:  Using symbolic constants in the decompiler

We’ve covered the usage of symbolic constants (enums) in the disassembly1. but they are also useful in the pseudocode 
view.

Reusing constants from disassembly
If a number has been converted to a symbolic constant in the disassembly and it is present in unchanged form in 
pseudocode, the decompiler will use it in the output. For example, consider this call:

.text:00405D72   push    1               ; nShowCmd

.text:00405D74   cmovnb  eax, [esp+114h+lpParameters]

.text:00405D79   push    0               ; lpDirectory

.text:00405D7B   push    eax             ; lpParameters

.text:00405D7C   push    offset File     ; “explorer.exe”

.text:00405D81   push    0               ; lpOperation

.text:00405D83   push    0               ; hwnd

.text:00405D85   call    ShellExecuteW

Initially, it is  decompiled like this:

ShellExecuteW(0, 0, L”explorer.exe”, v136, 0, 1);

However, we can look up2 that nShowCmd’s value 1 corresponds to3 the constant SW_NORMAL, and apply it to the disas-
sembly:            

After refreshing the pseudocode, the constant appears there as well:

ShellExecuteW(0, 0, L”explorer.exe”, v136, 0, SW_NORMAL);

Applying constants in pseudocode
In fact, you can do the same directly in the pseudocode, using the context menu or the same shortcut (M):

Note that there is no automatic propagation of the constants applied in pseudocode to disassembly. In fact, sometines 
it’s not possible to map a number you see in the pseudocode to the same number in the disassembly.

Consider this example from a Windows driver’s initialization routine (DriverEntry):
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1 https://hex-rays.com/blog/igors-tip-of-the-week-99-enums/ 
2 https://learn.microsoft.com/en-us/windows/win32/api/shellapi/nf-shellapi-shellexecutew 
3 https://learn.microsoft.com/en-us/windows/win32/api/winuser/nf-winuser-showwindow
4 https://learn.microsoft.com/en-us/windows-hardware/drivers/kernel/driverentry-s-required-responsibilities
5 https://hex-rays.com/blog/igors-tip-of-the-week-99-enums/
6 https://www.hex-rays.com/products/decompiler/manual/cmd_numform.shtml

We know4 that indexes into the MajorFunction array correspond to the major IRP codes (IRP_MJ_xxx), so we can convert 
numerical indexes to the corresponding constants:

and the pseudocode becomes:

DriverObject->DriverStartIo = (PDRIVER_STARTIO)sub_1C0001840;
DriverObject->DriverUnload = (PDRIVER_UNLOAD)sub_1C0001910;
DriverObject->MajorFunction[IRP_MJ_CREATE] = (PDRIVER_DISPATCH)&sub_1C0001510;
DriverObject->MajorFunction[IRP_MJ_CLOSE] = (PDRIVER_DISPATCH)&sub_1C00011B0;
DriverObject->MajorFunction[IRP_MJ_DEVICE_CONTROL] = (PDRIVER_DISPATCH)&sub_1C0001290;
DriverObject->MajorFunction[IRP_MJ_CLEANUP] = (PDRIVER_DISPATCH)&sub_1C0001070;

However, if we check the corresponding disassembly (e.g by using Tab or synchronizing pseudocode and IDA View), we 
can see that the array indexes are not present as such in the instruction operands:

Another common situation where you can use symbolic constants in pseudocode but not disassembly is swich cases.

See also:
Igor’s tip of the week #99: Enums5
Decompiler Manual: Hex-Rays interactive operation: Set Number Representation6
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When you open a decompilable file in IDA, you get this somewhat mysterious item in the Help menu:

And if you invoke it, it shows an even more mysterious dialog:

So, what is it and when it is useful?

Originally this feature was added to the decompiler to make decompiler bug reporting easier: oftentimes. a decompiler 
issue cannot really be reproduced or debugged without having the original database. However, in some cases sharing 
the whole database is impractical or impossible:

•	Whole database may be very large and difficult to share
•	parts of the database may contain private or confidential information
•	 the rest of the database is not really relevant to the issue and only adds noise

This feature leaves just the current function plus maybe some potentially relevant information in the database. It can then 
be sent to support for investigation and fixing, either by email or directly from IDA via Help > Report a bug or an issue…

See also:
Igor’s tip of the week #39: Export Data1
Igor’s Tip of the Week #135: Exporting disassembly from IDA2
Decompiler Manual: Failures and troubleshooting3

1 https://hex-rays.com/blog/igors-tip-of-the-week-39-export-data/
2 https://hex-rays.com/blog/igors-tip-of-the-week-135-exporting-disassembly-from-ida/
3 https://www.hex-rays.com/products/decompiler/manual/failures.shtml#report
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#151: Fixing “function frame is wrong”

Previously1, we’ve run into a function which produces a cryptic error if you try to decompile it:

In such situations, you need to go back to disassembly to see what could be wrong. More specifically, check the stack 
frame layout2 by double-clicking a stack variable or pressing Ctrl– K.

On the first glance it looks normal:

However, if you compare with another function which decompiles fine, you may notice some notable differences:

This frame has two members which are mentioned in the top comment:

Two special fields “ r” and “ s” represent return address and saved registers.

They’re absent in the “bad” function, so the whole layout is probably wrong and the function can’t be decompiled reliably. 
On closer inspection, we can discover that the structure sigset_t (type of the variable oset in sub_8058FF0) is 0x80 
bytes, so applying it to the frame overwrote the special members. You can also see that the variable crossed over from 
the local variable area (negative offsets) to the argument area (positive offsets), which normally should not happen.

Fixing a bad stack frame
Although you can try to fix the frame layout by rearranging or editing the local variables, this won’t bring back the special 
variables, so usually the best solution is to recreate the function (and thus its stack frame). This can be done by undefin-
ing (U) the first instruction, then creating the function (P). A quicker and less destructive way is to delete just the function 
(Ctrl– P, Del), then recreate it (P). Normally this should recreate the default frame then add local variables and stack 
arguments based on the instructions accessing the stack:
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1 https://hex-rays.com/blog/igors-tip-of-the-week-148-fixing-call-analysis-failed/ 
2 https://hex-rays.com/blog/igors-tip-of-the-week-65-stack-frame-view/ 
3 https://hex-rays.com/blog/igors-tip-of-the-week-148-fixing-call-analysis-failed/
4 https://hex-rays.com/blog/igors-tip-of-the-week-65-stack-frame-view/
5 https://www.hex-rays.com/products/decompiler/manual/failures.shtml

And now the function decompiles fine:

Some code is wrong because the function prototype still uses wrongly detected sigset_t argument. This is easy to fix – 
just delete the prototype (Y, Del) to let the decompiler guess the arguments:

See also:
Igor’s Tip of the Week #148: Fixing “call analysis failed”3
Igor’s tip of the week #65: stack frame view4
Decompiler Manual: Failures and troubleshooting5
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#152: Force-creating functions

Occasionally, especially when working with embedded firmware or obfuscated code, you may see an error message 
when trying to create a function (from context menu or using P hotkey):

There can be multiple reasons for it, for example:

1.	some code has been incorrectly converted to data and the execution flows into it;
2.	the function calls a non-returning function1 which hasn’t been marked as such, so IDA thinks that the execution 

flows into the following data or undefined bytes;
3.	the function uses an unrecognized switch pattern2;
4.	the function calls some function which uses embedded data after the call, but IDA tries to decode it as instructions;
5.	code has been obfuscated and IDA’s autoanalysis went down a wrong path.

You can double-click the address indicated to jump there and to see if you can identify the issue and try to fix it, but it 
can take a long time to figure out.

Functions are required to use some of IDA’s basic functionality such as graph view3 or the decompiler4.

Forcing IDA to create a function
Whatever the reason of the error, you can still create a function manually if you can determine its bounds using your best 
judgement. For this, the anchor selection5 is the most simple and convenient way:

1.	while staying on the first instruction of the function, use Edit > Begin selection, or press Alt– L;
2.	navigate down to the function’s end (e.g. look for a return instruction or start of the next function);
3.	press P (Create function)

Note that the function created this way may have all kinds of issues, e.g. disconnected blocks in the graph view, JUMPOUT 
statements in pseudocode or wrong decompilation, but at least it should allow you to advance in your analysis.

1 https://hex-rays.com/blog/igors-tip-of-the-week-126-non-returning-functions/ 
2 https://hex-rays.com/blog/igors-tip-of-the-week-53-manual-switch-idioms/ 
3 https://hex-rays.com/blog/igors-tip-of-the-week-23-graph-view/
4 https://hex-rays.com/blog/igors-tip-of-the-week-40-decompiler-basics/ 
5 https://hex-rays.com/blog/igor-tip-of-the-week-03-selection-in-ida/
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#153: Copying pseudocode to disassembly

When using the decompiler, you probably spend most of the time in the Pseudocode view1. In case you need to consult 
the corresponding disassembly, it’s a quick Tab away. However, if you actually prefer the disassembly, there is another 
option you can try.

Copy to assembly
This action is available in the pseudocode view’s context menu when right-clicking outside of the decompiled code:

Because the decompiler uses disassembly comments2 for this feature, it warns you that the action will destroy any exist-
ing ones:

After confirmation, comments with pseudocode lines are added to the disassembly:

You can see these comments even in the graph view3:
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1 https://hex-rays.com/blog/igors-tip-of-the-week-40-decompiler-basics/
2 https://hex-rays.com/blog/igor-tip-of-the-week-14-comments-in-ida/
3 https://hex-rays.com/blog/igors-tip-of-the-week-23-graph-view/
4 https://www.hex-rays.com/products/decompiler/manual/cmd_copy.shtml
5 https://hex-rays.com/blog/igor-tip-of-the-week-14-comments-in-ida/

In fact, you can make use of this feature even without switching to pseudocode. While in disassembly, use Edit > Com-
ments > Copy pseudocode to disassembly, or the shortcut / 

Note that unlike pseudocode itself, these comments are static and do not change when you make changes in the 
pseudocode (e.g. rename variables). To update the comments, you need to trigger the action again.

In case you changed your mind and want to clean up the function, use “Delete pseudocode comments” from the same 
menu.

 
See also:
Hex-Rays interactive operation: Copy to assembly4
Igor’s tip of the week #14: Comments in IDA5
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#154: Synchronized views

When working with a binary in IDA, most of the time you probably use one of the main views: disassembly (IDA View) 
or decompilation1 (Pseudocode). If you need to switch between the two, you can use the Tab key – usually it jumps to 
the the same location in the other view. If you want to consult disassembly and pseudocode at the same time, copying 
pseudocode to disassembly2 is one option, however it is of rather limited usefulness. You can dock3 two view side-by-
side and Tab between them, but this can be rather tedious.

Synchronizing views
To ensure that position in one view follows another automatically, select it in the “Synchronize with” context submenu.

Now, if you place disassembly and pseudocode side-by-side, the cursor position will be synchronized automatically 
when navigating in either window. The matching lines are also helpfully highlighted. Because a single pseudocode line 
may be represented by several assembly instructions and vice versa, the match is not one-to-one.

Any view which displays information tied to addresses can be synchronized to another. As of IDA 8.3 these include:

1.	Disassembly (IDA View)
2.	Decompilation (Pseudocode)
3.	Hex View4

You can even sync more than two views at the same time, although this has to be done in a specific sequence. For exam-
ple:

1.	Synchronize IDA View-A and Pseudocode-A
2.	Synchronize Hex View with the other pair

Synchronizing to registers in debugger
During debugging, an additional feature is available: synchronizing a view to a register value. You may have noticed that 
during debugging the default disassembly view changes name to IDA View-EIP (IDA View-RIP for x64 or IDA View-PC 
for ARM). This is because cursor follows the current execution address stored in the corresponding processor register.
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1 https://hex-rays.com/blog/igors-tip-of-the-week-40-decompiler-basics/
2 https://hex-rays.com/blog/igors-tip-of-the-week-153-copying-pseudocode-to-disassembly/
3 https://hex-rays.com/blog/igors-tip-of-the-week-22-ida-desktop-layouts/
4 https://hex-rays.com/blog/igors-tip-of-the-week-38-hex-view/ 
5 https://hex-rays.com/blog/igors-tip-of-the-week-22-ida-desktop-layouts/ 
6 https://hex-rays.com/blog/igors-tip-of-the-week-38-hex-view/
7 https://hex-rays.com/blog/igors-tip-of-the-week-153-copying-pseudocode-to-disassembly/

You can also synchronize the default Hex View to a register, or open additional views if you need to follow a specific one. 
For this, use “Open register window” from the context menu on the register in the registers view.

See also:
Igor’s tip of the week #22: IDA desktop layouts5
Igor’s tip of the week #38: Hex view6
Igor’s Tip of the Week #153: Copying pseudocode to disassembly7
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#155: Splitting stack variables in the decompiler

We’ve covered splitting expressions1 before, but there may be situations where it can’t be used.

For example, consider following situation:

The decompiler decided that the function returns a 64-bit integer and allocated a 64-bit stack varible for it. For example, 
the code may be manipulating a register pair commonly used for 64-bit variables (eax:edx) which triggers the heirustics 
for recovering 64-bit calculations. However, here it seems to be a false positive: we can see separate accesses to the 
low and high dword of the variable, and the third argument for the IndexFromId call also uses a pointer into the middle of 
the variable.

One option is to hint to the decompiler that the function returns a 32-bit integer by editing the function’s prototype (use 
“Set item type” or the Y shotrcut on the first line). 

Often this fixes the decompilation, but not here:

We still have a 64-bt variable on the stack at ebp-10h, so it’s worth inspecting the stack frame2. It can be opened by 
pressing Ctrl-K in disassembly view or double-cliking stack variable in disassembly or pseudocode:

We see that there is a quadword (64-bit) variable at offset -10. it can be converted to 32-bit(dword) by pressing D three 
times. Another dword can be added in the same manner at offset -C:

After refreshing pseudocode, we can see improved output:



Igor’s tip of the week - season 03

https://hex-rays.com/blog/igors-tip-of-the-week-155-splitting-stack-variables-in-the-decompiler/

02 Sep 2023

#155: Splitting stack variables in the decompiler

1 https://hex-rays.com/blog/igors-tip-of-the-week-69-split-expression/ 
2 https://hex-rays.com/blog/igors-tip-of-the-week-65-stack-frame-view/
3 https://hex-rays.com/blog/igors-tip-of-the-week-65-stack-frame-view/
4 https://hex-rays.com/blog/igors-tip-of-the-week-42-renaming-and-retyping-in-the-decompiler/

There’s only one small issue: v5 became an array. This happened bcause passing an array or an address of a single 
integer produces the same code but there was a gap in the stack frame after var_C, so the decompiler decided that it’s 
actually an array. If you’re certain that it’s a single integer, you have the following options:

1.	Edit the stack frame again and define some variables after var_C so that there is no space for an array.
2.	retype v5 directly from the pseudocode (use Y and enter ‘int’).

Now the pseudocode looks correct and there is only one variable of correct size:

Note that in some cases a variable passed by address may be really an array, or a structure – in case of doubt inspect 
the called function to confirm how the argument is being used.

See also:
Igor’s tip of the week #65: stack frame view3
Igor’s tip of the week #42: Renaming and retyping in the decompiler4



Igor’s tip of the week - season 03

https://hex-rays.com/blog/igors-tip-of-the-week-156-command-line-options-for-firmware-loading/

08 Sep 2023

#156: Command-line options for firmware loading

Firmware binaries often use raw binary file format without any metadata so they have to be loaded manually into IDA. 
You can do it interactively using the binary file loader1, but if you have many files to disassemble it can quickly get boring. 
If you already know some information about the files you’re disassembling, you can speed up at least the first steps. For 
example, if you have a binary for big endian ARM, which should be loaded at address 0xFFFF0000, you can use the 
following command line:

ida -parmb -bFFFF000 firmware.bin

The-p switch tells IDA which processor module to pre-select. You can see the available names for different processor 
types in the second column of the processor selector pane in the load dialog:

The -b switch specifies the load base to be used, however due to IDA’s origins as a DOS program, the value needs to be 
specified in paragraphs (16-byte units), so we have to omit the last hexadecimal zero.

In case the file is recognized by IDA as some specific format, it will be used instead of the plain binary, but the processor 
specified will be retained if possible. For example, since IDA 8.32 the firmware for Cortex-M processors is usually recog-
nized as such out-of-box:

If you prefer to have the file loaded as plain binary or another non-default format, you can force it using the -T switch 
with the unique prefix of the preferred format name:

ida -parm -b800400 -Tbinary firmware.bin

(-Tbin would also work)

See also:
IDA Help: Processor Type3
IDA Help: Command line switches4
Igor’s tip of the week #41: Binary file loader5

1 https://hex-rays.com/blog/igors-tip-of-the-week-41-binary-file-loader/
2 https://hex-rays.com/products/ida/news/8_3/ 
3 https://www.hex-rays.com/products/ida/support/idadoc/618.shtml
4 https://www.hex-rays.com/products/ida/support/idadoc/417.shtml
5 https://hex-rays.com/blog/igors-tip-of-the-week-41-binary-file-loader/




